Ubuntu 16.04 Audacity 2.1.2

I’m facing this issue since fresh install off ubuntu. My mic work well everywhere (and headphones, speakers too), but not on audacity. (picrel)

And devices list…

Default recording device number: -1
Default playback device number: -1
No devices found

My audacity version is 2.1.2. It will be good if this can be fixed.

What mic / headphones / speakers do you have and how are they attached to the computer?

Have you tried rebooting the computer?

I’m using Samson Go Mic for USB and Audio Jack headphones. On Ubuntu 14.04 and windows worked fine.

Have you installed PulseAudio Volume Control (pavucontrol)? Sometimes that helps.

Is some application or service taking exclusive control of the built-in sound card? If so then PulseAudio won’t get access and Audacity won’t see any devices through ALSA either.

Did you connect the USB mic before launching Audacity? Otherwise you have to use Transport > Rescan Audio Devices.


After installing pavucontrol nothing changed, same results. (do i have reboot?)

Nothing changed… It gives me error when i want to record
Error while opening sound device. Please check the recording device settings and the project sample rate.

Open PulseAudio Volume Control and look in the “input Devices” and “Output Devices” tabs. Are any devices shown there?

@steve yes, like in ALSAMIXER

@steve yes, my devices (in other apps mic works perfectly)

You must connect the mic before launching Audacity, as we said.

Where did Audacity 2.1.2 come from?

Is this Ubuntu Studio?

This is only likely to be two problems - some other application or service has exclusive ownership of the audio device, as already stated, or there is some permission problem. It does not sound like a permission problem if other applications can use the sound device. Try shutting down those applications that can access the device.

Is pulse in the audio group? Type this in a terminal and hit ENTER on your computer keyboard:

getent group audio


heres my output, yes

My ubuntu is 16.04 LTS

That looks normal.

You did not tell us where you got Audacity from. If you built it yourself you may not have built it correctly.

I would shut down all other applications that are using your sound card. Open System Monitor and shut down any audio daemons that may be running. Then Audacity should be able to use the sound card.

Or backup your data to a USB drive or similar and reinstall Ubuntu into a fresh partition on your computer. You said it was a fresh installation, but I can tell you that a few people have had messed up audio in 16.04 when they upgraded directly over a previous Ubuntu version. Ubuntu no longer recommend overwrite installations.


@gale I SAID it’s pure installation. Again, after shutting all apps that might using audio nothing changed. Should i reinstall it? I’m using apt package manager to install it.
Also I’m using cinnamon 3.0.

Theres a warning
(audacity:16023): IBUS-WARNING **: Unable to connect to ibus: Could not connect: Connection refused

It’s up to you if you reinstall Audacity. I doubt it will make any difference, from your description. “Something” is preventing Audacity accessing any devices so you need to find what that something is.

If you do reinstall the 2.1.2 package supplied by Ubuntu, first delete the ~/.audacity-data/ folder so that the new installation has clean settings.

If there is a glitch in the 2.1.2 package supplied by Ubuntu, remove it and try the 2.1.2 Ubuntu Handbook PPA instead: https://launchpad.net/~ubuntuhandbook1/+archive/ubuntu/audacity.

The IBUS-WARNING is “normal”. IBus a multi-lingual input method not related to audio.


Reinstalling after removing this repo didn’t change nothing.

Exactly what did you reinstall? You could uninstall the Ubuntu 2.1.2 repo version and install the 2.1.2 Ubuntu Handbook version.

You could open a terminal, type:

aplay -l

hit ENTER and post what that says. See aplay man page.

You may be better asking on the Ubuntu forums. There is a reason Audacity sees no devices. There may be a sound daemon we don’t know about which you enabled by accident.


**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: GoMic [Samson GoMic], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

What version of Audacity did you reinstall, exactly?

You have playback devices.


arecord -l

should show you recording devices.

If Audacity still does not see those devices, type this in a terminal and hit ENTER

ps -A > ps.txt

This saves a list of your running processes to the file “ps.txt” in the folder the command prompt was at.

Post the file “ps.txt” on the Ubuntu forums and ask if any of those processes would prevent pulse accessing the sound device.


I found this old thread when trying to find solution to my problem which seems to be the same as
“dracconi”;s. All the details are the same on my set up too.
Is there any further info in this matter?

Test your Samson Go mic on another computer.