"type": "Error_Opening_Project"


My aup3 file doesn’t open in Audacity and throws an error. The error appeared after restarting the Mac.

How to fix a file? There’s a new podcast release in it. This is very important to me.

“timestamp”: 1655108974,
“event_id”: “2a900ee1d1454b55917902e58e0b40ef”,
“platform”: “native”,
“release”: “audacity@3.1.3”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Macintosh”,
“version”: “10.16.0”
“exception”: {
“values”: [
“type”: “Error_Opening_Project”,
“value”: “Failed to open database file:\n\n/”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “11”,
“sqlite3.context”: “DBConnection::ModeConfig”,
“sqlite3.mode”: “PRAGMA .page_size = 65536;VACUUM;”,
“log”: “11:29:34: DBConnection SetDBError\n\tErrorCode: 11\n\tLastError: Failed to set page size for database /\n\tLibraryError: database disk image is malformed\n11:29:34: DBConnection SetError\n\tErrorCode: 11\n\tLastError: Failed to open database file:\n\n/\n\tLibraryError: (11): database disk image is malformed\n”

So you have an error code 11, which indicates a corrupt sqlite3 .aup3 project database file. To recover from this error see the first post in this thread: Corrupt or Otherwise Broken Audacity Project Recovery

Hi jademan!

Now I’m happy because I was able to fix my file.

There is no way to fix this error for my Mac, but there is for Windows. So I re-uploaded the file to Windows and fixed it, as it says here https://forum.audacityteam.org/t/corrupt-or-otherwise-broken-audacity-project-recovery/64162/1 and it worked!

You are doing a very great job. I was desperate this morning, and now I can work with my podcast again. Thank you for what you are doing, thank you for your help and thank you for new knowledge :sunglasses:

Have a nice day!

I’m glad this worked for you! Thanks for the report. :smiley: