Troubles with Audacity and new Macbook Pro with High Sierra.

Hi friends,

For years I have used a Mid-2009 MPB that currently has OSX El Capitan 10.11.6 on it to make recordings using Audacity. Version 2.1.0 is currently on that machine. I have always saved my projects as: “Name - YYYY/MM/DD Venue Name”. I have never had any problems saving or exporting projects or using slashes in project filenames.
I recently replaced my MBP to a mid-2016 model with OSX 10.13 High Sierra. I initially installed Audacity 2.1.3 and ended up with all kinds of problems opening, saving, and exporting my projects due to my previous file naming format. I couldn’t open any project by double clicking on it or I would just get a blank project. With Audacity already open, I was able to open my projects by using the “File, Open” method, but could not save again using the same file name, because of the slashes I assume. The same applied to exporting projects as well. No slashed allowed.

I next uninstalled Audacity completely and tried the 2.2.0 RC Version. I ended up with all of the same problems.
I tried uninstalling Audacity completely again, and this time went back to 2.1.1. All of the above problems seem to be gone, and everything seems to be running fine. I can load my projects by double-clicking, I can have more than one project open at the same time in separate windows, I can export and all, even with my slash-containing file names and all that.

The one singular problem that I have now is that Audacity will only stay in the dock only until I reboot the machine, at which point the Audacity icon becomes a question mark and nothing happens when I click on it. I have tried adding and removing to the dock many times, and I am making sure that the dock icon is pointing to the right place and I still get a question mark after reboot.

Any advice would be greatly appreciated. I already know that using slashes in file names is not an advised practice but I have hundreds of projects that I have saved this way and would like to avoid renaming everything.

I am at this point mostly interested in being able to keep Audacity in the dock and not having it become a question mark after every reboot.


Audacity will only stay in the dock only until I reboot the machine,

Should we be worried that you are restarting the machine all the time? Most Mac users have to be poked repeatedly with a stick to stop what they’re doing long enough to restart, sometimes over many months.

When you reinstalled Audacity, did you go into the system and delete the config file? Audacity keeps that around even during reinstalls so you don’t have to put all your configurations and settings in again. This is less useful if one of your configurations or settings is broken.

Go > Go To Folder > ~/Library/Application Support > drag the audacity (lower case intentional) folder to the trash. Next time you restart Audacity, it should realize it’s gone and rebuild it.

I know this isn’t likely, but are you running Audacity from inside the DMG? Did you use the click and drag graphic to actually install Audacity? I don’t do it that way, I drag the installer graphic into the /Applications folder. Both work.

because of the slashes I assume.


The top one is a date (in the US).
The bottom one is the name of a file called “17” inside a folder called “30” inside a folder called “10.”

Sometimes the system can’t tell, either and it can throw an error. Macs are usually better at that than the other machines, but it’s still just asking for trouble.

Today is 2017-10-30. That’s an ISO compatible date.


You shouldn’t be worried about my restarts, I have only been doing it repeatedly for the sake of testing this issue.

I went in and deleted the config file after deleting each installation in order to start from scratch.

I am definitely not running from inside the DMG. Each time I have reinstalled any version of Audacity I drag the .app file into my Applications folder.

On my old machines I never had any problems with dating such as 2017/10/30. Audacity 2.1.3 has a problem with this, as well as 2.2.0 RC

What has seemingly worked for me is to install Audacity 2.1.1 (from scratch after removing all traces of Audacity in /Library/Application Support).
This DMG had me drag an entire folder named Audacity into my Applications folder.

I determined that the dock problem was stemming from the fact that the file was in a folder within /Applications and not alone in /Applications.

Once I dragged out of /Applications/Audacity and put it right into /Applications, the dock question mark issue seems to have stopped and all seems to be functioning as is was on my other machine.

Weirdness I know, but it’s working the way I want it to, saving projects and exporting files as 2017/10/30 and all.

It’s unfortunate that I can’t get new releases of the software to work the way I want it to, but this will have to do for now.

It does everything that I need it to do now so I will just leave it as it is and not be frustrated anymore.

the file was in a folder within /Applications and not alone in /Applications.

That’s how I install multiple different versions of Audacity for testing. What did you call that folder? Rules for folder naming are pretty strict.
Screen Shot 2017-10-31 at 03.40.04.png

Well I’m puzzled here - I have a Macbook Pro running macOS 10.13 High Sierra (was originally El Capitan and upgraded through a few Sierras) and I don’t see this problem with either 2.1.3 or 2.2.0 RC1 :confused:

I don’t normally place Audacity in the dock for launch because, like Koz, working on Audacity QA/testing I always have several different versions in my Applications folder at all times and launch from there.

So I tried with 2.1.3 and 2.2.0 RC1 dragging a copy of the Audacity icon from the Applications folder to the dock - and rebooting the Mac. With both versions the Audacity icon is displayed properly in the dock (not a question mark) - and Audacity can be launched. I conducted these tests with no launch of Audacity before reboot and with Audacity launched before reboot - all four use cases were ok. So I remain puzzled by the behavior on your Manbook


Update: I have a very similar file structure to Koz

I know, it’s very strange to me and I can’t figure out the reasoning as to why it’s working properly only when configured this way. The folder within /Applicactions is simply called /Audacity.

Maybe later I will experiment again and trash the installation again completely and start over with 2.2.0 RC just for the heck of it to see what happens.