Timer Record Problem

Deleted old version / downloaded latest version of Audacity 4/18/2018 to my Windows 10 laptop - activated timer record function and while it started on time, it did not shut off at the selected time which was 2 hours and 8 minutes from start…I had to force a stop with Task Manager. I also had this same problem with the earlier version of Audacity. Is there a fix or setting change I’ve missed?

This is a long-standing bug that we know about: http://bugzilla.audacityteam.org/show_bug.cgi?id=42

It only happens very occasionally and no-one can define a set of steps to make it happen - thus it is listed as a “moonphase” bug.

I have only experienced it once over several years: http://bugzilla.audacityteam.org/show_bug.cgi?id=42#c29 -
I use Timer Record very regularly (once or twice every week) and apart from that one instance it has worked perfectly.

We would be interested to know if this happens every time on your machine - or only just occasionally.


Got a new computer running Windows 10 Pro workstation 1709, and installed 2.2.2. For the two times I used timer record, it did not stop. I never had a problem on the old computer. Used task manager to stop it, then recovered the project.
But this last time, after recovery, I then ran a silence finder, and saved the project. No save progress bar popped up, looked like Audacity froze, but a few minutes later the project had been saved.
Then I tried to export multiple, and again no dialog window popped up, Audacity froze.
Could there be a problem with dialog windows not getting the focus? I can’t see if there is a window behind the main Audacity window because it is frozen, any click on the main window just gives a warning bell. All other windows/tasks seem fine.
Again I killed it with task manager, recovered the project (warning about orphan files was ignored), tried to save multiple again, and it worked.
So it gets there eventually, just very awkward.
To help with debug, in the same Audacity window that just saved multiple, I asked for a 1 minute timer record. The timer window pops up and says elapsed time=0, time remaining=0. It records past 1 minute, click on the stop button, window pops up to ask if I really want to stop, click on yes and the window goes away, but nothing happens. Time for task manager.

Update on previous post: Don’t know if this affects timer record, but all the other issues were due to dialog windows being opened off-screen. I can press Alt-Tab Window shortcut repeatedly to select the hidden window, then Alt-Space to get the move option, and move the window back on screen with arrow keys. Every dialog opened just beyond the upper left corner. But after moving a bunch one by one, I finally closed Audacity, reopened, and now the dialog windows open on top of the main Audacity window. Just needed a clean exit for window locations to be saved?
For the developers, the new computer has dual 4K screens, that may have started this Window confusion.
Then I tested timer record, asked for 1 minute, and exact same events, elapsed time=0, time counters do not move, try to stop the recording after 2 minutes and the stop button window will not close, hangs up and is greyed out. Task manager kill.
Reopened Audacity, tried a 1 minute timer record with auto save/quit Audacity, and no success. Elapsed Time counted up to 12 seconds, then stopped. Recording did not stop, Audacity did not exit. Stop recording window hangs up. Task manager kill.
I will keep trying every month or so, maybe the issue will not be permanent.

Thanks geneware, I will transfer your reports to the bug thread - the developers tend not to visit the Forum (but they do look at the bug reports)


Yes, it happens every time I use the Timer record function - and the same was true before I updated to the latest version of Audacity…did the update on 4.18.18. I have no problem exporting the file as an mp3 or saving the .au file. I’m just stymied as to why the timer record function does not stop at the pre-determined stop time.

thanks sleepy john, I have added your comments to the bug thread - and alerted the Release Manage about this thread.


sleepy john,

I’ve been discussing this bug with one of the developers, he still doesn’t understand why this happens, but he has his suspicions and has an idea for a change to the code that may make this problem go away.

If he develops such a “fix” would you be prepared to test it for us - as you are one of the two users for whom this seems to happen consistently?



I have posted about the same issue in the past. If the developer is willing to take the time to try to fix this issue some of us are having with the timer, I will be willing to run test for him as well.


Thanks for your efforts! Yes, I’d be interested in testing a potential fix - though I’m not the most computer-savvy user on the planet! To review, the timer function starts on time, but doesn’t stop on time. This occurs when I opt to take no action at the end of the session or if I choose to automatically save the recording. Thanks!

Hi Sleepy John,

the developer involved is busy for most of the next week so it may be next weekend before we can provide a test build.

It will just be a link for a download of the test build, just like a normal install - and then it’ll be just down to using that Audacity as normal - on Timer Record.

Thanks for responding,

updated to the latest version of Audacity…did the update on 4.18.18.

It’s super handy if you called out the three-number Audacity version. It’s completely possible to get the wrong or bad Audacity version even with the events and conditions in your post.

The current Audacity version is 2.2.2 and you can get it from https://www.audacityteam.org/

There is an additional consideration. Audacity puts Settings and Preferences in a different place than the program. Reinstalling Audacity doesn’t reset audacity. To completely reset Audacity in Windows, there is a tick mark at install. Mac and Linux, you have to go into the operating system and delete them.


My fuzzy impression reading these posts is Audacity Timer Record does not fail. Audacity itself fails and starts blowin’ spit bubbles.

Also this sounds vaguely familiar from school (sometime in the paleolithic). An event timer has to be supervisory and not a normal activity command. If it depends on multiple programming moons and stars lining up to succeed, that’s a recipe for a moon-phase bug.

If that’s not enough metaphors, I can do better.


I suspect you’re right Koz - and James suspects so too, but he can see no underlying cause in the underlying timer mechanisms that Timer Record rests upon - he does have some ideas for a workaround inthe app which we are planning to test in the next wek or so.

It’s very useful that we have finally found two users for whom TR fails extremely consistently - and that both of those two users have kindly offered to help us test the patch.


Hi, I have had the timer record issue for many years exactly as it is written up in the bug report (Win10 and upgraded over old version to 2.2.2). I will uninstall and try to remove all references to the app on my machine. Then reinstall. I’ll update once completed. If the issue persists, I ready and willing to help test the patch. -mike

Well uninstalling and cleaning the registry of every reference I could find and then reinstalling did not help. Interestingly, I installed it on another Win10 desktop and the Timer Record feature works as expected.

Tnaks for the offer Mike - much appreciate

There may be a little delay in getting the test patch out as the developer involved fell and hurt his wrist last week and is having problems typing :frowning:


Brand new to the forum. I also experience this problem with the Timer Record. For me, the recording timer stops counting every time I try to use the feature.
As described by others, it simply stops counting, the recording continues, and I am unable to exit the Timer Record window. Only a force quit via Task Manager can stop Audacity.
I do differ in that my CPU/Memory do no spike significantly.

Dell XPS 8700 (BIOS up to date, just updated sound drivers from the DELL website)
Windows 10 (64 bit), updated except for the most recent (2018-06 Cumulative Update for Windows 10 Version 1803 for x64-based Systems)

Audacity 2.2.2
Program build date: Feb 14, 2018
Commit Id: f665e6 of Web Feb 14 02:11:20 2-18 -0500
Build Type: Release build
Compiler: MSVC 18.00.31101.00

Things I’ve tested/tried to do to remedy:
Tested recording (non timer) - works properly.
Adding a new stereo track prior to starting timed record. No change, timer still freezes.
Tested recording stream versus recording local file (in both WMP and iTunes), no change in behavior.
Ran Audacity (and media players - WMP and iTunes), as admin to see if permissions were an issue. Double checked directory permissions on Temp file directory as well.
Added Audacity to Norton Internet Security’s Items to Exclude from Auto-Protect, SONAR and Download Intelligence Detection. No change.
Turned off Norton Internet Security Real Time Protection. No change.

Adjusted project Hz rate - did impact length of time prior to timer freeze. Lower Hz rate did initially seem to (loosely) correlate to increase in recording length prior to freeze. The more I tested that, the less sure I was that it was correlated though.
Adjusted buffer (larger and smaller) - no discernible change in behavior/length of time until freeze.
The one anomaly I observed was with Hz set to 16000, buffer 2000, and Audacity and iTunes both running as admin, it recorded until 19 seconds then froze; then the timer jumped to 27 seconds, then froze for good.
All other attempts, the timer stopped somewhere between 6 and 20 seconds (most commonly centered on 15) and did not resume.

I think that’s everything, if anyone needs more details (or another run through with different settings) let me know.
I’m very happy to help troubleshoot more as well if needed, I’m a programmer (primarily VB) and am comfortable doing just about anything necessary to get a program working as intended :wink:

I just installed Audacity 2.2.2 on another Windows 10 machine that is has a minimal amount of applications installed (Chrome, Firefox, two Remote/VPN related apps), and the Timer Record function works as intended.
So it’s definitely a machine specific issue in my case, not the Audacity build.

The initial install is on my dev machine which has countless installs related to desktop dev/database work, so I’m not sure what the conflict will be. I’ll start looking at the libraries used in Audacity to see if there are any known conflicts or dependencies that are needed.

Will post back with any findings…

I tested the 2.3.0-alpha-52 version made available by waxcylinder:
Ran a 5 minute timer record with auto save/exit. Everything worked.
Ran my old audacity version 2.2.2, timer record failed as usual.
Ran the alpha version with a 2 minute timer record, no auto save. It worked.
Bug fix looks good!