Timeline bar not moving, track not recording! [SOLVED]

Windows 7 Ultimate 64-bit.
Audacity 2.0.6

Basically, I have an at2020 mic with an m-audio m-track interface. it’s all setup, responding, i know they are working fine. i have used them and recorded with them on Audacity before.

But, it’s been 2-3 days since i used them, opened up Audacity. Everything seems fine. Everything is same as usual. Mic inputs and speaker inputs are all the same as they were before.

When i press record, it automatically brings up an audio track (as it usually would), but now, the time line bar on the track doesnt move like it should and i cant get a waveform, or a recording. that paper thin line/ timer line that sits vertically up the track just does not move from the star of the track.

This has been bothering for the past few hours. i have tried general stuff like changing the inputs, re-plugging everything, restarting my computer, turning off sound activated recording off etc. still nothing? The bar just does not move.

I realise that this fix will most likely be right in front of my eyes, but i just have not figured it out yet.

hope somebody an reply and help me with this.


The input you should be choosing in Audacity Device Toolbar is the M-Track.

Perhaps you should look in Recording Preferences and make sure Audio to buffer is large enough - the default is 100 milliseconds.

Perhaps you should check or replace the USB cable.


Problem solved! :smiley:

I only needed to unplug the USB and plug it back in.

So in conclusion;
If anybody else had this same problem, then do what i did. As that is the fix. If that does now work, then you will need to replace the USB with a new one.





I have the same problem today in December 2023 with Windows 11 and Aud 3.4.1