Sync problem with export multiple


I have a problem exporting multiple tracks, windows XP sp3 Audacity 2.0. The tracks are dragged and dropped tracks and recorded with Audacity tracks too. The recorded tracks have a compensed latency offset, you can see it with the symbol ← in the red circles. With previous version, a simple track/mix and Render on each recorded track before exporting resolved the problem. Now I can’t export all the tracks, together, they are not synchronized! Did I missed domething?



I’ve never actually run into this, but Audacity does not export the blank spots you made with the Time Shift Tool. The time shift appears in the final show assuming you mixed the whole thing down to one track, but not if you export one single track.

I don’t know that there is an easy way around this. Others may drop in.

I guess if you created a silence track under the skipped music track and married those two, then the music track silence would export along with the music…


Here’s two alternative keyboard shortcut sequences:

Method 1:

Method 2:

Both methods select from time=0 to the end of the project in all tracks, and then trim to that selection.
Unfortunately there is no single operation to trim all tracks at time=0, though if you would like to suggest such a feature or some alternative way to export tracks starting at t=0, feel free to post your suggestion on this forum board:

Is the latency correction adjusted to what you want anyway, with leading silence, even if trimmed to time zero ? See if not.

Is the required feature request that Export Multiple has an option not to export before Time Zero?


That would work for me.


Wath a reactive forum, thanks for you answers, I’m going to work but I willl study them this evening.

The time shift appears in the final show assuming you mixed the whole thing down to one track, but not if you export one single track.

Just to be sure (I’m not english native speaker), the time shift is automatically done by this option in preferences and is mandatory for me:


And +1 from me


If you mean mixing a shifted track and a non shifted track with Tracks/Mix and Render (I’m not sure of the exact words, I use a french version), I have checked it, it don’t fix the problem, unfortunatly. But with older versions (like 1.3), it did.

I know the latency of my machine, it’s near 130ms, due to an USB soundcard, I presume.



I have found a workaround. I have notice that if I create a new track (Ctrl-Shift-N) and copy paste in it a time shifted track, the symbol ← (for the time shift) diseapear in the new track, cool. But… I have to delete the latency manually before proceeding to “Export multiple”. It works fine. The best should be that the “Export multiple” do this job itself. An other thing is missing in my opinion: Before proceeding, this option should put the volume of all tracks to 0db and the pan to center. And return to current values after exportation, to preserve the audacity mix, of course


So in effect, export the unmodified audio data from the track rather than “post fader” export.
Yes I can see that being useful.

That should only happen if you place the cursor at or after time zero before pasting.

How about the workaround of selecting the tracks you want to align with time zero then Tracks > Align Tracks > Align with Zero?

It’ was a design decision that render should now preserve audio before time zero. Render also does not now render any white space before the first audio clip as silence, but leaves the white space as it is.

I guess most people probably export multiple or as a mix rather than both?

I could see some command to export pre-fader as being turned on by mistake and then creating complaints.

Would it be more useful to have a command that affected selected tracks “Tracks > Reset Gain and Pan” thus it could be undone?


As Audacity is a “general purpose” audio tool, the usages are very differents. I use it to record and edit compositions and cover that I play. For this, I mix in the same project

-“Regular” waves, that means waves created by other softwares like band in a box, drum machines, sampled rythm sections nd so one. I simply drag and drop them directly in Audacity, it works really fine.

  • Recorded waves, that means time shifted because of the latency.

I am very found of “export multiple” for only one reason, the same as everybody, I guess: To continue to work on the audio project with other audio tools. For instance I like to go in holydays with some packs of waves to mix in my Zoom R16. These waves come from Audacity, it my favorite recorder/editor. To mix waves, I prefer to use tools like Cubase, regarding the lot of non destructive effects, compressors, and so on. That is the reason why “Export multiple” is important for me, and for a lot of musicians, I guess.

I have tested it, it doesn’t seem to resolve the problem, I really will test it again more seriously, I have perhaps missed something.

I think that the exportation should be done on raw waves, that means without volume and pan corrections. If people want to mix with Audacity, the regular way is “Export” and “Export selection”. In my opinion, the “export multiple” should not export muted tracks, The guy between the chair and the keyboard is supposed to know what he is doing. An other way could be to popup a list of all the tracks with a checker for each one, this to select the tracks to export.



I’ve just retry, It “works”, the time shift symbol ← is deleted… But the track stays still shifted with the value of the latency, exactly the same result as the track name “copied” on my screenshot. :confused:

After that, I’ve done a simple test.

I’ve create a click track of 2 bars, 120BPM.
For the length I’ve selected the size of the click track.
I’ve recorded one bar of guitar.
I’ve normailzed the recorded track.
I’ve duplicated it with Ctrl-Shit-N and a copy-paste.

Some analysis:

  • The record is truncated at end with the value of the latency, I’ve loosed a half note.
  • The copied track is shifted with the value of the latency.
  • The only way for me is to cut each recorded track manually before export multiple.

I am an unprofessional musician, but I think that resolving this problem should be a big step towards professionnal usage of Audacity. Here is an exemple of mixing drag and dropped tracks (from “World beat cafe” CD) and time shifted recorded tracks (guitars, bass). Before exporting to Cubase for mixing, I’ve had to cut manually the latency at the begin of each recorded track.



I’m very fond of Export Multiple for the same reason, but such usage is probably not as common as you think. If it was a common user case I would expect there to be a lot more complaints about it.

That does the opposite of what is required.
pfeuh is describing the scenario where latency compensation is set up correctly and the tracks in Audacity are in sync. If the tracks are exported with export multiple and then imported into a new project (or a different DAW) then the tracks are no longer in sync because the “hidden behind zero” section is included at the start of the track.

The workarounds that I posted previously accomplish the required task by trimming all of the tracks to delete any “hidden behind zero” audio. Although the workarounds do the job, they are not obvious or convenient.

A check box in the Export Multiple interface for “Include audio behind time = zero” would be a lot more convenient, though I’m not sure that such an option would actually be required. Is there any reason why audio before time = zero needs to be included in Export Multiple? Wouldn’t it be easier to “always” exclude audio from behind zero from Export Multiple?

:open_mouth: It works! No more “<-” symbol and tracks are synchonized, even after a export/import. :slight_smile: Two days ago, I had tried it, but I had failed… I note the procedure on a reminder, thanks a lot!

When a software doesn’t do what you you want it to do, there are two kinds of reactions: You complain on a forum or a hotline if it’s a professional stuff… Or you switch to another software. I guess the professionals prefer the second solution. Most of people uses Audacity to numerize old tapes or to cut their phone rings in 30 seconds slices, but Audacity can do so much more… I don’t think that “not so much people uses this function” is a good argument to keep the bug. I work on embedded softwares, I can’t say such a thing to the customers, I would be immediately fired. But it’s just an opinion. Well, I’ve just receive my Crumar Mojo, let’s try it! :sunglasses:



Hooray :smiley:

It most certainly can. I’ve used a lot of “professional” audio software, but for a lot of editing tasks Audacity has remained my tool of choice because I can get a lot of stuff done faster and more easily. There are even some tasks that I do in Audacity that can only be done in Audacity (though of course the opposite is also true - there are some tasks where I have to switch to other software).

Absolutely true, but we need to be careful about the word “bug”. A “bug” is an unintended feature or behaviour. In this case Audacity is doing exactly as intended. The argument that you and I have with Audacity is that the intended (and actual) behaviour is not good for the type of work that we do, so changing the behaviour is not a “bug fix” but a “feature enhancement” (which imho would be very worthwhile).

Enjoy your Mojo - it looks cool :sunglasses:

You are right about the word bug, it’s not the good one.



I think too, it’s not common. I expected complaints about render not creating silence from leading white space, leading to desynced export of multiple tracks, but there have not been many complaints. Had there been more complaints, I think there would have been a case for an “Ignore leading white space” checkbox for Export Multiple.

Yes, but I wasn’t sure if the sync was actually correct. It doesn’t look correct with the leading silence in and then pfeuh asked a couple of times about “removing the <-” which made me doubt further .

I can recall several cases where people were exporting multiple tracks for separate (not mix) usage and got tracks behind zero due to latency correction or careless use of Time Shift Tool. I guess this is somewhat more likely to happen with Export Multiple, but really I would find it easier to remember if there was just a preference for all exports to include audio behind zero or not, especially as all renders now preserve it.


Usually when you record just the selected area (which happens when Transport > Overdub is “on”), the recorded length is actually a little longer than the selection - in fact people have been known to complain about that length extension. Please recheck by double-clicking the click track then the recorded track and comparing the length in Selection Toolbar at the bottom.

To compensate for recording finishing “early” because it is behind the playback, I suppose there could be a post-roll of the value of the latency? Meantime, the workaround would be to select a distance equivalent to latency correction past the end of the clip you’re dubbing over.


The len of the click track is 4.000sec. I have recheck the recorded track:

I use Audacity in french, I have tried to uninstall/reinstall in english, I had failed, it could be another topic :confused: I dont find in french menu something like Overdub in Transport menu.
I know that Audacity is a big team, and decisions are not easy to take. In my opinion, a track shifted because of latency should be automaticaly converted to a regular track (that means without the symbol ‘<-’ ) as soon as it is recorded. But I suppose it causes more problems than it solves.