Spitfish Audio Units plugin no workie [SOLVED]

I am having no luck getting Spitfish 1.1 (Audio Units version) to work with Audacity 2 on my OSX 10.6.8 system.

I have installed the Fishfillets.component file in /Library/Audio/Plug-Ins/Components (alongside a file named A52Codec.component, so I feel relative sure I’m in the right place).

When I start Audacity, I expect to see something new in the Effects menu, but I don’t. I have made sure that Audio Units plugins are enabled in the Audacity Preferences. Do I need to do anything else?

Thanks in advance for any help you can give me.

I don’t use Macs but the instructions here: http://audacityteam.org/download/plugins say:
“To install new plug-ins, place them in the Plug-Ins folder inside the Audacity installation folder. On Windows computers, this is usually under “Program Files”. On Mac OS X, it is usually under “Applications”. Restart Audacity, then the Plug-ins will appear underneath the divider in the “Effect”, “Generate” or “Analyze” menus.”

Thanks for replying.

I was going by the instructions that came with the Spitfish download, and also http://audacityteam.org/download/features-1.3-f.php .

No harm trying your suggestion, of course - however, it did not work. I also tried putting the file directly in /Library and ~/Library… still no dice.

Audacity will not load Audio Units plugins from the Audacity plug-ins folder - they must be in the system locations. /Library/Audio/Plug-Ins/Components is the right place.

What does Spitfish say about the component you are trying to use? Is it PPC only? Universal binary? Intel only? I see that the latest change was in 2005, which implies that these might be PPC only.

[later] I downloaded the FishFillets package and it is indeed PPC only.

– Bill

Bill just beat me to it, but the FishFillets plug-ins are very old and the VST versions of them are also for PPC Macs only. So they won’t work on OS X 10.6 (which is an Intel system). The way to check (I think) is by right-clicking > Get Info over the Fish Fillets.component file.

I think your only chance is to install Rosetta then find an audio host (VST or AU) that is a native PPC application rather than a Universal Binary like Audacity. You could try running Audacity under Rosetta, but I don’t think it will work.

If you update to OS X 10.7 then there is no support for PPC programs whatsoever.


That’s correct.

– Bill

Wow, it’s been so long since I came across a PPC-only file that it never occurred to me to check that.

Thanks for the insight, everyone. I guess I need to find some other way to de-ess files. Spitfish was supposed to be the hot tip for that.

I remembered I have one of the original Mac Mini’s (PPC) so I dusted it off and loaded Audacity 2 (which is a UB) on it and also Fishfillets - I now see the Fishfillet plugins in the Effects menu. :slight_smile:

OK, this is just to satisfy my curiosity:

I thought I’d try running Audacity 2 on my Intel Mac using Rosetta, just to see if the Fishfillets plugins would work, but I have no “Open With Rosetta” checkbox when I Get Info. I know it must be a Universal Binary, because the same download (I think it’s the same) runs on the old PPC Mac Mini.

Why is there no Rosetta checkbox?

What are you talking about here - Audacity 2.0 or Spitfish?

Sorry! Audacity.

Interestingly, Get Info for Audacity does not show that it is a UB, but it must be - again, the same download (i.e. downloaded from the same place on the Audacity website) works on the PPC Mac Mini.

I’m confused. :slight_smile:

If you recall, I doubted that current Audacity (as a Universal Binary) was runnable under Rosetta. Rosetta will work with a PPC-only application (like Audacity 1.2.6).


From what I can understand, UB’s can be opened with Rosetta in order to run their PPC side. Look at the attachment for an example.

This is all academic, in any case. I’m not going to try to use Spitfish anymore. I’ve since become convinced that I need to replace my vinyl stylus (and have one on order from Soundsmith).

If you drill down through /Applications/Audacity/Audacity.app/Contents/MacOS/Audacity and right-click > Get Info, that should show you “Universal”.

Universal applications can be configured not to show the “Rosetta” checkbox. If Audacity does not show this checkbox on an Intel Mac running OS X 10.6, I assume we may have done this in order to give better performance (the PPC emulation can make Audacity very slow).


It doesn’t. Again, not that it matters to me - just trying to help you out in case it’s important from your perspective.

Maybe UB’s that are configured not to be open-able by Rosetta don’t say “Universal” .
audacity screen capture.png

On my Mac (OS X 10.7.3) if I open /Applications/Audacity/Audacity.app/Contents/MacOS/Audacity and right-click > Get Info, I see “Universal” for Audacity 2.0.0. But not if I open /Applications/Audacity/Audacity.app .


Ah, yes - same here. Sorry, I missed that detail about the path when I “Got Info” .