Sound Activated Recording 2.1.2 not working properly

I have Windows 7 pro, Audacity 2.1.2, Intel i7. I record mono book reading with the following settings: Overdub & Software playthrough not checked. Latency 100/-130. Sound Activated Recording checked. Sound Activation level -35. I have been using these settings for years. They worked fine on 2.1.1. They do not work on 2.1.2 Once the recording has been stopped by the 2.1.2 software, not at the correct spot but after putting a blank stretch on the recording, it will not start again with any sound. The pause button is indented by the software. I had to go back to 2.1.1 to get the sound activated recording to work again. What am I doing wrong.

Just to flesh it out a little, how are you getting your voice into the computer? Part numbers are good.


If you are using a USB mic, try restarting the computer. There is no known problem with Sound Activated Recording in 2.1.2.


Beyerdynamic MMX 300 headset connected to 2.0 usb. Window 7 Sound window shows recording through USB PnP Sound Device as the Default Device.

I want to emphasize that this headset, usb, computer system has worked recorded flawlessly in ALL other Audacity versions for over 5 years.

I reinstalled 2.1.2 over the correctly working 2.1.1. I opened Audacity and checked if it showed the version 2.1.2. It did. I closed Audacity. I closed all opened programs. I restarted the computer. I waited 5 minutes after Windows showed to be running to have all auto programs and background programs terminated. I opened Audacity 2.1.2. I checked preferences to verify that they were as stated above in the original message. They were. I recorded a test recording. All verbal pauses were recorded as no sound. This was done in a very silent room. The program would continue to record blank no matter how long the pauses were between the vocal inserts and no matter what volume the voice level. The sound did not stop as the preference was supposed to stop. When I tried a 2nd recording it arbitrarily stopped after the 3rd pause and would not restart under any volume of sound. The pause button was depressed by the software.

You may not have a “known problem with Sound Activated Recording in 2.1.2” but there is a problem.

This means that no-one but you can reproduce a problem with Sound Activated Recording.

When recording carries on irrespective of signal level, does your voice record blue waves or is the whole track a flat line?

In case your Audacity settings are corrupted please run the 2.1.2 installer again but be sure to enable the “Reset Preferences” box half way through the installer.

If you would not mind, before launching 2.1.2 after reinstallation, save a copy of the existing “Users<your user name>\AppData\Roaming\Audacity\audacity.cfg” settings file. Please see if you need help finding that file. Please see here for how to attach files:

When you do launch Audacity, confirm you want to reset preferences.

If 2.1.2 still records wrongly with Sound Activated Recording, please quit 2.1.2, run 2.1.1 then confirm if 2.1.1 still records correctly with Sound Activated Recording. If you need 2.1.1 you can obtain a ZIP of it here: which you can just run without uninstalling 2.1.2.

Try this to test if Sound Activated Recording is working in 2.1.2.

  1. Ensure Sound Activated Recording is on.
  2. Generate > Silence, duration 30 seconds.
  3. Click and drag in the generated track from 15 seconds back to time zero, Generate > Tone, amplitude 1.
  4. Double-click in the track to select all of it, not just the first 15 seconds.
  5. Set Audio Host in Device Toolbar to Windows WASAPI.
  6. In the same toolbar, set Recording Device to speakers (loopback) and set Playback Device to your speakers.
  7. Set Transport > Overdub on.
  8. Record. Does the recording pause after 15 seconds?
  9. Stop.
  10. Turn off Transport > Sound Activated Recording
  11. Record. Does the recording carry on after 15 seconds?

Note: On a few machines WASAPI loopback recording may act like Sound Activated Recording and pause when there is apparently no signal from the device. The last two steps above should test if that is the case with your device. If so, and you have stereo mix or what U hear, you could choose that input instead, with any Audio Host.


Connaway, you’re not the only one that’s given up on 2.1.2. There’s been a code change somewhere making plugins and other stuff not work.

If you want to help, please tell us precisely what the “other stuff” is that does not work, with exact steps to reproduce the problem. Did you find a problem with Sound Activated Recording in 2.1.2?

As far as I can see, KeroVee that you were complaining about has never given proper real-time preview in Audacity 2.1.0 or later, but works with standard preview in 2.0.6. MIDI tuning will not work because Audacity does not support MIDI input.


I was only sympathising with Connaway.

There is a chance Connaway may simply need to reset preferences. We don’t know unless they reply.


Well that’s not my experience. I was heavily involved in the alpha testing stages of 2.1.2 and it never really faltered for me - to the extent that I took the risk of using those later alphas for my production work. I have no problems with plug-ins not working either.


I am having the exact same problem as Connaway.

I do appreciate this excellent program, so I hate to complain ;o)

The first thing you should do is upgrade to Audacity 2.2.2, which you can get via the Audacity website:

I am having the exact same problem as Connaway

Are you also recording from a USB headset?

What have you selected as your [u]Recording Device[/u]?

In general… If you set the threshold too high (a small negative dB number) recording may not start.

If you set the threshold too low (a bigger negative dB number) recording may be triggered continuously by background noise (acoustic or electronic noise) and the recording may never stop/pause.

If you can’t find a setting that works (no false-triggers and no misses) then sound activated recording may not be appropriate for your application.