SOLVED Reverb silences the audio

Hey! I’ve never had a problem with reverb before. I’m using a standard preset. no matter how I set the effect, the preview sound fine, but when I add the effect the result is a flat line, as if I had used ctrl+L.

SOLVED: Turns out I had two tracks selected at once. So that effect does not work except on one single track. Just thought I’d post this, in case anyone else should have a problem and go searching for “reverb silence.”

Oh dear. That’s a bug. It “should” work on multiple tracks, but that appears to have broken at some point.
I’ll log it on the bug tracker.

The surprising thing is that the bug appears to have been present for over a year, and you’re the first to mention it! :open_mouth:

I think we usually apply effects to one track at a time.

Good catch Jebbers :sunglasses:


Is this bug fixed yet? I’m on Windows 10, Audacity 2.3.3.
I really don’t want to have to select 10 individual tracks and apply reverb individually one at a time…
This is a task I’m going to be doing repeatedly - having to do it this way will drive me a little nuts…

I’m not sure how long it has been fixed (this topic is nearly 2 years old) but It’s fixed in the current 3.1.3 version: Audacity ® | Downloads

HELP! I am on Windows 10, using audacity 3.1.3 and anything I record is silenced when I use reverb. I have rebooted, and rebooted again, and tried silence at each end of the recording. Until recently I had been using an older version of audacity and had no problems using reverb. What should I be doing to fix this? Thank you.

Does the problem only occur with that one effect?

Works for me on W10 with 3.1.3 (and 3.2.0 alpha test build)


yes, it only seems to be with that reverb. i just finished trying a whole lot of other effects and there is no problem doing so. another thing i have noticed is that i have to “compress” everything i record in order to get any proper volume to my recordings. don’t know if it is related??

Just checking, is it this reverb that you are having the problem with:

It’s normal for recordings to sound much quieter than commercial recordings due to the amount of compression that is usually applied to commercial recordings. See: Loudness war - Wikipedia

. okay- so compression is just something i will need to do. i can handle that. And as for the reverb problem- yes the reverb picture you sent is the reverb option i am referring to. if i apply that to any recording it makes the recording level so low it is silenced.

Please post a screenshot showing all the settings that you are using (or list them).

Hello. I hope my screenshots come through and help explain my problem. Thanks again.
audacity screenshot with random intended reverb settings.png
audacity screenshot with random compression applied.png
audacity screenshot with clapping recorded.png
audacity blank.png

There are two parts to the sound from the reverb effect - there’s the “Dry” sound, which is the original signal (without reverb) and the “Wet” sound, which is the reverberation. The two sounds are mixed together within the effect.

In your settings, both the “Wet” and the “Dry” are turned down to -20 dB (very quiet). Try increasing both to say -6 dB.

Note that Audacity’s Reverb effect provides a number of presets. See:

thank you. that has really helped. i will experiment to see how to tweak it some more.