[Solved] audacity-wxgtk2 3.0.3 do not portuguese language

I’ve been to this forum on other occasions, but again details of my case:

  • I use a distribution based on manjaro Linux
  • From the AUR repository the audacity version is:
creto@creto:~$ pamac search audacity
tenacity-git                                3.0.2.r595.g04609bba0-1     AUR 
    An easy-to-use multi-track audio
    editor and recorder, forked from
audacium-git                                1:2.4.1.r1698.gf785b4e04-3  AUR 
    telemetry free version of audacity
darkaudacity-git                            2.1.3.r1237.gec4838600-1    AUR 
    A program that lets you manipulate
    digital audio waveforms
audacity-git                                3.0.2.r317.g3ebd8d401-1     AUR 
    A program that lets you manipulate
    digital audio waveforms
audacity-wxgtk2                 [Instalado] 3.0.3-1                     AUR 
    Record and edit audio files
audacity                                    1:2.4.1-4                   community 
    A program that lets you manipulate
    digital audio waveforms

audacity-wxgtk2 [Instalado] 3.0.3-1 AUR Record and edit audio files, that said, the audacity version, even though I have all the language packs installed in the distribution, didn’t translate the audacity-wxgtk2 as it should.

Does anyone have any suggestions?

Thank you in advance!

==== EDIT ====

In another distribution that I also use the audacity 3.0.3 package, it also has no translation for another language than english (PCLinuxOS)

Click to enlarge

[cretonews@localhost ~]$ apt-cache policy audacity
  Instalado: 3.0.3-1pclos2021
  Candidato: 3.0.3-1pclos2021
  Tabela de Versão: 
 *** 3.0.3-1pclos2021 0
        500 http://pclinuxos.c3sl.ufpr.br pclinuxos/64bit/x86_64 pkglist
        100 RPM Database
[cretonews@localhost ~]$

T+ = See you later

I investigated this and found a workaround (see also https://aur.archlinux.org/packages/audacity-wxgtk2/):
Edit the file ~/.audacity-data/audacity.cfg, search for the entry [Locale] and set the language:


This seems to be a general bug, the behaviour is also the same if using the official AppImage.

We are not able to provide support for Tenacity now that it is diverging from Audacity. I believe the correct place to report issues with Tenacity is the “Issues” section of their GitHub repository.

The absence of locales other than English in the Audacity 3.0.3 AppImage is currently logged as a bug: https://github.com/audacity/audacity/issues/1382

Thank you @osch I performed the procedures you indicated and my audacity-wxgtk2 is opening in pt_BR now:

Click on image to enlarge

Now it’s time to wait for the guys who are also very good (beast) here from the audacity team to find a definitive solution for that. Thanks also to @steve who was always very friendly with my Brazilian problems here in this forum.

But @steve, I have audacity installed and not tenacity

Best regards,
Paulo Creto

T+ = See you later

Thanks for posting, that’s very useful.

I’ve observed an alternative workaround that works the same way. If I launch an earlier version of Audacity and select any non-English language, then close Audacity and launch the 3.0.3 AppImage, it opens with the language selected by the previous version.

Even with a workaround that @osch indicated me here and on the AUR, I put the topic with the title [Solved]

And remember, I use Audacity for over 12 years and will not be told of rumors on the WWW that I will choose any fork.

Long live Free Software, long live Linux and long live Audacity, your team and fellow members of this forum and all other open source support forums!!!

Best regards,
Paulo Corrêa Creto

T+ = See you later

Thank you.

That helps me also to set my language in French.