Silence Finder

I’m using Audacity 3.1.3 with Windows 7 Home Premium Service Pack 1. When I open Silencer Finder the window with the parameters to manage appears. Once OK is given another window appears with “Validation error: value not in the range from -100 to 0”.
Pressing OK we see that the “treat audio below …” parameter has changed by itself from -26 dB to -2600 and so on with the other 2 parameters.
How is it resolved? Thanks Rocchei

What language is Audacity in?
Ensure that you are using the correct character as the decimal separator (comma or dot). If you just use the sliders in Sound Finder, it should show you whether it is expecting a dot or a comma.

Audacity is in Italian language and the decimal separator is fixed on a point, it does not accept commas. However I don’t change the three default silence finder parameters (-26.0, 1.000 and 0.300). At this point I press OK and the window appears with the message value not included between -100 and 0 and the value -26.0 has automatically become -260.00. At this point if I press the “correct” button I get -2600.00 and so on.

Note that Windows 7 is obsolete and no longer supported. Nevertheless we’ll try to get you up and running.

I think what is happening is that the plug-in is not seeing the dot as a decimal separator. Ignore the dot in “26.0” and you have “260”.
As a test, what happens if you run this code in the “Nyquist Prompt” (in the “Tools” menu)?

;control  test "Test" float "" 5 0 100
(print test)

I entered the code in Nyquist Prompt. What are the next steps: Load, Save, Manage, Debug or OK? If I press OK the window with “Test: 5.0” appears. Pressing OK again, the message appears: value not in the range from 0 to 100.

Please send a screenshot of that (it does not seem possible).

The various steps only by pressing OK. By continuing to press the OK key, the test number increases more and more.

OK, that makes a bit more sense.

What happens if you enter this in the Nyquist Prompt and click the “Debug” button:

;type generate

Silence Finder is an old effect which was many releases ago removed from Audacity - replaced by Label Sounds (in Itialiano Suoni etichette) - this new effect can also be used to label silences - please see:

You only have Silence Finder (and its cousin Sound Finder) because you have upgraded Audacity from an older version that had thos efeects installed - the upgrade retains them and does not remove them unless you do a full reset.

Please try the new effect - I just tested it in Italiano on my W10 PC with 3.1.3 and it appeared to work well:

New code, key debug and I get # .
OK button then I open Silencer Finder and I get the usual “Value not in the range from -100 to 0”.
Using Sound Finder with default parameters also exits “Value not in the range from -100 to 0”.
At this point, isn’t it convenient to install the latest version of Audacity that had “Silence Finder” installed? On the “” site there are all versions of Audacity starting from the 2.x.x series
What is the latest version of Audacity with “Silence Finder” installed?
Thanks for your help.

I uninstalled Audacity and then I reinstalled Audacity version 3.1.3 this time not in Italian but in English.
I added the Silence Finder plug-in. Now it works and so does Label Sounds.
Thank you and best regards
Gianfranco alias rocchei

I don’t expect that to make any difference as the problem you describe is affecting all Nyquist plug-ins.

The thing that I expect will fix the problem is if you set the language to English (“Edit menu > Preferences > Interface”).

The problem is that the standard decimal separator in Italian is a comma, but your PC is set to use a dot. That mismatch is confusing Audacity.