setting speed prior to recording an overdub track

Hi. Long time user here with a few of my Audacity-recorded songs on YouTube. I’m using Version 2.1.0 on a Windows XP with a Presonus Audiobox USB (for my guitars, piano, etc.) I’ve never had a problem until about a month ago. And here it is: The first track records fine. But somehow a setting has been changed and a second track records nearly 2 notes lower pitchwise. Yes, I could use Effect>Change Speed at +8.125 to put it back to the correct pitch but its a pain and it has skipping quirks. Also, I can uncheck the Dub in Preferences and it will record at the correct pitch, but of course then I cannot hear my other track (or click track). Is it the default speed when I hit the Record button? or my playback choice? or Audiobox-related? Everything is set for 48000 and 16bit as it has been for years. Thanks for any help from anybody. I can’t figure this out.

Is track 2 the correct duration? Do you and the click track get to the end of the song at the same time?

What happens on tracks 3 and 4? SOLO the guide track so you only hear that in overdub mode.

This error doesn’t easily fall into known failures or conditions. Normally, the computer can’t keep up for some pretty normal reasons and the playback gets faster and/or pitch goes up.

Koz

Hey Thanks for the reply!! No Track #2 is not the same lengthwise. Its longer. Track #3 and Track #4 and all subsequent tracks are all 2 notes low and longer. Is there a way to set the recording speed to the same as the first track ?? And thanks again for the help !! :slight_smile:

Is there a way to set the recording speed

Don’t get all excited yet. It’s a common error to fixate on one aspect of the problem repeatedly and not solve anything.

Are 2, 3 and 4 the same length? That if, is you play your music without the guide track, everything sounds OK (given the pitch is wrong)?

Audacity 2.1.0 is not the current version. You should probably download and install Audacity 2.1.2 from here.

When it asks you if you want to reset Audacity as well as install it, say yes.

See if that doesn’t help.

Koz

I’m going to try the 2.1.2 - Thanks Koz!! Hopefully it will work. If not, I’ll be right back.

New version, but shucks – Same problem. I’m wondering if it may have something to do with the speed the Audiobox is sending?

Well I reset and installed version 2.1.2 - but same problem. Is it possibly the Audiobox not sending the correct (or real-time signal) to the program quick enough?

If the Audiobox was sending bad data, the first track would be bad. That’s what’s so darn much fun about this problem. The symptoms never settle into one set of conditions.

As an experiment, reset the whole world for 44100 rather than 48000 and try overdubbing.

Koz

Someone did manage to cure a pitch-drop in recordings by disabling Windows-enhancements … https://forum.audacityteam.org/t/mono-recording-darth-vadar/44080/1
( in their case the problem was only on mono recordings )

Hi. I am also a long time Audacity user (around 4 years) and never had a problem. Now my overdub second track goes slower for some reason. I have version 2.1.2 of Audacity and running Windows 10 Home version 1607. It is very interesting that I recorded successfully on December 9, 2016 with at least 2 overdub vocal tracks and had no problems, and yet now it has gone haywire. My computer is a recent release HP laptop running Intel Core i5 processor, so that should not be a problem. My tracks are playing and recording at 44100Hz and 32 bitfloat. My Audacity was installed from the exe installer. Any thoughts on what might be causing it and possible solutions would be great appreciated. I produce a podcast for learners of English. It seems to me that I must have taken a Windows 10 update in the last few weeks which has affected my environment. I have de-installed all updates since December 9 but with no solution in sight. Any thoughts appreciated.

Please provide information about your playback and recording devices chosen in Audacity including Host (look in Device Toolbar).

Also provide make and model number of the microphone and say how it connects to the computer.

Also see FAQ:Recording - Troubleshooting - Audacity Manual (and FAQ:Recording - Troubleshooting - Audacity Manual if you are connecting the mic direct to the computer).

Sometimes running the Windows audio troubleshooters can help (click the Windows Start button and type “troubleshooting” (without the quotes). Click the first search result that says “Troubleshooting Control Panel”.


Gale

Thanks Koz for everything !!! It is now working perfectly. 3rd, 4th track doesn’t matter - it records guitar, piano or whatever on pitch and timed correctly (of course slight latency as normal). I took your advice of calming the frustration and deliberately looking at everything piece by piece, setting by setting. I made two changes:

Change #1: I right-clicked my Audacity icon and clicked Properties. Under the Compatibility tab, I changed it from Windows XP to Windows 7.

Change #2: Inside the program, I did Edit > Preferences > Devices and changed the Host: from MME to Windows DirectSound. [Playback is still “Speakers (Audiobox)” and Recording is still “Line (Audiobox)”.]

It appears by going back to my basic ASUS computer soundcard, it is a workaround of some sort. I’m not sure, but I did notice everything automatically changed back to 44100 and 32 bit. I may have went back in time setting-wise, but the version still says 2.1.2. and all my plug-ins are still usable. Regardless, everything works.

And again I thank you. The smile has returned to my face!!! And as Ric Ocasek and the Cars put it - “Let the Good Times Roll”

Joey in West Virginia :slight_smile:

HI Gale,

Many thanks for your prompt response and very useful links. I have found what the problem was and it is now fixed. It seems I had changed the sample rate in another music recording application I have, and it flowed through via my recording and playback devices to Audacity. Not sure if that is the right way to describe it, but either way it is now fixed. The key was ensuring that all sample rates were the same.

Cheers and thanks again.
Rob


The reset of preferences did that.

Thanks for letting us know what you changed. Using Windows DirectSound is probably a good idea - on XP it gives more direct access to the sound device than MME.

You might find that the compatibility change is not necessary (I’m puzzled you see a compatibility option for later than XP).


Gale

I am searching this topic so as not to create a new thread about recording track at slower speed (and pitch) and have found that this question has been asked, but am not finding a thread where a solution has been found. I’ve re-installed and reset with no success. Should I start a new question or has this been answered somewhere?