Screen stuttering in playback in Audacity 3.1.3

I recently upgraded to Audacity 3.1.3 and I’ve found a very annoying problem: very often when I’m playing a track the part of the screen that displays the track stutters. It happens when the cursor reaches the right edge of the segment of the track currently displayed and Audacity refreshes the screen with the next track segment. This didn’t happen with the previous version of Audacity (2.x.x).

I attach a short (8 seconds) clip that shows the problem:

Has this been reported previously? Any idea of how to fix it?

Thank you.

So, there have been stuttering reports on Windows before. See here:

You can try Pinned Play Head, or resizing your Audacity screen, to see if that has any effect.

Note that the developers have been overhauling this video rendering logic for the next verion of Audacity (3.2) which is hoped to be released within a few months (possibly sooner). If you wish, you can download a copy of the alpha testing version and report back whether or not this issue is fixed there. Finding the latest alpha(experimental) build can be tricky, but here is what I do (Steve or others may post simpler steps):

  1. Go to this web page: This will display a table of the most recent (pushed) alpha builds with the most recent being closer to the top of the list

  2. Locate the uppermost item with a green check mark. Note that in the second column you will see the word “master”. If it doesn’t say “master”, go further down the list.

  3. These builds frequently occur in pairs - the top one for Linux, the next one for Windows. In the fine print you will see either “Build Audacity Linux Packages #…” or “Build Audacity #…

  4. Click on the one that does not say Linux.

  5. On this this next screen, scroll down (use the scroll bars) to the Artifacts table. You are looking for the build labeled: audacity-win-3.2.0-alpha-2022xxxx+xxxxxxx-x64-msvc2019. The key here is the “64-msvc” which means Microsoft Windows VC 64-bit.

  6. Click on this item to download the zip file. [Note added 4/25/22: You may have to Sign In or Sign Up to do this (it’s free).]

  7. Unzip the downloaded file. (eg., “Extract All”)

  8. To lessen any worries about viruses, right-click on the unzipped directory and select “Scan with Microsoft Defender”, which, after scanning about 191 files, should say “No current threats”.

  9. Double-click on the unzipped directory (perhaps twice), then double-click on Audacity.exe.

  10. Since the alpha builds are not registered, Microsoft Defender may pop up. If it does, click on “More info”, then “Run anyway”. The 3.2 Alpha build of Audacity should start right up.

WARNING: Please please please do not run any production on an Audacity alpha build. Also make a copy of any .aup3 files before openning them with the Alpha. While there should not be any problems, understand that the code is experimental and untested, so please be careful.

Please report back if you are able to reproduce your original issue with the Audacity build. Also, include in your report the name of the build file downloaded.

Thank you for your detailed answer, jademan. For some reason the problem disappeared before I had the chance to test your advice. I’m afraid I cannot tell why this has happened. I’ll write back if it happens again.

Eventually the problem came back, so I tried all your suggestions. Unfortunately nothing worked, so I have opted to go back to Audacity 2 until the problem is fixed. I did reproduce the problem in the Audacity build, the name of the build file is audacity-win-3.2.0-alpha-20220607+1ebe0e3-x64-msvc2019. Let me know if you want more info about this.

Your issue has been logged on github. You may track it here:

In the meantime, if you care to supply any additional specific details, please do so. You can do that here or on github.

  1. What is the most recent version of Audacity where this does work properly?
  2. What are your Device and Windows specifications: Windows Start > Settings > System > About (press the copy button, then paste in your reply).
  3. Do you have any unusual graphics or HDMI drivers ?

Testing on W10 with 3.1.2 1n latest alpha master audacity-win-3.2.0-alpha-20220608+a2b9986-x64-msvc2022

I cannot reproduce this on W10

And I do not recall seeing this over the last week on W11 when I was in Zurich with my Swiss laptop.


Testing on macOS 12.4 Monterey with 3.1.3 and latest 3.2.0 alpha master/

Mostly I get no such stutter in the display.

But with both versions if I

  1. set it to normal zoom levels with Cmd+2
  2. Zoom in with the Zoom button 2 or 3 times
  3. Then I can see a very slight stutter at the redraw - but nothing like as extreme as in the video posted by the OP.


I just noticed my graphics drivers were slightly outdated. I don’t imagine that might be causing the problem, but just in case I have updated them and will report back after I have done some work with the updated drivers.