Save Project As errors

I am using Windows 10. Since moving from 2.4.2 I am unable to rename or overwrite a file using Save Project As. Error messages and corresponding log files attached. Please note that I am not a techy but I noticed something about ffmpeg files and downloaded ffmpeg-win-2.2.2 but was unable to install it even as Administrator. Please help!!
log2.txt (1.79 KB)
log.txt (1.79 KB)

That’s not an error that’s now intentional in 3.0.0 - we tightened it all up a little for safety.

You can’t:
a) save to an existing filename (except from your current project)
b) Backup Project to the same name as your current project
c) Save As to the same name as your current project

Audacity 2.4 and earlier would let you do that, it issued a warning asking if you were sure and wanted to overwrite the existing project.


But now with 3.0.0 you can rename projects outside of Audacity with your OS’s file manager - BUT only after you have closed the project,


Thanks but I’m not trying to save with the same name - I’m modifying a file and then trying to save with a new name or to overwrite an existing file. E.g I save a raw file then go back and edit and save it as an edited file but with a new name - I want to keep both the raw file and the edited file.

Don’t use OneDrive for active projects.
OneDrive provides “cloud storage”. This can be a serious problem for Audacity projects because the data on disk may not match the active project.

It’s OK to move a project to OneDrive after you have closed Audacity, but if you want to work on it again later, move it back to a normal local drive (such as “Documents” or “Music”) before you open it in Audacity.

Thanks. I removed the active project folder from One Drive’s list and even tried closing One Drive completely. Neither made any difference and I still had the same error messages. So I then copied the files to an external drive, which was not linked to One Drive at all, and still had the same problems. I’ve even tried reinstalling 3.0.0. but that didn’t work either. It’s making Audacity unworkable for me at the moment.

Do you have punctuation marks in your filename? That can be a bad idea, particularly slashmarks. Use ISO dates. Today is 2021-03-22.

Upper case letters, lower case letters, numbers, -dash-, and underscore are OK.

Slashmarks can make your computer go off looking for a non-existent folder, location, or drive and report seemingly nonsense errors.


No, file names are straightforward - just letters and numbers. In fact, whilst trying to solve this, I’ve been using Test, Test2, etc. Please what else can I do?

You can stop using OneDrive for active projects.

If you look at previous answers, I’ve already done that but to no avail.

Are you still having problems with new projects, or just with projects created previously?

Steve, I think I’ve solved it. I uninstalled Audacity 3.0.0. and then this time downloaded the zip file instead of the .exe file. I extracted the files, ran the .exe file - problem apparently solved. The download page suggested this to solve problems with permissions. Thanks for your patience and help. Got there in the end!!! Hope it helps someone else.

Thanks for the update. Glad to hear you’re up and running :slight_smile:

I have the same problem. Audacity 3.0 on Windows 10.
I saved a project and opened it later on to do some pitch shifts.
When I was trying to sve the project with a new name “Sweet Child O’ Mine click reduced plus 1HT.aup3” I got the messag ethat it couldn’t be saved because the disk is not wtitable (e.g. is full) but thats no the case.
I did some changes on the track vivibility and stored the project with the original filename “Sweet Child O’ Mine click reduced.aup3” and it worked.

What can I do to save my work ??

The method to uninstall Audacity and install the ZIP-Download doesn’t help for me. How should ist as it is the exactly same .exe File.

I need some help to solve the issue.


Since “The method to uninstall Audacity and install the ZIP-Download doesn’t help for me”, it is likely that you do not have the same problem.

I’m confused. :confused: So exactly what is the problem :question: