Regarding Project Sample Rate The problem

For example, I have a native music in the format 96/24!!After importing the file, its default is 44.1/16

After I finished editing the music in the 96/24 time period,Select FLAC export 96/24!
So this music file is from 44.1/16→96/24? Or 96/24→96/24??
I have been thinking about this issue for a long time, and I was completely confused until I saw your software manual.

There is such a sentence in the manual!
“The Project Sample Rate is stored with your project when you save the project”
I don’t know if my Google translation is accurate! But if it is accurate, I will become very confused.

I know many people use this software to synthesize audio files with different sample rates! But I still hope you can add a new option in the audio settings! Automatically identify the specifications of the currently imported audio file! ! thx

If I split a full CD album into many singles, I wouldn’t have any questions! Because he originally had the specifications of 44.1!!
Just curious, is there really no negative optimization from 32→16?

When importing a 96/24 audio file, the default sample format in Audacity should be 32-bit float.

In older versions of Audacity, importing a 96 kHz file into an empty project would automatically change the project rate to 96kHz to match the file. This functionality appears to have been removed from recent versions of Audacity, so you now need to change the sample rate manually if you want to work in 96kHz.

Only if it ws the first file imported into the project (in older versions that is)

And not juust auromatically, it did it “silently” with no warning to the user.

Peter

“Almost” silently. The attentive user may have noticed that the “Project Rate” setting in the lower left corner of the main Audacity window changed. The “Project Rate” setting in the lower left has since been removed. To see what sample rate the project is using now, you have to open the audio settings and find it in there.

I’ve tried manually changing the audio I just imported to 44.1/32→96/24. When played back, the sound sounds like it’s being played backwards. This is very strange. If I change 96/24 in the audio settings and restart AUDA, everything works fine. I’d love to know which older version I should downgrade to