Recording Vocals over Audio Separately

I have a usb mixer and mic. I can record right over the audio track that I either imported or am just playing on my computer
BUT, I would LOVE to know how to record both of those simultaneously in two separate tracks so that I can edit the vocals, so it’s separate from the audio as well but still matching with audio track above or below the vocals.

THANK YOU in advance

You almost described Overdubbing.

Import the music track in Audacity. Set up your system for Overdubbing. The next time you press record, Audacity will play the music into your headphones and produce your voice on a second track, in time with, but divorced from the music. Use this process to sing three and four part harmony to yourself by recording multiple times. You can select which track or combination to play to your headphones.

Fair warning that this process only works perfectly with special hardware that offers zero latency monitoring. Without that, you can’t listen to your live voice during the overdub, you can only hear everything else.

For example, that’s what this is.

The USB adapter has a mini-mixer inside and allows you to hear your own live voice perfectly correctly as well as the background music tracks. If you listen to the computer, your live voice will arrive late with an echo.

No, I don’t recommend earbuds for production. They were handy for the photo.


If you’re comfortable not hearing your own voice during overdubbing, then you don’t need the special hardware or device. Some people work like that.


Thanks for this man! BUT I have overdubbing on, and it makes a new track but its just recording EVERYTHING together including the song.

IDK if this helps but my headphones are hooked up to the mixer, and i can play both vocals and song at the same time in my headphones and stand by the mic but for some reason it cant record both vocals and audio separately or just the vocals in a diff track?

I JUST WANT KNOW HOW TO SEE ONLY VOCALS AND EDIT THEM, because i think it would be easier to find the right range when i can hear both together

Yeah. I got that. There’s changes you need to make and I need to research them.


its just recording EVERYTHING together

Right. Perfectly common. That’s what happens when you have your machine set for recording YouTube or other internet sound. Those settings are different from the settings needed for overdubbing.

To record YouTube sound, the computer has to play the music out to you. Then, while it’s still in the soundcard, turn it around and send it back down the recording pathway so Audacity can record it. Overdubbing depends on the recording and playback pathways being completely divorced and not cross-coupled like that.

I don’t know that we ever got a simple, single-line process for fixing this. I know in at least one case, we never solved it. Each computer has a different process to record internet sound. There’s a silly joke if you remember how you got that to work, stop doing it.

There’s a couple of base-line requirements. Audacity has to be recording from the mixer directly. Set that with the recording side of the Device Toolbar.

Audacity > Preferences > Recording > [X] Overdub… should be the only thing selected.

You need to be on headphones so the microphone doesn’t pick up speaker sound.

Did I hit it yet?

What’s the mixer?

What is the version number of Audacity?


Are you using SoundFlower or SoundFlowerBed?

Maybe it’s not enough coffee. You’re on Windows 7.
Do you record internet music or YouTube sound?


Sorry I got a little ansty! I have an m-audio multimix 8 usb, and I am not using sound flower or soundflowerbed. I also have never recorded from YouTube or online sources, this is the first time I’ve recorded stuff on audacity, I just downloaded the newest version of audacity today

Right. So we’re here. Things that can cause Overdubbing pileups.

– Audacity > Edit > Preferences > Recording > [X] Overdub… should be the only thing selected.

– You need to be on headphones so the microphone doesn’t pick up speaker sound. If you use a live microphone, you’re stuck with headphones.

– Some USB sound mixers can produce this effect. If your mixer has a button called 2 TRACK USB TO MAIN (or something similar), you do not want to push that button.

– Audacity has to be recording from the mixer, sound device or microphone directly. Set that with the recording side of the Audacity Device Toolbar (the microphone symbol). This is the one that gets messed up if you like to record YouTube or internet sound.

Got all those? Still getting overlayed recording?


I used soundflower and I started having this same issue. I uninstalled soundflower and I’m still having the same issue. Any recommendations