Recording stops immediately in overdubbing mode, not always

After pressing the Record Button in overdubbing mode (playing track is present), the recording process stops immediately, or after some milliseconds recorded. Doesn’t happen on the empty track.

Happens frequently, but not always. After several presses, it starts and continues recording fine.

Software playthrough, Sound activated recording options are switched off. Tried with and without Detect dropouts option.

Linux: Ubuntu 20.04.2 LTS
Audacity: v.2.3.3 (from Ubuntu packages), 2.4.2 (from ppa, 3.0.0 (built from sources).

Audio subsystem: ALSA (from Ubuntu packages)

Devices used:

  • playback - HDA Intel
  • recording - HDA Intel, and external USB microphone

Found some number of (probably) related reports:

WIndows guy here. It is good to see that you have done research on this issue.

Have you tried Pulse Audio and/or Jack as your links have suggested?

Hopefully a Linux or Ubuntu guy will step forward with some more useful suggestions. :smiley:

What settings are you using in the Device Toolbar?

Really neither of the settings in the device toolbar helped me, but right now the toolbar looks as in the attachment

I’ve read here that this guy has already tried with Pulse and Jack options without success, so probably I don’t need to repeat such an unsuccessful experience, because Pulse and Jack subsystems are not defaulted and need a lot of time to make them work fine.

PulseAudio is the default sound system in Ubuntu.
To check that it is installed correctly, try running this command from a Terminal window. It should open the PulseAudio Volume Control:


Found the workaround!

The pavucontrol command is not installed on my host right now. I am using Kubuntu, it probably has its own sound subsystem UI options.

You right, I’ve checked and found installed the PulseAudio package 1:13.99.1-1ubuntu3.10, but anyway, Audacity has only one option to select the Audio host (first member of the DeviceToolbar) - the ALSA.

The recording device control (the second member of the Device Toolbar) contains the pulse option to select, and it looks the same as the default one. Changing this option to pulse and trying other options directly selecting the recording device (see the first attachment) doesn’t have an effect on the issue.


The playback device (the fourth member of the Device Toolbar) also contains pulse and direct device options for the playback device (as in the second attachment). Changing it to the direct device selection (see the second attachment) works around an issue! It might be some tip for developers to find the bug, thank you.

The default sound system is PulseAudio, so “default” is just an alias for PulseAudio.

“ALSA” is the underlying sound system (“drivers”) between PulseAudio and the hardware device.

This is a known issue, and is what I was going to suggest next (but you beat me to it :wink:)

It does not happen often these days, but it is still an issue for a few Linux users. Unlike most audio apps, Audacity does not just connect to the sound system and leave the connections open until Audacity is closed. Audacity makes a new connection whenever it is required to play or record, and closes the connection on “stop”. It is like this for historic reasons.

Unfortunately, PulseAudio does not always manage to open and close the connections when requested, which causes PulseAudio to quit and respawn. It’s the “respawning” that causes the problem because Audacity is left in a state where it is trying to communicate with a PulseAudio device that no longer exists - it has been replaced by a new instance of Pulse.

The workaround is to bypass PulseAudio by using the underlying ALSA devices directly. As you have done, you just select the “hw” option that corresponds with the audio device that you are using. In your case that’s “hw:2,0” (the “ALC887-VD Analog” device).

My hope is that eventually Audacity will be changed to make the audio connections persistent, thus avoiding the problem arising from constantly making and closing connections, but this is a big job that goes deep into Audacity’s audio handling so it’s not likely to happen anytime soon.

I am using Ubuntu and had the same issue - went away when I uninstalled, reinstalled audacity,