Recording in mono severely limits the waveform - why?

I upgraded Audacity to the latest version 2.3.2 and it ran beautifully on Windows 7.

I’ve just upgraded to Win 10 and there’s an issue. I use a Focusrite Scarlett 2i2 into audacity - and before I always used to record mono. It was fine.

After the upgrade, recording in mono limits the audio at -0.5 dB as if I’ve put a very harsh limiter/compressor on it.

However if I record in stereo - so the left side is recording and the right side is silent - it records fine - and as a workaround I can split the audio track to just work with the left side as a mono track. Is this something that’s known about?
It records fine in Adobe Audition in mono - so it does seem that it’s an Audacity issue.

Somebody on the forum suggested this is to do with the output on the Focusrite (but it worked fine on Win 7) - any thoughts? I don’t think there’s a way of changing the output of the Focusrite from mono to joint-stereo - so I’m looking for ideas!

I can’t see any Windows settings that it could be - so is this a bug in the way the newest version of Audacity works with the newest version of Win 10?

It’s mixing (summing) both inputs on your interface. Both inputs together can get very-close to clipping (showing red) and the mono mix will be near clipping (near 0dB). If the signals weren’t cut in half it would be possible to have both channels “in the green” and end-up with a clipped mix.

Please confirm if it is “limiting” at “-0.5 dB” or “0.5” on the vertical track scale (0.5 linear).
0.5 dB is only a tiny fraction below full track height, whereas 0.5 on the linear scale is half the track height.

Assuming that you actually mean “0.5 linear scale”:
In the Windows Sounds settings, Recording tab, is the Focusrite set to record “1 channel (mono)” or “2 channels (stereo)”?
(Windows 10 often sets this to mono, even for stereo USB recording devices, requiring the user to manually change it to stereo).

It should probably be set to “2 channels (stereo)” because the Focusrite Scarlett 2i2 is a true 2 channel device, even if you are recording only the first channel.

Thank you, no from what I can see it’s not that. It’s just really strange as I know this has happened before and I can’t think how I got it back to normal. I’ve even tried taking the whole programme off my pc and re-installing it, however it’s still doing the same thing.

Why are you replying to a year old topic as if you were the original poster? :confused: