recording from sound card


Thanks for this forum. Here’s my situation: been an audacity user for years and frequently use it to record both line in and from sound card. I have version 2.0.4 and installed from the .exe. Running Windows 8.

I had to refresh my pc a couple weeks ago and probably didn’t try to record from the sound card in audacity since til I wanted to tonight and can’t get it to work. Been looking at tutorials, forums, etc. and long story short things just are not lining up with what they say to where things are on mine.

It does record Line In just fine. I actually recorded from a line in source earlier today but can’t get anything to record from the sound card. Tried changing all the settings, input drop downs, etc. I can find.(Especially from Line in to Microsoft Sound Mapper input) What am I missing? Is is not seeing my sound card? I do have sound in my pc coming through the speakers. Virtually everything else seems OK. Even checked all my other audio programs to be sure all sound volume controls were up. Might be something in my Windows 8 and not audacity I realize too. Seems all those vol. controls are all the way up too. Unless there’s some little setting I’m missing which probably is.

Any help would be appreciated as I’m stumped.


For a start upgrade to 2.0.5 which has just ben released:

And then try the WASAPI (loopback) host (rather than MME or Windows Direct Sound).


Thanks. Just installed the new version and now it just clicks. sorry, I don’t know what this means:
the WASAPI (loopback) host


thanks again

p.s. oh, I think I found it. there’s another drop down menu where it has Windows WASAP. Tried that but the cursor won’t even move when I try recording.

Try playing the stream you want to record in YouTube or wherever it is, then the recording cursor should start to move.


I know it should, but it didn’t in that WASAP mode. The other way it does but doesn’t record.

The issue might be my pc and if so, does anyone know what I could look for there?


You could just try rebooting the computer. Sometimes the recording cursor gets stalled whichever host you use.

Also make sure Transport > Sound Activated Recording (on/off) is off (not checked). If it’s on, this may prevent the cursor moving until the input stream is loud enough.


Naturally, I have rebooted my PC more than once. Thanks for the other idea. That is also unchecked. I think I have deeper problems here.


ok, after even more labor, I discovered “stereo mix” is no longer showing up like it used to. I’m pretty sure that is the issue. I’m supposed to be able to go into my sound/recording window and right click and choose “show disabled devices” for “stereo mix” to appear so I can enable it. However, it won’t show up even there, so looks like I’m off to the Windows 8 forums. Thanks for trying and if anyone has any other ideas please let me know.


ok, further research/labor revealed it was my driver. I thought they were all updated but one was not which turned out to be the “stereo mix”. So, eventually I worked it out. If anyone else is having this problem where “stereo mix” is not showing up to record from your sound card, be sure to update your drivers.

thanks for your help,

Thanks for looking into it yourself.

Ideally Windows WASAPI would have recorded for you even if you did not have stereo mix. Does WASAPI record now, if you quit Audacity, play your stream then start Audacity?