Recording from Alesis Multi 8 track fx usb

I was refereeing the OPs request to record with several inputs at the same time. “I don’t know how to make audacity record from multiple audio devices simultaneously”. I am running the latest version and it will not work for me as you say. I did follow the link and I am sure I am choosing the correct inputs. I took a pic and maybe you can point me in the right direction. It does the same thing regardless of what track I choose, or record in mono or stereo. I had this same problem with my Alesis Multi 8 track fx usb interface. I can run eight channels in at once, pan 4 l and 4 r but that defeats the purpose for what I was trying to do. Any suggestions would be most welcomed. I think I have also recreated a problem over in the Teaching forum. I will recheck the post then post my pic as well.

and now you appear to be asking an unrelated question, so better that we have a new topic. We find it gets very confusing if we don’t stick to one topic per question/subject.

Which version is that? Look in “Help > About Audacity”.
I’m using “Audacity 2.2.0-alpha-Jun 27 2017”

From the “Help” menu, select “Audio device info”, then save the info as a text (TXT) file and attach it to your reply.

I am using the latest version that is posted on your website. I think this is what you were asking for concerning the audio device info. Kudos for whoever added this little nugget. :bulb:
deviceinfo.Mack-Caster.txt (10 KB)

When WASAPI is selected as the “host” in the device toolbar, applications connect tightly to the device drivers. This usually has benefits of low latency (not important for Audacity), and for multi-channel sound cards it often allows multi-channel recording without the need for ASIO (which can be useful for Audacity as ASIO is not open source and cannot be distributed with Audacity). The downside is that options are limited to the capabilities of the hardware and its drivers, which in practical terms means that it can be very fussy about sample rates, the number of channels and exclusive access.

When MME (or Direct Sound) is selected, Windows takes over the sound system and can usually provide a lot of flexibility over sample rate and shared access, but is usually limited to a maximum of 2 channels (mono or stereo).

According to the “Audio device info” that you posted, it should be possible to record from the Tascam using MME, but with a maximum of 2 channels. Usually the available channels are the first two channels of the device. (Input 1 for mono, inputs 1 and 2 for stereo).

Thanks @Steve. The Tascam has its own dedicated ASIO file and I have ASIO4All installed as well for other applications. I posted on another thread showing what happens when I try and record two tracks at the same time. I think this is what the OP may have been asking about.

The official release version of Audacity does not support ASIO.
We don’t offer support for unofficial versions.

There is a bug in a couple of versions of Audacity where Audacity adds the wrong file extension to exported files. That’s why I responded the way that I did in that other thread.
Can we try to keep to one topic per forum thread? :wink:

No problem Steve, since I have never asked a question, I am really confused on how to stay on topic when your staff moves my REPLIES to another thread. :wink:

In the first post of this thread you appear to be asking how to get your Tascam working with Audacity. Is that not the case?

No that is not the case. Like I said, I was replying to the OPs question, letting them know that as far as I know, you can not do this with Audacity. As I have shown in the pics I have supplied, it still can not be done. I promise you that if can be done Steve, I will figure it out and reply back to this thread. I go Wheels up in 50 mins and I need to get going. Have a great day. p.s. I referenced the other thread as an example of what I see when I record using a True USB Interface. :wink:

I couldn’t find that Audio Device Info, but if you wanted to use WASAPI host you might have to record all 16 channels and close the tracks you don’t want after recording.