Recording Computer Playback - Windows 10

Windows 10 Home x64
Dell XPS 9343
Audacity 2.1.1 (.exe)


I appreciate this is covered in depth here,, and elsewhere, but I still can’t record directly from the system. This worked perfectly well a few months ago so I can only guess it’s as a result of automatic updates. I’ve tried the latest drivers from Dell and RealTek. I’ve tried installing older drivers too.

Each time I install a different driver I try all of the options is in the dropdown list (MME / DirectSound / WASAPI), along with recorded inputs. RealTek high definition never appears as an option. And of course I’ve looked Device Manager and the sound control panel with recording devices. I’ve never seen “Stereo Mix” (show disabled devices is selected).

My apologies if the topic has been covered previously but I’ve now spent hours trying trying to get it to work with no results. If anyone has any insights based on what I’ve outlined above I’d be delighted to hear from you.

Thank you.

Sometimes it’s good to know the basic computer is working.

I can’t tell from the pictures what the sound connections are, but do they work? If it’s a headset connection, does a headset work? Can you listen to YouTube presentations in stereo (if you are intended to)?

I don’t know that you’re going to get “Stereo-Mix.” That dates back to WinXP machines, and besides, it’s tied to the soundcard and soundcard drivers.

The WASAPI software is supposed to take over all those oddball drivers and software packages that had to hold hands to make self-recording work.

What happens if you Google your laptop model and “Stereo-Mix?” Are you inadvertently joining a long list of people none of whom can get this to work—is this a known problem?


Hi Koz,

I haven’t provided any pictures. Audio plays perfectly well on my system - I’m trying to record from the system itself, ie, whatever happens to be running through the sound-card. This worked very well up till recently and so I presume it’s a driver issue - either that or there’s a setting in Audacity that needs adjusting.

I’ve tried drivers from Dell and RealTek. I don’t need “stereo-mix”, necessarily, I just see that that’s what’s been used in the past. I now understand that WASAPI is the way to go but even this doesn’t work. The results are distorted, muffled sounds.

Thanks for responding,


Have you tried the two Realtek drivers from this page?

The one that ought to work best there is the latest Realtek Audio ALC3263 Driver 9343_Audio_Driver_8FWK0_WN32_6.4.10041.127_A01.EXE 10 Aug 2015.

What drivers do you have now? Look in Device Manager > Sound, video and game controllers, right-click the device > Properties > “Driver” tab. Who is the driver provided and what is the driver version?

Post the information from Help > Audio Device Info… in Audacity.

Post a sample recording that you say is muffled. Please see here for how to attach files: Recordings are usually muffled because you have chosen a project rate below 44100 Hz (bottom left of Audacity).

What exactly are you recording. Spotify? YouTube?


I upgraded from W7-HP to W10 last week on my 64-bit Toshiba Satellite laptop with Realtek onboard soundcard and surprised to find that I do still get Stereo Mix. But I still prefer to use WASAPI host and loopback.


Thank you both.

Under Sound, video and game controllers there are three entries:

  1. High Definition Audio Device - driver provided by Microsoft (version 10.0.10586.0)
  2. Intel Smart Sound Technology (version
  3. Realtek HW Audio Codec (version 6.4.10041.127)

I entered my service tag on Dell’s Driver Updates page and was taken to the driver suggested by Gale: Realtek Audio ALC3263 Driver 9343_Audio_Driver_8FWK0_WN32_6.4.10041.127_A01.EXE 10 Aug 2015.

This won’t install on my machine. The reboot request pops up every time I turn on the PC, and despite following the instructions to complete the installation, it reappears every time I reboot. I also now get a missing dll error message.

Clearly this is now an issue for Dell, so I’ve opened a support ticket. I’ll keep you updated.

Thanks again.

According to “3” above you did already have the Realtek HD driver version 6.4.10041.127, but it may not be installed “properly”.

Have you tried using Device Manager to uninstall that Realtek device, and then install the downloaded driver from Dell?



Back to your earlier question - I want to extract short clips from talks given by people in my industry for a podcast - these are mostly from youtube and licensing is not an issue.

I’ve successfully updated the driver and did the “proper” uninstall beforehand. I can record from youtube but the quality is not good (it’s hollow and echoey and not nearly as good as the source). See sample attached.

Earlier in the year, before the driver update, this sounded flawless. My settings are as follows:

Audio Host - Windows WASAPI
Recording Device - Intel Smart Sound Technology (loopback)
Project Rate: 44100 Hz

I suspect my best bet now is to try looping by running a cable between audio out and mic in.

Thank you for all of your helpful suggestions.


So what Realtek driver do you have installed now - Realtek Audio ALC3263 Driver 9343_Audio_Driver_8FWK0_WN32_6.4.10041.127_A01.EXE 10 Aug 2015?

Which driver did you have before? If the Aug 2015 driver is what you have now, you could still uninstall it and try the earlier of the two audio drivers on Device Manager may already give you an option to roll back to earlier drivers. Check it out. There is a chance Windows Update might try to reinstall the current drivers but you can prevent bad updates reinstalling.

What is your default playback device in Windows Sound? Whatever is the default will be what your web browser is using, and you should use the (loopback) for that device in Audacity.

Is there a Realtek playback device?

If you are not sure, please post the information from Help > Audio Device Info… top right of Audacity.

If the mic in is only meant for a computer mic, that may give you mono or distorted over-loud sound. Let’s see if we can get WASAPI to work.


Thank you for persisting with this.

The two Realtek drivers available through Dell are the 10041.127 and 10041.125. I’ve tried both of these and they produce the same poor results in WASAPI: a hollow chamber sound as if talking into a large empty vat.

As I say this was not the case in the first half of 2015. The oldest of the two drivers is dated as recently as 18/06/2015, so it’s the one previous to this that may be of use. I’ve asked Dell for this but have no luck as yet.

My default playback device is Intel Smart Sound Technology (Intel SST). The only other one available appears to be S27D390 High Definition Audio Device. I’m attaching Audio Device Info.txt here.


Audio Device Info.txt (6.4 KB)

I don’t fully understand what the Intel Device is - it does not appear to be display audio from what I see online.

What happens if you make “S27D390 (High Definition Audio)” the default playback device in Windows Sound, restart Audacity, then make the playback device in Audacity “S27D390 (High Definition Audio)” and the recording device “S27D390 (High Definition Audio Device) (loopback)”? Restart the browser so it picks up the new default device.

What version of Windows were you using when you did not have the issue? Did you ever not have the issue in Windows 10?