Record requires a second track be opened

I’m running Audacity 2.0.5 on a Windows 7 Ultimate PC. I record streams I’m playing on my computer using the Windows WASAPI setting and all has been working fine. Normally, from an empty Audacity window, I click the record button, a track opens up, the record head begins moving to the right, and any audio stream I’m playing gets recorded. Last night I was recording various things and when I started a new recording, I clicked the record button, a new track appeared, but, the record head remained at the left starting point and nothing was recorded. Through a process of trial and error, I’ve discovered that if I stop the first recording attempt with the stop button, leave the track window open, and click record again, a second track opens and the recording head starts moving to the right and recording works. I have tried some searches on this forum, but so far haven’t found anyone experiencing this. Can anyone suggest what might be going on?

Audacity is designed to be able to make multi-track recordings. For example, record yourself playing guitar - press stop - Record yourself singing along to the guitar - press stop - record yourself playing a piano part … For this to work, each new recording must be on a new track.

If you wish to continue recording on the same track after pressing the Stop button, then you need to “Append Record” (“Transport menu > Append Record” or Shift+R).

When recording with “WASAPI loopback”, Audacity will record what is playing through the sound card.
If you already have a track in Audacity and start recording a new track AND you are recording with WASAPI loopback, then Audacity will try to record the old track onto the new track as well as whatever else is playing through your sound card. Depending on other settings, this can get very complicated and (bad) unpredictable results can occur. For what you are wanting to do, ensure that when you want to continue a recording after pressing Stop, use “Append Record” (Shift+R) and not just the “Record” button.

Not so if you un-check “Overdub” in the Transport menu :slight_smile:

WC

Steve and Waxcylinder:
Thanks for the replies, but I’m afraid my original query wasn’t sufficiently clear. By the way, I’m a long time Audacity user on both Linux and Windows, and I’ve done what I’m trying to do many times, and up till last night this was working properly on this Windows box. Nothing in particular changed, to my knowledge - it just stopped working properly while in use. Here are the reproducible steps with my current settings:

  1. Open Audacity
  2. Click the record button
    – Expected behavior: a track window should open and the record head should start moving from left to right - any audio being streamed by my PC is recorded
    – Present behavior: a track window opens, but the record head doesn’t move and nothing is recorded
  3. Click the Stop button, then click the Record button again
    – Now, a second track window opens and the record head starts moving from left to right and streaming audio is recorded on the second track

Perhaps I inadvertently changed some setting, but, I’ve looked and looked and couldn’t find anything… I do know about recording multiple tracks, and being able to play what was previously recorded, but this is not what I’m talking about. I’m just trying to capture single audio tracks of streams, and save them - the Step 3 workaround above accomplishes my goal, but, I’d like to not have to use that method as I’m doing a lot of recording and that workaround involves several additional steps.

You can get a stalled cursor when Audacity starts recording and there is no bitstream. Does it happen to all internet recordings or only the special one? You can connect to a stalled streaming server. A news service I use is updating their system and is going through this.

“Sorry for that. I posted the individual news pieces [here] until we get the server back up.”

The fuzzy rule is Audacity is a slave to the computer and system around it.

Koz

"You can get a stalled cursor when Audacity starts recording and there is no bitstream. Does it happen to all internet recordings or only the special one? "

For the record, I always start recording before I start a bitstream, and it’s always worked and this issue was happening with numerous different recording attempts.

“The fuzzy rule is Audacity is a slave to the computer and system around it.”

Bingo! A few other weird things started happening on this machine so I decided to cold-reboot. That solved all issues including my strange Audacity problem. Thanks to all for your input - sorry for the noise.

The one host that you need to be careful with is the new WASAPI loopback which was introduced in 2.0.4. With WASAPI you do seem to need to have the bit-stream started before you record. This is not the case with MME (default) and Windows Direct Sound if you have stereo-mix (or what-u-hear or whatever) capability on your PC.

WC