record one track while listening to the other-without both audio being put onto one track-

Hi. I want to record a track while playing alongside another, without both audio being condensed into the one track (the recording one)
When I first downloaded Audacity it was doing this fine, and then something changed and now it always records everything to one track no matter what. I have the overdub option turned on, software playback turned off…I’m running everything through Loopback audio routing, which I’ve done before with no issues.Before I could play alongside the other tracks while only recording what I was specifically on (1 track). I’ve tried to look online and keeps sending me to the overdub option which doesn’t change anything. do you know what the issue might be?

Something has changed, as you say, and my bet is that it’s within Loopback.
– Bill

my bet is that it’s within Loopback.

What he said.

You are intended to get a clean new recording separate from the backing track or backing tracks you select.

Two things can get in the way of that. You can have Playthrough turned on (not “playback”). But you can also be set up to record internet music.

Recording YouTube is a juggling act. You have to run Playback so you can hear what you’re doing and you also have to run Record so Audacity (or your recorder software) can capture the sound. They are two completely separate pathways. If you leave it set up that way and launch overdubbing, you can get lots of magical problems such as recording your laptop built-in microphone by accident, recording the beeps and chimes your machine is making, recording the notification sounders from FaceBook and Twitter … and recording your backing track.

I don’t think you need loopback to use Overdubbing. The Overdubbing set-up will take care of all that.

You should be set up to record from a real hardware thing you can point to and touch. Line-In is a real connection on the side of my machine. That’s where I plug in my sound mixer. I can reach over and touch it. SoundFlower is not. That’s a software app that rearranges the sound pathways inside my machine. It’s not a thing.

Loopback is not a thing. It’s a software package. You should be recording from a thing.


Koz and Bill,

thanks for the replies.

The issue is I make music only from my laptop (electronic music using Loopback to route the audio from programs like Ableton and Cecilia to Audacity so I can record.), so I don’t have use for the hardware or mics and all that. I was having no issues with this-I could overdub, Audacity would isolate which was a track and what was recording and I could hear both and everything would work fine. Its only been this past week where no matter how many configurations I go through, Audacity or the routing program still continues to put all the audio onto the one track I am recording. I looked at the older questions and I assume I have the same problem as this person and yet I still can’t get it to resolve. But I’m curious, where can I find the “Playthrough” options? I added two screenshots if that helps at all, idk.
Screen Shot 2020-04-30 at 2.33.35 PM.png
Screen Shot 2020-04-30 at 2.33.18 PM.png

You can see the “Software Playthrough of Input” in your first screen shot. Leave it unchecked.

In your second screen shot you have “Loopback Audio” selected at the input to Audacity. That means Audacity would be recording the audio you have routed from Abelton, etc.

I am not clear exactly what you are doing. In Audacity, overdubbing means to play back one or more tracks from Audacity while recording a new track. You say you are not using “hardware or mics and all that”. So how are you recording the new track into Audacity?

– Bill