Recognising USB microphone

I am running Windows 10 and Audacity 2.4.2

I have plugged in my USB microphone and checked in Windows that it is properly installed and tested. I then re-started Audacity, but it does not recognise the device. All i get is ‘Error opening recording device, Error code: 0 Success’. I have tried Transport: rescan audio devices but nothing is shown either for recording or playback devices. I am aware of the issue with Windows 10 and have followed the instructions for that.

What am I missing, please!

USB microphone

Whose name and number is? We have to build your system in our imaginations to make this work.

I am aware of the issue with Windows 10

That’s not reassuring. The microphone has to be recognized in Windows and actually work there before Audacity can connect.

That’s Windows 7, but do you get the Windows bouncing sound meter?


Yes, I’ve gone into Windows, Settings, Sound, and have seen the ‘Test Microphone’ sound bar reflect my voice test.

In the Device Toolbar, set “host” to “MME” and select the USB mic as the recording device (and your sound card as the playback device).

The Device Toolbar has no options for host, for choice of microphone or for speakers!
I’m afraid I am totally new to all this, and need to be guided through with words of one syllable as it were!

Ensure that Audacity has permission to use the microphone:

Yes, have checked this setting and done the test in Settings again. What is also odd is that my speakers, which work fine for Zoom meetings, playing videos in messages, YouTube and the like, are also not recognised by Audacity!

You’ve not got Zoom (or Skype or similar) running at the same time (or running in the background) have you? They tend to grab exclusive control of the sound system, which interferes with Audacity.

NO - I don’t use Skype at all, and have not been logged into Zoom when I’ve been trying to use Audacity.

Open “Help menu > Diagnostics > Audio Device Info…”
After a few seconds the info screen should show information about your computer’s audio devices.
Save that info and attach it to your reply.

I’ve been able to successfully use Audacity to record my monthly Zoom meetings of Bella Hardy’s harmony singing workshop - works a treat.


Default recording device number: -1
Default playback device number: -1
No devices found

I have just come off a Zoom meeting in which the microphone in my Webcam (which plugs into the back of my Optiplex 780) and the external speakers similarly plugged were both working perfectly! It’s a mystery!

That strongly suggests that Audacity does not have permission to use the microphone.
I know that you said that you have checked that, but I’d suggest double checking (because I can’t think of anything else it could be)

I’ve checked al this again, and tested the microphone in Settings, but Audacity still doesn’t give any options for host, for output device or for input device. I’m wondering if I should uninstall the programme and then re-install - if so which website would you recommend I log onto to do this?

This is the official Audacity website:
The download links direct to “FossHub”, who are the only official download location for Audacity releases.

Note that reinstalling with the same version of Audacity will make no difference to anything, unless you also “reset preferences” (the Windows installer provides an option during the installation to reset preferences).

retested everything, and have now used an adapter to go between my usb microphone and the microphone jack socket on the front of the desktop. Still no joy!