Realtek HD internal speaker - no playback sound

Acer Aspire One notebook
Windows 7 SP1
Audacity 2.2.2
Realtek High Definition internal speakers

I can record and playback ok but when I playback I cannot get any sound from my internal speaker. Everything visually is working ok but no sound. If I use my headphones I can hear the sound loud and clear. I have also saved a project as MP3, and played it back, but I get the same problem. I can only hear it through headphones.

Before I offer any more info, is there a simple setting that I am overlooking? I have tried everything I can think of to resolve the problem.

The settings on the toolbar are as follows

MME
Microphone (Realtek High Definition)
2 (Stereo) recording
Speakers (Realtek High definition)

BTW, all other existing videos and MP3’s on my computer are working loud and clear through both the internal speaker and headphones

Any help very much appreciated.

Many thanks

Terry123

Stereo show? Did you record it with an XLR microphone and an adapter cable to your laptop?

Try this. Tracks > Mix > Mix Stereo down to Mono. Did the blue waves on the timeline vanish?

Edit > UNDO.

Koz

Thanks for the reply Koz. This is what I have found out.

When I mix stereo down to mono, the blue waves do disappear - and I can no longer hear what I recorded. I have been using the internal mic.

Here is what I have discovered.

If I record using the internal mic, I cannot hear it played back on the internal speaker but I can hear it on the headphones. If I record using an exterior mic, the sound is very much quieter but I can hear it on both internal speaker and headphones.

Using the internal mic, the blue wavy lines are a lot bigger (stronger) - suggesting that the internal mic is a much better quality than the external mic. I am using the microphone boost. If I don’t, the recording is too quiet.

Does that make any sense? I cannot figure it.

Terry123

I have been using the internal mic…

…Does that make any sense? I cannot figure it.

No. :smiley: :smiley: :smiley:

I’m guessing there is only one speaker in your Notebook? Not separate left & right speakers?

Your left & right channels are out-of-phase (AKA one channel has reversed polarity). Or, if you think about speaker movement/vibration, one speaker pushes-out when the other pulls-in and vice-versa.

We know it’s a recording problem because when you did Koz’s experiment and mixed the left & right together for mono, they canceled-out to a flat line.

The left & right channels are mixed together if you have a single-mono speaker in your notebook. The same thing would happen on a phone speaker.

If you play it back on regular stereo speakers you’ll get a strange spacey/phasey effect as the soundwaves partially-cancel in the air. The bass (if any) will get almost completely canceled.

On headphones the left & right electrical signals (or acoustic soundwaves) never mix so you won’t hear anything unusual.

That should be impossible with the built-in mic. Did you use any effects, or did it get recorded that way?

It can happen with a stage/studio mic (XLR connector) plugged-into a stereo input because pro mics use a 3-wire balanced (“push-pull”) connection and the two signals are out-of-phase (not intended to be split left & right).

Does that make any sense? I cannot figure it.

As above, that should be impossible with the built-in microphone and speaker.

One more confirmation test. Select one place in the blue waves with sound. Use the Magnifier Tool and keep clicking on that one place so the waves get wider and wider. As you view closer and closer, you should see the up and down rhythm of the two waves are mirror-image of each other. They’re supposed to be exact copies.

You can fix this in Audacity, but the effect is so totally not supposed to be happening in the first place.

It’s one of the horror movie problems. You send a performance file to three different clients and one of them can’t play it for no known reason.


This is the adapter from Hell which can produce the same effect.

If the magnify test showed a mirror image, here’s how to correct the track.

Drop-down menu on the left > Split Stereo Track.

Select the bottom track by clicking just right of the up arrow.

Effect > Invert

Top track pull-down menu > Make Stereo Track. That should play anywhere.

Koz

Koz. Thank you for your suggestion but I could not get it to work.

When Audacity starts up, it does so with a split horizontal screen (divided by a broad line). That ‘Audio Track’ window (you showed me in your post) appears as soon as I click ‘record’. After recording with the internal mic, the blue wave lines in each window are a mirror image to each other. If I keep clicking the magnifier, the wave lines get stretched out in both windows.

I did follow your suggestion but when I get to click on ‘make stereo track’, nothing happens… There is a black spot on waveform.

I think though you have led me to resolve the problem (the emphasis on ‘I think’). It is a bit involved but I will do my best to explain.

After I record in Audacity using the internal mic – and then playback dragging the stereo slider to the left or to the right, I get increasing sound from the internal speaker. When it gets to the extreme right or extreme left, the sound is of a reasonable volume. If the slider is in the middle (where it defaults) I get no sound whatsoever. The volume is the same either extreme left or extreme right. It fades out to silence as the slider approaches the centre.

What I cannot work out is why I hear the sound OK with the headphones (both left and right)? – and why is the right one somewhat louder when I slide the stereo slider from left to right?

The other thing I cannot understand is that the top right volume register bar (not sure what you call it), when the stereo slider is to the right or to the left, registers accordingly, and I get sound, but when it is the middle, both green bars are registering equal volume but I get no sound. I would have thought that registering like that shows the recording was ok (but why no sound)?

It is the same with recording with the internal mic. The right and left green volume bars on the volume register are equal, making it look as though it is recording ok. It is all a bit of a mystery to me.

Thanks though for everything you have told me. I appreciate it. At least now I can hear sound from the internal speaker.

Terry123

Koz

I have an apology to make. Last night I posted explaining what was happening. I said I could not get your suggestion to work. This morning I have tried it and it works perfectly. I must have been doing something wrong. Sorry.

BTW, my post last night does not appear to have been posted on the forum yet

Thanks for the help. Sorry for the mess up.

Terry

my post last night does not appear to have been posted on the forum yet

New forum posts are moderated. Your post has to be accepted by an elf before it becomes visible. We got overwhelmed by spam and couldn’t keep up.

For Some Reason your laptop is producing a stereo show (two blue waves) with the Left and Right sound cancelling. As long as you don’t try to mix the performance to mono—such as one laptop speaker or listening on a smartphone, the sound should be OK, although it can have some odd aural effects like appearing to come from behind you. Anything you do to upset the volume balance will destroy the effect, such as throwing off the L/R slider.

You can also split the stereo track to mono (one of the options) and just delete one of the two tracks.

Koz

Thank you for all your help. It has been much appreciated. I shall need to experiment with Audacity to realise its full potential. No doubt I shall have more questions in the future.

Terry123

I moved the “Select Track button proposal” to its own new thread: https://forum.audacityteam.org/t/select-track-button-proposal/50151/1