Project is corrupt

Hi, I’ve just tried to reload a saved program and I get “project is corrupt.” I had exported it as a WAV as well and that WAV file is now basically empty of content.

Here’s the full message I get:

13:17:39: Error: Could not parse file “E:\Audacity\New Russian Flag.aup3”.
Error: Project is corrupt
(Unable to work with the blockfiles)
13:17:59: sqlite3 message: (11) database corruption at line 70749 of [7ebdfa80be]
13:17:59: sqlite3 message: (11) statement aborts at 8: [DELETE FROM sampleblocks WHERE NOT inset(blockid);] database disk image is malformed
13:17:59: DBConnection SetDBError
ErrorCode: 11
LastError: Project is corrupt
(Unable to work with the blockfiles)
LibraryError: database disk image is malformed

Previously I sent a .zip file of this as a private message to a user who sorted this out for me. I would really appreciate similar help if that’s possible!

Here’s a Google Drive link to a .zip file of the Audacity file if that helps.

So the good new is that in many cases you can fix this yourself. :smiley: Here are the instructions:

Hi, thanks for your help. I’ve managed to recover the file now with some help from a friend, and I can load it into Audacity but I can’t save or export the file. Every time I get an error saying Audacity failed to read a file in… whatever drive I’m trying.

Any ideas?

I’ve reinstalled Audacity to make sure i have the latest version, and then also restarted my computer. Same result.

I can re-record my audio tonight. It’s a major pain, but I can do it. My worry is that I’ll have the same problem again. Since I first had a problem with Audacity I’ve made recordings with no issue at all, so i’m not sure why it happened this time.

WAIT - it’s fixed now…I think.

I deleted the previously generated broken.recocvered file and redid the process. This time, even though I could open the new borken.recovered file I kept going with the additional steps and that seems to have done the trick.

Thank you!

I’m glad to hear you got it sorted. :smiley:

Hey, I’m new to the forum so I hope I’m doing the right thing, I have this issue also on an important project I’m working on… Jademan could you please help me if I zip and send the file somehow?

David, as I have said before: