Problems with multitrack (overdub) [SOLVED]

I have been a long time user of Audacity going back to a 32bit Windows XP desktop. It always worked perfectly over the years. But now I’m on a Lenovo laptop with Windows 7 and have the latest Audacity 2.0.6 installed. It plays back all my pre-recorded tracks and sessions from my old XP system and lets me tweak them and remix them. But yet for some reason I can’t record like I used anymore.

Shure microphone plugged into an 1/8th inch adapter, and then plugged directly into the external mic jack on the laptop
Track 1 records beautifully. Whatever instrument (rhythm guitar, keyboards, etc…) is fine.
Track 2 records but gets all choppy, cuts out, goes whisper quiet, comes back in again at normal recording level, etc… repeat… etc…

Test mic (fine). Test mic cable (fine). Test 1/8th inch adapter (fine). Test laptop (Windows 7) settings in the control panel (and they too are all fine).

Forgo the Shure mic and try using the built-in, internal, microphone on the Lenovo laptop (yeah, I know - it sounds like {censored} but what the heck). Same thing…
Track 1 records beautifully. Whatever instrument (rhythm guitar, keyboards, etc…) is fine.
Track 2 records but gets all choppy, cuts out, goes whisper quiet, comes back in again at normal recording level, etc… repeat… etc…

What happened with Audacity running on a 64bit Windows 7 laptop? Why are there so many problems now?

It’s possible to wander off in several directions. Do you mean “Track 2” as in the right channel of a stereo capture, or “Track 2” as in the first overdub timeline of a sound-on-sound session?

You should be capturing the microphones as mono. One bouncing red bar and one line of blue waves. Is that what you’re doing? My laptop has option to capture the built-in microphone as stereo should I so desire, but the external services are pure mono.


I’m sorry I wasn’t clear…

Both tracks are mono. Both tracks are the Shure microphone into the 1/8th adapter and then into the external mic jack on the laptop.

Track 1 MONO: Rhythm guitar.
Track 2 MONO: Bass guitar.
Headphones on or off, it makes no difference. If I get bleedover, I’m not that concerned at the moment. I just want Track 2 to record clearly and cleanly while Track 1 is playing.

If you post enough times without trying to sell us anything, the forum moderation will go away and your postings will appear immediately. I need to go back and read that again.

I’m more than even sure I know what’s happening, but the mystery is why it’s not happening to track one. The guide track or Rhythm Guitar.

Mic-In on a Win7 machine (or Vista, or Win8) is not just a hole where you pour microphone sound. Windows tries to “process” the sound so to make communications like Skype work better. It tries to do echo cancellation and noise removal… and it hates music.

I’m not a Windows elf, but this happens often enough we have a manual entry for it.

I would dust off my hands and go away but for one problem. Why didn’t it happen to the first guitar?

That may be your bleed problem. You should be listening to headphones and there should be zero bleed between the tracks (this is assuming your headphones can’t be heard down the hall in the kitchen. I know people who listen like that. I don’t know how without their ears starting to bleed.

Those kinds of problems are frequently cause by telling Audacity to record from “Stereo Mix” or other fake software device instead of the actual hardware Mic-In on the soundcard. You can check that with the Audacity Device Toolbar.

Stereo Mix is “Everything Playing on the Computer.” So your track two is really trying to record the bass guitar plus the rhythm guitar plus everything else that’s open in Windows Control Panels. That’s why when you said you might have bleed, my ears went up. That could be a settings problem.

Let us know.


Thanks… I am going to go to Lenovo’s website and see if they have updated audio drivers. That be another place to look…

No such luck… :frowning:

I went to Lenovo’s website and updated the audio drivers to the latest version, rebooted, tested various Windows sounds, played an MP3 tune, watched a You Tube video, and everything still works great


I don’t get this at all! Try this simple test… Heck, don’t even use an external mic. Just use the mic built into your laptop:


  1. Hit the record button on Audacity. Leave it as mono, it doesn’t matter for this test…
  2. Sing “Helloooooooooo” for about 10 seconds into the built in microphone.
  3. Stop the recording.
  4. Hit the record button again on Audacity. It will create another mono track on track 2. Again, leave it as mono for this simple test…
  5. Sing “Helloooooooooo” again but in a higher pitched voice, for about 10 seconds into the built in microphone.

In theory, you should be harmonizing with yourself in this simple test for 10 seconds. Track 1 is playing your first “Helloooooooo”, while you are recording your second “Hellooooooo”.

Both tracks should be crystal clear with no choppyness or cutting in and out… Maybe I should completely uninstall Audacity, reboot, come back and install a fresh version of it. I’m completely at a loss here… :frowning:

Assuming they’re two mono tracks, use the left-hand track drop-down > Make Stereo Track. Drag-select the first 6 seconds (assuming there’s a stutter) and File > Export Selection: WAV (Microsoft)… If that doesn’t include any damage, drag-select 6 seconds that does.

Post it here.

Are you trying to produce work at some super high quality rate? I’m assuming 44100, 16-bit, Stereo. If you’re trying to produce at 96000 and 24-bit Stereo, you may just be over-running the machine’s ability to keep up. Overdubbing needs carefully timed, bi-directional, real-time data streams. It can’t stop and wait while hard drive services catch up.


I just made a sample recording of me speaking to you and also strumming an acoustic guitar.

Track 1 Stereo: My voice talking to you and explaining the problem. :55 to 1:10 is me simply strumming on my guitar.

Track 2 Stereo: At :55 to 1:10 is an attempted overdub of me playing a quick little guitar solo or something over the guitar chords on Track 1.

Both tracks were recorded using my Lenovo laptop on Windows 7 and using the built in microphone. Nothing fancy… I was also wearing headphones so I could hear Track 1 play as I was recording Track 2.

Hopefully you can open up the file from that website called

Here’s another example…

I plugged my Fender Stratocaster straight into the mic jack (with 1/8" adapter) on my Lenovo laptop. Track 1 (not heard, not mixed down, not included) was me just playing a rockabilly guitar rhythm in the key of “A” in Mono. It recorded perfectly fine.

Track 2 is the main problem… Below is the clip of me playing a short rockabilly guitar solo/riff through headphones, while Track 1 was playing and Track 2 was recording. You can clearly hear how the electric guitar cuts in and out and the sound is all whacked out… :frowning:

What is going on with version 2.0.6???

Thank you for your test clips. This is from from first clip. I did see something that went by you. Attach #1 is a blast of odd sound just past 1:07. Attach 2 is the same segment where I told Audacity to show me serious overload (in red).

So something at that instant made the digital sound channel completely overload. I’m guessin’ that wasn’t you playing.

This is messy. I’ve never heard of anybody with that kind of distortion.

The third attach is what my Audacity looks like at the top. Can you do a screen capture of yours and post that either on the forum or somewhere.

Screen Shot 2015-03-02 at 12.07.45.png
Screen Shot 2015-03-02 at 11.59.57.png
Screen Shot 2015-03-02 at 11.59.38.png


I am having exactly the same problem trying to do exactly the same thing…like you I also had no problem doing it on my old XP computer using audacity…however I also have win 7 64 bit, I record my rhythm guitar on one track, play it back and it sounds just fine, clear and clean…as soon as I record a second track- in mono or stereo or left or right channel- it doesn’t matter, when I play it back with both tracks combined it sounds like a distorted mess of ugliness…I am thinking the only resolve is to dust off the old XP computer…

one thing I tried that worked a little, was to combine both files into a single track, then hit the “Normalize” feature, this seemed to clean up the distortion and weirdness some~

dust off the old XP computer…

Perfectly fine idea. Just don’t put it on the internet. Microsoft stopped issuing security updates and it’s a sitting duck.

I use WinXP and Win2K machines locally to do odd jobs that don’t require internet service. I have a local network that doesn’t go outside.


Have ButchA and wildwin looked carefully at

You might find that choosing recording hosts and sample rates carefully might help. Make sure you are using the same device for playback and recording, and make sure you have followed all Windows Sound setup instructions at

Were the tracks at different sample rates before you combined them?

If the machines are in warranty, get complaining and press for a replacement USB sound card. The manufacturers know they only pay a few cents for the built-in sound device. They may be prepared to pay $30 for a USB sound card to keep you quiet.


Good morning…

I got it! :smiley:

I contacted Lenovo and also the audio driver company (Conexant). I ran a few tests that they suggested, and had to the following:

  • Uninstall Audacity.
  • Reboot.
  • Test microphone (both built in and external mic jack), using the simple WIndows’ “Sound Recorder”. Recorded fine.
  • Run further test by plugging smartphone (headphone output) into external mic jack (input). Go into “Properties” and select “Listen To This Device”. Then play a ringtone or something. SOUND WAS ALL CHOPPY AND DISTORTED!
  • Contact Conexant and describe the problem. Download the latest Audio HD drivers for Win 7, version
  • Reboot.
  • Run same tests as before. SOUND WAS STILL CHOPPY AND DISTORTED!
  • Go back into Audio settings for recording (click Advanced). Uncheck the sections:
  • – Allow application to take exclusive control of this device
    – Give exclusive mode applications priority
    …and finally
    – Enable audio exhancements.
  • Save settings.
  • Run audio tests again using smartphone. TEST SUCCESSFUL!! No choppyness. Ring tone came through the laptop speakers with a hint of feedback (too close).
  • Go back to Audacity’s website and re-download version 2.0.6 and install.

Long story short… Audacity now works fine on my Lenovo Windows 7 laptop!!! :smiley:

Thanks for the update. I don’t think we were ever clear what host you were choosing in Audacity’s Device Toolbar or what project rate you were using.

In the case of unchecking those Exclusive Mode boxes, I would recommend making sure that the Default Format (above those Exclusive Mode boxes) is set to the same sample rate as your Audacity project rate. Otherwise, additional resampling between different rates will occur which could create a problem.

And you may want to make the same changes you made for the device in the Playback Tab, too (though if it ain’t broken, don’t fix it can also apply).

You disabled the enhancements or enabled them?

Also (with the “if it ain’t broken” caveat) I would assume drivers obtained from Conexant could be generic drivers not matched to your hardware, whereas the drivers from Lenovo would be matched. I just want to say for others reading this that in most cases, drivers from the computer manufacturer for your specific computer are much preferred to generic drivers supplied by a built-in sound device manufacturer.


Good evening,

Sorry about that, if I wasn’t clear or made a confusing post. I am using MME as the host. Conexant is the maker/company of the audio hardware device drivers FOR the Lenovo laptop. I just had to get the most current drivers and all is okay.

I always leave Audacity as default for its quality rate:
44100 Hz
32 bit float

I am just glad I got the issue solved. Not everyone has a Lenovo laptop though. What worked for me, might not work for others who also might be using Conexant SmartAudio HD for the audio drivers.

If I have time tomorrow, I will take some sample print-screen images and upload them so you all can see my settings and even show a multi-track recording session too.

Thank you all for the great help!

OK, but MME host should not be affected by the “Exclusive Mode” boxes, so this still suggests things “may” not be right. Normally, Lenovo should be giving you the download of the correct audio drivers for your motherboard Was that where you looked before? Of course there may be some reason why they don’t offer the correct drivers themselves.

OK so if you start hearing problems again, your may want to check that your Default Format for playing and recording in Windows is set to 44100 Hz too.