problem with solo/mute button interaction

Hello. I hope this will be clear.

I’m aware this is a general feedback thread but the 2.2 threads are locked as far as I can see so I can’t ask this kind of question there.

First, I have version 2.2.2. This was downloaded last week. As far as I know this is the latest version although I see there’s a 2.3 thread so I don’t know what that is.

I’m using W.10.

I’ve searched the forum and FAQ for info on this problem but can’t find the right answer. According to the manual there 3 options for mute/solo buttons but I can’t find them. Pressing the down arrow in the left hand track box does not bring them up. Nor do they appear to be in the menus up top.

This will be difficult to explain in every detail. It concerns the mute and solo buttons and how they interact.

On my previous version I could use the mute and solo buttons independently of each other on several tracks. Pressing one solo button, of course, mutes all other tracks. This is as it should be.

However, if I have quite a few tracks going, I might want to hear, say, two and not the others. Before, this was not a problem, Pressing the solo button on two or more tracks was fine. All other tracks were muted.

Now, apparently I can’t do this. Pressing one solo button is fine. If I want to do two it won’t let me. I can only have one track soloing at a time. Consequently I have to mute all the tracks I don’t want to hear manually. With many tracks open this becomes a bit tedious, as you can imagine.

There’s also something strange going on with the mute button. Pressing that apparently activates the solo button on another track, I think generally the first one. I haven’t quite fathomed this problem yet so bear with me. It looks as though it’s doing the ‘one solo button/mute other tracks’ in reverse. The trouble is that’s not always what one wants to happen.

Is there a way of going back to all buttons being independent? I think that’s the problem. The exception being that one solo button only mutes all other tracks.

I hope I’m being clear. And, by the way, I think Audacity is 100% terrific, I’d be lost without it. And I’m quite sure I haven’t unlocked many of its secrets yet.

Thanks for any assistance. I’d be happy to clarify anything that’s not clear.

As you are using the current version of Audacity on Windows, I have moved this to the Windows forum. Generally this will be the best forum board for you to post questions. (The 2.3.0 version is the pre-release development version and is not recommended for production use, just for testing).

The behaviour of the solo / mute buttons is set in Preferences:
“Edit menu > Preferences > Tracks > Track Behaviours”
More info in the manual here:

The default behaviour in old versions was “Multi-track”.

Thanks, Steve,

I read all that before but didn’t get it. Apologies. So Multi Track it is.

Thanks for your prompt reply. I wish I understood it all like you do!


Steve (and I) have been at this for about twelve years now - and we’re still learning :wink: :sunglasses: