Problem With Playback of Exported Music Files


First off, I have Windows Vista. As far as I can tell, I’ve correctly downloaded new version (2.0.0) of Audacity. Also, I’m pretty sure I’ve correctly downloaded the LAME encoder to export music as mp3s. So, I imported the song, did some editing, and saved the project. Then, went to file>export and saved the song as an “mp3 files” in the My Music folder where I put all my other mp3 songs. I press save and a warning comes up telling me im about to save an mp3 file that some programs will not open with nonstandard extensions, whatever that means. Am I sure? I click yes, and it starts exporting at 128kps. When its finished, I exit audacity and go to my music to see the new file.

This is the problem: when I open up my music folder, the file is there, but thats just it–its just a file, not an actual mp3. Therefore, it will not open up in itunes so i cant get it to a cd or my ipod.

Any idea what the problem is?


Since you are using iTunes and iPod I wouldn’t bother exporting MP3.

I export WAVs from Audacity (44.1kHz 16-bit stereo PCM - Red Book standard for CDs) then I can either burn CDs with these or import them into iTunes and then use iTunes to convert the WAVs to AAC (you can set iTunes to convert to MP3 rather than Apple’s AAC if you prefer). Apart from anything else iTunes does the compression faster.

See this workflow tutorial I wrote for the manual a while back:


You probably have a dot in the file name when exporting. The warning Audacity gives you is that since there is a dot in the file name, everything after it will be used as the file extension and that Audacity will not add any “.mp3” to the end. It is that little “.mp3” at the end that tells Windows what kind of file it is.

By default Windows hides file extensions. You are advised to change that behavior.

  • Open Folder Options by clicking the Start button , clicking Control Panel, clicking Appearance and Personalization, and then clicking Folder Options.
  • Click the View tab, and then, under Advanced settings…
  • Clear the Hide extensions for known file types check box, and then click OK.

Then you can simply rename the file to add the “.mp3” to the end; click the file, hit F2 to make the name editable, hit End to place the cursor at the end and type in “.mp3”. Hit Enter or click outside the file to save the new name (or hit Esc to abort editing).


Thanks, Ragnar.

Next time someone asks this, we have a FAQ you can link to directly:


Brilliant, totally brilliant! Thanks Ragnar! You rock.