Please help get rid of this bizarre buzzing during playback

Howdy, okay I am using a Mac OS X and using audacity 2.0.5.
My issue is this I’ve been using audacity for a few years but in the last three months it has developed this problem where an insane electrical buzzing occurs while I playback what I recorded. If I export the song the buzzing isn’t there. This also happens very randomly… Sometimes I won’t happen for a few days and then all of a sudden it’s just there again. I’ve used different interfaces like the focusrite 2i2 and the zoom h4n and it has happen on both. I’ve tried restarting audacity and my computer but the buzzing just remains unless I start a whole new project. But I’m at the point now where it just keeps coming back… I feel so frustrated!!! Ahhhh! Please help, thank you.

Which OS-X and which computer? I’m typing on a MacBook Pro with OS-X 10.9.2.

Oh! I’m using a MacBook Pro 10.8.5

Do any of the tracks not start at time zero (there is empty space before the song starts)?

If so, try pressing HOME on the keyboard then drag select a little way from time zero and Generate > Silence.

You could also try Audacity > Preferences: Recording and try different “Audio to buffer” settings (they affect playback too).

If all your tracks start at zero, did you install Mavericks over earlier OS X? Reinstalling Mavericks may help cure audio problems.

On Mavericks, Scarlett recommend using standard Core Audio USB drivers. See: .


Okay, well all the songs start at 0 so i don’t think that’s it. Sorry to ask, I’m just not certain what maverick is. I looked in my application and searched my hard drive but nothing of maverick nature came up. Should I try installing that? I’m messing around with different “audio to buffer” settings but haven’t accomplished much yet. thanks so much for your help. I really appreciate it.

Oh, sorry I see now you are on OS X 10.8 (it was Koz who is on Mavericks). “Mavericks” is OS X 10.9.

OK. If all your tracks start at zero there may not be an easy solution.

Do you get the same problem if you set the output device in Device Toolbar to your built-in audio?

If you set external devices as your playback device then you must make sure the sample rate settings match everywhere. Set Audacity Project Rate (bottom left) to 44100 Hz. Open /Applications/Audio MIDI Setup, then select the Scarlett. In the “Output” side, set the “Format” to 44100 Hz. Set Zoom output to 44100 Hz too.

If the Zoom or Scarlett have sample rate playback settings on the device, set those to 44100 Hz too.

Try running the MacBook Pro on mains power if you are running on batteries, or batteries if you are running on mains.


Dang… So I checked the sample rate and it’s still at its default of 44100 hz, I didn’t see a sample rate on the scarlette or the h4n. I get the buzzing no matter which export I use except with the scarlette it’s way worse. The buzzing doesn’t seem to be effected by battery or main power. So I was thinking of unistalling and then reinstalling audacity to see if that will help.

You said before there was no buzzing in the exported file. If there is buzzing in the export you may be recording the buzzing.

Just to be clear, if you have multiple tracks, their volume combines. Make sure on the green playback meter that the red clipping lights are not coming on. If there is clipping, turn down the -…+ gain slider on each track. See: Audacity Manual .

The important thing is that sample rates match. So if 48000 Hz suited your devices better you would choose 48000 Hz everywhere. The manual for the devices may say what its “native” or preferred rate is.

Occasionally you may need to match the bit depth too. So choose the bit depth (16 or 24) in Audio MIDI Setup, and choose the same depth at “Default Sample Format” at Audacity > Preferences: Quality.

Can you use the built-in output just to play back?

That won’t change anything. To reset Audacity settings, “initialise” the audacity.cfg settings file by replacing all its text with:


This page explains how to do that: .

If nothing else works, let us know if 2.0.2 or 2.0.3 have the same problem:
Google Code Archive - Long-term storage for Google Code Project Hosting. .