Recordings on playback choppy, skipping

Looking closely at the sample “garbled.mp3”, it is not the typical “skipping”.
The most common form of “skipping” is that some part of the system is not working fast enough so fragments of audio are missing. In the case of “garbled.mp3” there are bits missing, but also some parts are repeated.

This looks more like a problem with the sound card drivers than with speed.

Did you download and install the “Scarlett USB 2.0 - OSX 10.9 Mavericks” and “Focusrite USB 2.0 Driver” from here: Focusrite | Focusrite Downloads

If the correct drivers don’t help, look at the “Audio to buffer” setting in Audacity’s Recording Preferences and buffer settings in Scarlett if you can access buffer settings.


Gale

Hi, I downloaded the latest drives for the 2i2 and the problem persists. I’ll try the buffer settings now.

I am having the same problem - choppy playback on Audacity 2.0.5. I use a Mac Pro and the OS X 10.9.1. I’ve not had the problem with Audacity 2.0.3. It began showing up on 2.0.4, so I just went back to 2.0.3. Now 2.0.5 still has this problem with my system. Back to 2.0.3 again, which has worked great for me.

I am playing 24 bit/96kHz uncompressed .aiff sound files. They play fine using the Finder “Quick Look” feature. They also work fine in iTunes.I don’t know what to set the buffer to. It all worked fine in Audacity 2.0.3.

I have not tried recording with this new version yet. First I want to make sure it will play back, and so far it has not.

As far as I can tell there may be a specific problem with Mac Pro and Mavericks. It doesn’t show up with Mavericks and Mac Mini.

If the problem is the specific one with Mac Pro and Mavericks, changing the buffer will likely fix it. Possibly reducing the buffer to say 50 ms will cure it - it did for one user. If you can, please experiment with different buffer settings and let us know.


Gale

That solved the problem. Thanks!

:slight_smile:

I used the 50 figure you recommended. It appears to work. Since I don’t really understand how it works, I don’t know how to experiment. I’d be happy to do so if I knew what to expect or what would be accomplished by trying other figures. Thanks again.

When playing audio, the buffer is a chunk of audio data waiting for the computer to send it to the sound card’s output.

If the sound card finishes playing the buffer before the computer sends it another chunk of data, you’ll get gaps in the playback.

So generally, the lower the buffer, the faster the computer has to work to keep serving the buffer to the sound card on time. The higher the buffer, the smoother the playback even on slow machines, but the longer it takes for the sound to become audible. You can prove that by setting Audio to buffer in Audacity to 5000 ms. That will probably also cure the choppy playback, but it will take about five seconds before you hear any playback, and the cursor in the waves won’t relate to the audio you’re hearing.

See “Buffers: The Basics” on http://www.soundonsound.com/sos/jan05/articles/pcmusician.htm if you need more explanation.

It’s somewhat unexpected that lowering the Audio to buffer prevents clicks, but the explanation could be that Mavericks internal audio buffering (and/or Scarlett audio buffering in Simpstuck’s case) are conflicting somehow with Audacity’s setting.


Gale

I am having the same problem. It started after I took the latest update to my OS for my Macbook Pro to Maverick. I wonder if that messed up my settings? I will adjust the record buffer to 50 from 100 and see if that resolves my issue.

Well, changing the record buffer from 100 to 50 in Audacity did not make a difference. Back to researching.

Are you sure the problem is not in the audio itself? Have you zoomed right in to see if there are flat line gaps in the audio, or if there are abrupt changes of level in the audio dots?

What playback device are you using in Audacity?

The update to Mavericks won’t modify Audacity settings.

It’s hard to comment without more information as suggested above, but you could also try increasing the buffer to more than 100. It’s up to you to experiment with different values. They will vary from device to device.


Gale

I’m running a Macbook Pro OS x 10.9.1 with Audacity 2.0.2 and I use a Focusrite Scarlett 2i2 USB interface. I’m using an AKG Perception P220 mic. I’m using the Built-in Output for the playback device. I have narrated and produced 3 audiobooks and several commercials with this set up without a problem. The Mac is used basically only for my audio production so there shouldn’t have been any other changes to the system that I can think of. They only updates have been installed recently are the OS, iMovie, iPhoto, Voice Update - Yannick, Voice Update - Anna, and iBooks Update. So the only thing that I can think of that would have caused the change would have been one of the updates.

When I have Audacity set up to record for a project I don’t change any of the Audacity settings. All my recordings prior to the recent updates sound fine. looking at the wav forms I don’t see anything unusual.

I think the update messed up my Scarlett 2i2 drivers because everything records fine through built in mic. I’ll do some testing and let you know.

Hi all,

So if you are running OSX Mavericks, you will want to put your Scarlett interface into Class Compliant Mode. This essentially runs the unit using Apples Core Audio Driver (as opposed to the native driver) which generally produces a more-stable result.

Head over to Focusrite.com/downloads>Select Scarlett 2i2>Download ClassCompliantMode.App.Zip > Unzip, unplug your Scarlett and run the Apple Script.



Let me know if this works for you guys!


Cheers!

Miles

Thanks. The latest Audacity is 2.0.5 Audacity ® | Download for Mac OS . You may want to try the zip of 2.0.5 and see how you get on with it before replacing 2.0.2 with it.

A few people on Mac find that playback after version 2.0.3 is crackly on multiple tracks or tracks that don’t start at zero, but that isn’t a specific Mavericks and Mac Pro issue. There is no fix as no-one on Audacity Team can reproduce the issue.


Gale

Hi Miles,

Can you explain what the native driver is? Does that mean that specific instructions provided by your USB 2.0 driver are ignored, or that your USB 2.0 driver is disabled?

Are you aware of Core Audio buffering changes in Mavericks that specifically affect Macbook Pro?


Gale

Thanks everyone. I was just coming here to post about the Class Compliant Mode but I see someone beat me to it. Here is what Focusrite had to say about it:

Using a Scarlett Interface on OS X 10.9 Mavericks
Some users have reported experiencing audio glitches and drop outs with the Scarlett range of interfaces since updating to OS X 10.9 Mavericks. If you are experiencing these problems with your interface, it is possible to utilise Apple’s USB audio driver by downloading and running the class compliant mode application below, while we investigate further.

Please note: After the class compliant mode application has been unzipped, please right click on the application and choose “Open”. If you do not do this you may get an error message from the Apple Gatekeeper service.

Gale, thanks, I’ll update Audacity.
Jim

Hi Guys,

well…there you have it! From what you symptoms you provided there, it does seem that you might achieve a higher stability by going into Class Compliant mode - of course, it can be reversed at any point by simply reinstalling drivers, should you want to!


Cheers,

Miles

Apparently 30ms in some cases … Funny playback from imported wav file

21.5-inch iMac
OSX 10.9.4
Audacity 2.0.6

Had a horrible skipping problem after years of trouble free use with older Audacity. I tried everything including slowing the sampling rate to 16 bit but nothing worked. Then saw this post and changed the buffer to 50 and the skipping was gone, but there was still a faint rhythmic click like every few seconds. So I lowered it to 30 and it seems that problem is gone, too. Thanks!