Playing along backing tracks


my set up is:

guitar>focusrite Solo>laptop

I have no problems recording my guitar input in audacity, but when I click record button with MP3 (serve as my backing track), the error is popping. could anyone help me on this problem. this is my first time to use audacity.

i already match the input/output of my device and also trying the microphone privacy settings. but still in can not play along with my MP3.

It would be good knowing exactly what the error said, but Overdubbing usually fails because the Audacity Record and Playback settings both have to be set, correct and match. No fair having one at 44100 and the other at 48000, for example.



the MP3 (my backing track I like to play along) is 44100 while the new track (which im recording) is in 48000. overdub is already check and the device is matching with my focusrite still the below error is appearing.


and whenever I click “OK”


i already match the rate to 44100 but still no luck.

also in 48000 still no luck

i also tried to add “STEREO TRACK” for my recording track so that it will match to MP3 stereo but still not working. i just downloaded the audacity yesterday version 2.3.0

any advice regarding this problem?

thank you

In the Windows Sound Control Panel, look for the focusrite in both the recording and playback tabs and check what the sample rate is set at for each.

What settings do you have in the device toolbar?

How are you listening to playback? Headphones plugged into the focusrite?

In the “Transport menu > Transport Options”, “Overdub” should be enabled and “Software Playthrough” should be disabled - do you have it set like that?

hello steve

im using headphone most of the time.

Audio Host: Windows Direct
Recording Device: Line-in Scarlette Solo
Recording Channel: Stereo
Playback Device: Line-out Scarlette Solo

I also check the overdub and uncheck the Software Playthrough

still not working.

Plugged in where?

Hello Steve,

Im plugging my headset and guitar to focusrite. then into USB port of my laptop.

Did you do that? Did you find the sample rates for the recording and playback devices? What are they?

Hi steve

thanks for replying.

yes I did that and check the rate of each. both have 16 bit 44100. and I matched to audacity track. 16bit 44100.

track for MP3 (for my backing track): 16bit 44100
track for new track (for recording my guitar) 16bit 44100

still error

Did you match the “Project Rate” to 44100?
(“Project Rate” is in the lower left corner of the main Audacity window)

hello steve

yes. I set all to 44100 hz.

but still whenever I click the button it will have an error

when I set all of them to same rate (44100)

and then click the record button, the record will start at the end of my MP3. I does not record under the MP3 waveform. I hope I explain in clear way. my apologies.

That is normal. To record to a new track, hold down the “Shift” key and click the record button.

If you can’t get overdubbing to work without an error, it’s possible you have a different mismatch than any of the normal ones.

When you overdub, Audacity has to play the backing track to the interface perfectly at the same time it records the new performance. The Solo is a native mono device. It’s job in life is to record your single microphone. It has a Stereo variation where you can plug your guitar in, too, but that’s not the main mode.

Try setting Audacity to mono and mix down your backing track (temporarily) to mono at 44100. See if that starts working, or also important, if you get a different error.


thanks steve and kozikowski.

I press the shift and click the record button and now its working with the backing track. I can see my guitar signal under my mp3 backing track.

thanks for help. appreciate it!

There’s something wrong about that. I need to do some experimenting. You shouldn’t need to do that.


In Audacity 2.3.0, by default (there’s a preference setting to change this) recording to a new track requires the “Shift” key to be held down.
(In old versions of Audacity, the Shift key had to be held down to “append” record to the same track).

(there’s a preference setting to change this)

See this page in the Audacity Manual re the preference setting:

And this page about Recording: