Pass Through Sound

I cannot figure out the pass through function. I have a lot of old tapes I want to transfer to CD with an ION Tape2PC which does a great job on Mint with Audacity 2. The only problem is that I cannot hear what I am recording !

There is no way in Audacity to both record in Stereo AND play what it is recording.
I find this weird. Whgat is the use of recording something you cannot monitor ?

If I go into settings and activate the “Pass through” feature, then Audacity will not record. If I switch it off then Audacity records in Stereo.

Is there another way to monitor with your defaults soundcard a tape source played through USB ?
The USB soundcard is available in the sound devices on Linux Sond config, but there is no way to pass it to the soundcard either.

I was hoping that Audacity would do it as it is intuitive that someone would like to listen to what he/she records, similarly to someone wanting to “see where they driving to” and not just blindly navigate the roads.


Preferences > Recording > [X] Playthrough. Its job is to connect the recording to the playback so you can hear what you’re doing. I’ve never heard of a recording dropping dead if you do that.

Are you sure you’re recording your actual sound device and not “Everything Playing On The Computer?” The settings for recording a real device and the settings to record YouTube Sound are different.


And make sure you set the output device to be your computer’s speakers and not the ION tape device. Most computers assume that you want to use a USB device for both input and output.

This tutorial from the Audacity manual should be useful to you:


It’s fairly common on Linux. Audacity always uses PortAudio’s default latency values when software playthrough is on (the “Audio to buffer” setting in Audacity’s Recording Preferences is ignored). The PortAudio latencies for Linux are much more ambitious than on Windows, so recordings can be glitched.

Steve may know if there are better ways to monitor using PulseAudio volume control. Would using JACK help?


You should be able to achieve very low latency using Jack. Even with my cheap laptop and even cheaper on-board sound card I get 23.2 milliseconds (hardly noticeable) very reliably and stable, or down to around 11 ms if I’m not stressing the machine. On a good machine it should be possible to get the latency down even further.

However, for recording a USB cassette, low latency is not required, so it is less bother to not use Jack.
Just set the recording input to the “hw” option that corresponds to the USB device and the output (playback) device to the “hw” option that corresponds with the computer sound card, which is usually (hw:0,0). Check that recording and playback are working correctly. If they are, then enable “software playthrough” in the Transport menu.

IMPORTANT: When using the “hw” options, only one program will be able to access the sound card. Ensure that no other audio programs are running (this includes your web browser if Flash player has been used in the current session and remains loaded). The easiest way to get this running is to log out then log back in again, and start Audacity before opening any other programs. Avoid visiting any web pages that use flash (such as YouTube) while you are recording. Attempting to use other audio programs at the same time will probably cause the error:
“Error while opening sound device. Please check
the input device settings and the project sample

As a point of detail, would I expect any other choice than (hw) for a USB audio device input? On my Ubuntu 13.10 netbook, the “pulse”, “default” and “sysdefault” input choices still record the internal microphone when I connect my USB turntable.

Hopefully the (hw) choice for the built-in audio card will solve the problem for playthrough, as it will provide direct access to the playback device, bypassing the “pulseaudio” intermediate layer.


Well now you did hear about it. There is always a first time.
In fact it has always been a problem on Linux.
As soon as you activate the pass through it will not record in stereo period. There is not even any cursor movement in the recording window.
Of course I read the manual.
It did not help in this case though so I decided to ask the usergroup.

Gale, thank you I will try your recommendations. I do not use Jack as it is a bit convoluted, but it might solve the problem as you suggested.

It is not an intrinsic problem on Linux. It works fine for me on Debian.
Have you tried what I suggested yet?

Yes I tried it. No change, and to add if I select the sound pass-through then Audacity loses all it’s toolbar tabs except “File” but it disp;lays File as “FI”, and I can drop down the menu, but it clearly show some strange behavior which can only be code issues.
I am running Mint16 and the latest Audacity.

I have been a Linux user since 1997, and started using Audacity about 4 years ago. Although it is a great program to do multitrack editing on and I use it dayly to record and compare ideas, the pass-through never worked accross sevral flavors of linux namely FC, RedHat, Debian, Mint/Ubuntu, Slack, that is including use over several terminals and servers ranging from IBM X-series servers with 16G memory (in case that becomes an excuse), Lenovo and IBM laptops, Aopen minipc’s, Apple Intel Macs and more.

That specific feature never worked for me, in fact when I switched on the sound pass-through it hard-hangs some of the computers. I had that particular one again this morning and it happened last year on other pc’s as well.
I do not have these problems with Audacity on windows, although I dont use windows since 1997 and only have it around for software that doesnt work properly such as Audacity on Linux or is unavailable on Linux such as Audiobox and other software IO mixers.

I add a screenshot of what Audacity menus do when you activate sound pass-through.

You mean when you enable Software Playthrough in Audacity Preferences? If so that is a wxGTK 2.8.12 bug, but Audacity 2.0.5 or later has worked around that so it won’t happen there.


I think you may mean that you are running the latest Audacity version that Mint 16 distro provides. What version does Help > About Audacity say?

You can change many playback and recording choices more conveniently by using the Transport Menu.

Does Audacity for Windows run on Mint under WINE fail with software playthrough enabled?

It’s a simple change if you want to recompile Audacity and turn off the PortAudio latency settings for software playthrough, but we don’t know for sure that is the issue.

If you launch Audacity from the terminal then try to record with software playthrough enabled, what messages appear in the terminal?


If that was only the singular problem. It sometimes hard freezes my pc. Something software hasn’t done to Linux around here since advent of USB 1 so that version is pretty screwed up.

Ok, I used the latest 2.x from apt and that is not the latest stable it seems.
I looked at Audacity website for a stable repository URL but could only get a repository for the latest unstable.
Any idea if there is a stable version repository ?

Also, Ardour uses jack properly on the same machine, but Audacity does not even have jack available in the device dropdowns.
Ardour is just too heavy and convoluted. I like Audacity, due to it’s simplicity and flat idiot-proof menu rather than the Protools like touchy-feely spoof interface of Ardour which intentionally tries to intelectualize the obvious. Audacity is the greatest for simple tasks, but this sound-through code needs to be rewritten. Someone knows little about devices and device-drivers it seems.

The Audacity version in Mint 16 is 2.0.3 (by coincidence I installed Mint for someone earlier today).
The current version of Audacity is 2.0.5.
There is no official repository version for Mint with Audacity 2.0.5.

That must be more than an Audacity problem. As I said, I’ve had Audacity freeze up due to its problems with PulseAudio, but I’ve never had a system freeze when running release versions of Audacity on Ubuntu, Debian, Mint, or any other distribution.

Jack should be running before you open Audacity (recommended) or if you open Audacity first you will need to use “Transport > Rescan Audio Devices”. “Jack Audio System” will then be available in the “Host” settings of the device toolbar.

In order to record from a USB device using Jack you need the USB device as the “Input device” for Jack and your sound card as the playback device. In Audacity set both input and output devices to “system”.

Note that there is a bug open for Audacity with Jack which is that if you click on the recording meter before doing any recording, Audacity will probably crash. This is noted in the wiki (though this page is rather out of date, this issue with Jack is still present: Missing features - Audacity Support)

I agree that Audacity on Linux would greatly benefit from some expert attention to handling the sound system (either by Audacity or Portaudio developers, or both, but the problems that you appear to be experiencing seem to go far beyond the limitations experienced by other Linux users, so I strongly suspect that there is some other underlying problem with the machine.

Audacity no longer has “stable” and “unstable” distinctions for released versions.

We only release what we consider to be “as good as a stable” version. If the distro does not offer the latest released version, then the user can uninstall the repository version and compile the release source tarball (2.0.5 at present):
Redirecting to: .

Optionally a user can compile Audacity from the SVN development code: Redirecting to: . This latest code is not “released”, although compiled binaries therefrom for Windows and Mac are made available by volunteers for those who do not wish to compile code. Ubuntu make compiled “Daily Builds” available in a similar way.

Builds or binaries from latest code are designated as “alpha” in “About Audacity” in the program. You can regard them as “unstable” but they are potentially more “unstable” than builds from a project that was releasing “stable” and “unstable” versions.

I’ve already given one possible reason why software playthrough fails on Linux. If you want to compile Audacity I’ll tell you what to change. If the Windows build of Audacity under WINE records with software playthrough on, then I think the PortAudio latencies are quite likely the cause.

You haven’t clearly stated what happens when you record with Software Playthrough on. Do you see “error opening sound device” or does the recording cursor stall, or does it record but you don’t get playthrough? What are the terminal messages that you see?

Can you record from the built-in sound device (choosing the (hw) input) with Software Playthrough on?

Can Ardour play a one second tone completely without adding silence to the end of it?


Yes, but so does Audacity when using Jack.
The most obvious difference between the two is that the audio sockets in Ardour are persistent whereas for Audacity they appear on play/record then disappear on stop. So Ardour connects to the sound system once (at the start of the session), then disconnects on quit, whereas Audacity is repeatedly connecting/disconnecting then connecting again (with new sockets) every time the audio stream starts/stops.