Opening m4a files[SOLVED]

I have 2.03 it was working fine until today. Suddenly it no longer opens m4a files. Mp3 and aiff work fine. m4a show up but when played only give me 2-3 seconds of gibberish. I can’t do anything with the files at all. I wiped out my copy of Audacity and reinstalled it. No luck. Is there a setting that has changed?

You probably managed to delete separate FFMpeg software which is required to open and play M4A files. Or FFMpeg is still there and you have to tell Fresh Audacity where it is.


Thanks, I did that and it still won’t work :frowning:, I’ll try anything.

Which “that?” Download fresh or point Audacity? Where did you put the FFMpeg software? It should be a folder with a long name. What is the name?


On Mac you can tell Audacity in the Extended Import Preferences to try the QuickTime importer first for M4A files, so you don’t have to use FFmpeg for importing M4A files.

To do that, press “Add new rule” and type:


in the text box under “File extensions”.

Then in the “Importer order” list, drag “QuickTime files” to the top of the list.

Now, uncheck the box “Attempt to use filter in OpenFile…”. This ensures QuickTime will always be tried first for M4A, whatever you have the file filter set to when opening or importing files. Finally, click OK.


Thank you VERY much that worked! :smiley:

It always helps to know which “that”? The Extended Import Preferences or finding FFmpeg?

You still need FFmpeg to export M4A.


The new rule tip. I had everything loading and the *.M4A was the missing piece, thanks again Gale!

OK,thanks for replying, I will mark it [SOLVED] then.

FFmpeg “should” be able to import M4A containing AAC, but M4A is a “container” format, so your file might have included some other format than AAC, which might trouble FFmpeg.