iTunes Import Problem

What’s the show and where did it come from? If you have more than one reason to believe the show itself maybe damaged, then the show may be damaged.

Koz

Attached iTunes AAC test file. Plays and opens beautifully everywhere. This is a vinyl transfer, so it’s not going to win any Grammys for sound quality.

Koz

…Um, I don’t understand the replies. It doesn’t matter what show or album the song was from, or whether or not it was mastered for iTunes. What matters is that every AAC song in my iTunes Library, when imported into Audacity, shows up as this piece of **** waveform, completely ruined. I don’t understand it at all, and I just need some help fixing it. If it helps, I’ve tried uninstalling and re-installing both the latest versions of Audacity and the ffmpeg plug-in at least twice, even deleting the program folders from my computer. Nothing has changed. I just need a straight answer. If there is something I need to delete, reinstall, or uninstall, or if it’s a programming error that needs to be debugged, I just need someone to help me.

Moderator note: please do not swear when writing on the Forum, it is considered bad netiquette here where we try to keep this a sane amd family-friendly corner of cyberspace. I removed your unnecessary expletive.

We can’t give a “straight answer” without knowing more about the problem. Currently there are lots of possibilities.

Please turn off “Show Clipping” in the Audacity “View” menu, and post another screenshot.

You could try downloading and opening any of the sample AAC audio files available for example from http://mympxplayer.org/image-df543.html, or http://download.wavetlan.com/SVV/Media/HTTP/http-aac.htm
If these files play correctly in Audacity, this means that your own AAC files somehow are corrupted.

Which is why I posted the sample AAC file from my iTunes library. If it plays correctly, then there may be something wrong with your libarary files.
Koz

It matters a lot wher tge source files com from. I’m suspecting that the AAC files you have are loading intpo Audacity have had the life compressed out of them due to the current “loudness wars” ( see Loudness war - Wikipedia ) and have been amplified or normalized to the maximum 0dB.

The red clip lines don’t always mean that clipping has occurred and that 0dB has ben exceeded - it can be just that the signal has reached 0dB at those points (a lot in your case.

Try selecting the audio and then using the Normalize effect to set the maximum level to say -3 or -2 dB

WC

Okay, I think I found something. I just discovered a log, describing the complex process of importing an AAC audio file into Audacity. Multiple errors popped up. Is the problem in one of those errors? Here is the screenshot:
FFmpeg errors.jpg

No, those are not errors. That is Audacity looking to see if you have FFmpeg installed. You do, and Audacity finds it.

Wait, my mistake, I did that wrong. Here’s the log while I import an AAC audio file:
Error Full.jpg

That says that the file was opened successfully.
As I wrote previously, it would be useful if you would post a screenshot of the waveform with “Show Clipping” turned off.

What happened when you imported that short iTunes AAC music file I posted?
Koz

Did you try Normalizing to -2db or -3dB as I suggested :question:

Okay, I’ve made another discovery. When I imported my audio files before, under “Import/Export” in Preferences, I had it set up so Audacity would “make a copy of uncompressed audio files before editing” and “normalize all tracks in project”. This would result in the bizarre glitch that turned the imported song into the piece-of-s***-soundwave seen in prior pics. However, when I uncheck the previously mentioned boxes, and checked the box “read uncompressed audio files directly from the original”, this soundwave popped up instead (see photo attachment). This doesn’t fix the problem, but I think it’s a step in the right direction. No, I have no idea what else I can tell anyone that could help. As I can recall, everything was working just hunky-dory until, out of the blue, this godforsaken program acted like a stubborn pig and wouldn’t work the way it should. I am desperate at this point. Somebody please help!!!
Preferences.jpg

Sorry, I can’t help without your cooperation. If you don’t follow advice or provide the information requested then there is nothing that we can do to help.

The “read uncompressed audio files directly from the original” option does not apply to AAC files.

If you used Effect > Normalize… once at -2 dB then turned “normalize all tracks in project” on again, all your songs would import at a peak of -2 dB and would not then appear red when you turn Show Clipping on.

What edits are you trying to make to these AAC files? If it is just cutting a piece out, you can do that in other software without losing quality by re-encoding the file.


Gale

Never mind, solution found in other thread: https://forum.audacityteam.org/t/opening-m4a-files-solved/30009/1

So the problem that everyone missed until now in your log iTunes Import Problem - #11 by truckin72 was that the MP3 importer (libmad) was importing the M4A file?

I can’t imagine how that would happen. A file with M4A extension that is legitimately MP3 audio in an MP4 container, or is an MP3 file misnamed as M4A, imports with FFmpeg (libav) for me.


Gale

Okay, here’s how the problem started: somehow, under “Extended Import Preferences”, under “File extensions”, there was no extension for the .m4a format. After checking the forum I linked to, I clicked “Add new rule” and added the extension for .m4a files back in. I don’t know when or how it was removed from the list, but I must have been poking around with it and removed it from the list, messing everything up. I’m sorry for coming off as a jerk, but I didn’t fully understand what was wrong and thought I was getting the runaround on this forum. Anyway, marked this problem as solved or something, I’m signing off.
Extended Import Preferences.jpg

Thanks for the explanation.

So you know for future, this is what happened.

That “Extended Import Preferences” do not need to be set under normal circumstances. When you drag a file into Audacity, it automatically decides the most appropriate importer to use by looking at the extension of the file (WAV, MP3, M4A or whatever).

Without using Extended Import Preferences, you have extra flexibility if you use Open or Import from the File Menu instead of dragging files in. You can then choose “FFmpeg-compatible files” in the “Files of type” selector to force FFmpeg to try to import the file, even if it’s an MP3 or WAV for which Audacity would normally use its own MP3 or WAV importer.

What I think you did is to add

*.m4a

as a rule. That makes Audacity import any M4A files trying each importer in the order shown in the list. MP3 files is above FFmpeg in the list, and when the MP3 importer tries the file it actually opens it but the audio imports as noise a fraction of a second long because the MP3 importer does not understand M4A.

That looks like an Audacity bug - we should not let libmad take MP4/M4A. However for some reason on Mac, although the log says that libmad opened the file successfully, it fails to do so and therefore FFmpeg gets a chance to import the file.

What you have now done is to add a rule

.m4a

That rule says to open a file called “.m4a” using the importer order shown in the Extended Import Preferences, otherwise to use the normal rules to decide the importer based on the file extension. Since you can’t have a file name starting with a dot on Windows, that rule is equivalent to having no rule, and M4A files import normally again using FFmpeg.


Gale