Opening a file via keyboard shortcut corrupts project file irreversibly


in Audacity v and v3.0.4.0 I have the following weird problem:

I know 6 different ways to open an Audacity project file (aup3) on a Mac:

– Double-clicking on the file when Audacity is NOT running → okay
– Double-clicking on the file when Audacity is running → PROBLEM no. 1
– Dragging the file on the app icon is NOT running → okay
– Dragging the file on the app icon is running → PROBLEM no. 1
– When Audacity is running, using the menu entry File/Open → okay
– When Audacity is running, using the keyboard shortcut Cmd-O and the following open dialog → PROBLEM no. 2

PROBLEM no. 1, Result:
The file is not opened, but stays intact in the finder (= file size is unaltered)

PROBLEM no. 2, Result:
The file is not opened, the project window is grey, the file size in the finder is still unaltered. But after closing the Audacity project window, the file size itself is reduced to 328 kB, no matter how big the file was before!

macOS 10.15.7 Catalina
iMac (Retina 5K, 27 Zoll, Late 2015)
3,3 GHz Quad-Core Intel Core i5

See video, if wanted:
Video (134 MB):
Video (4 MB):

Can anyone reproduce this?


Problem 1 is known.

I cannot reproduce problem # 2. Does this happen with any AUP3 file, or just that one?

– Bill

Thx 4 replying, Bill!

Yes, problem #2 occurs with every AUP3. :frowning:

Additional info:
I also tried this on a freshy created user on my iMac: same problem.
Tomorrow, I will have access to another iMac with 10.15, which I will use for a test as well.

You didn’t say what the content was. Try this. Open a fresh Audacity. Generate > Noise.
Screen Shot 2021-08-29 at 17.58.02.png
Command-D Duplicate the track. Drop-down from the left of the top track > Make Stereo Track.

Save it. That should give you an AUP3 file of about 107 MB. Ten minutes of noise.

Are you using 44100 for the sampling rate in the lower left of Audacity?

Close and re-open Audacity and see if Command-O opens the new file without the Hindenburg Effect.


Are you using a Mac internal drive? If not, where is the drive and what kind is it?


Hi Koz,

I followed your detailed instructions, thank you.
No changes, the behaviour is exactly the same. I am left with an empty file, 328 kB of size:

Maybe a file analysis by a specialist could help?

Here are the answers to your questions:
– I am using 44100 sampling rate
– So far, I used the internal drive (2.12 TB Fusion Drive). Now, I did some more tests with two external USB drives: the outcome was the same.

„Hindenburg Effect“: is that the official term for that? :slight_smile:


Perhaps obviously, as the file is so small, there is no recoverable data present.

Was your project based on an older (think 2.4.2) .aup project that was converted to .aup3? Or did you start with a recording or a .WAV file. If so, what version did you start with?

This is a potentially serious issue so I have brought this to the attention of the developers.

Hello jademan,

until your post, I only used completely newly recorded audio files, all recorded with Audacity v3.0.0.0. or or

So, I did some further testing:

TEST 1 „v2 project“
After your post I did a test with an old Audacity v2.x project.
Audacity 2 project file (aup) opens fine via menu, but opening it via Cmd-O reproduces the problem: project window is empty, when the file is closed the size is down to 328 kB.

TEST 2 „v2 → v3“
I opened the v2 project and saved it as a v3 project. Then I Cmd-O-opened the v3 project with the same result: file empty, size 328 kB.

TEST 3 „MP3 to AUP3“
I dropped a MP3 on the Audacity ( icon and saved the audio as an v3 project. Opening it via the menu or dropping on the app icon works fine. But opening it via Cmd-O reproduces the problem.

TEST 4 „Big Sur“
And another test on Big Sur:
I can even reproduce this problem on Big Sur, booted from an external USB drive. See video, if helpful.

TEST 5 „Audacity v3.0.0.0“ – SURPRISE! –
On my current iMac (see above specs), I now installed an older version of Audacity 3 (v, which I found in my backup.
Now comes the surprise: Cmd-O does open the file correctly and leaves the file untouched after closing the file! :sunglasses:

So, this behaviour occurs on my iMac when using Audacity v3.0.3.0 and v on both macOS 10.15.7 (Catalina) as well as Big Sur, but not with v3.0.0.0 (on Catalina).

If the developers sent me Audacity versions between and, I would offer to test with these as well to further narrow down the problem. (I could not find any of theses vintage versions on the website.)

Thanks for your help!


You don’t need the devekopers to send you these - you can get them from here:

Note that 3.0.1 wa skipped and never relased (it was buggy)


Thank you, Peter. I will hav a look at it later on. I am now AFK for several hours.

I downloaded Audacity v for Mac and made a test, but same problem.

So, v3.0.0.0 is the last (on my iMac) that does not destroy a AUP3 file when opening it with Cmd-O.

It was said that v 3.0.1 was buggy and therefore a developer release only. The question now is:

– Was the problem already in v 3.0.1?

And a another, more generell question:
– Can anyone reproduce this problem on macOS 10.15 or Big Sur? Or is it just my system?

„Hindenburg Effect“: is that the official term for that?

That’s an overactive sense of free association. You’re gazing sadly at the smoldering wreckage of what used to be your show.

That also gives me the “Yeti Curse” for a particular flavor of USB sound damage. That was an accident of marketing. Blue Yeti is an insanely popular USB microphone and thus many of the errors appeared on Yetis. There’s nothing wrong with the microphone.

It can make events and circumstances easier to remember. One of the Noise Reduction settings sometimes associated with audiobooks I called "Noise Reduction of the Beast (6, 6, 6).

But free association can sometimes reveal solutions.

Since nobody else can reproduce your problem, what else do you have on your machine that could be trying to capture or “share” your keyboard commands? Do you like Skype, Zoom, or Meetings? Those are famous for taking over your computer settings and not asking.

While Zoom is running, it’s not “your” Mac any more.

Are these Zoom recordings?



I have just been informed that the developers have been able to reproduce this bug and consider it a P1 regression bug, which should get their highest priority. They have created a Issue Report which you can follow here: The project file is being corrupt if it's opened while Audacity is running. · Issue #1571 · audacity/audacity · GitHub

Hey Koz,

thanks for explaining Hindenburg Effect. :slight_smile:


The problem occurs with AUP3-recordings of Internet Radio Streams recorded form Apple’s Music with the help of Soundflower (2ch) via a Motu M2 (digital-analogue converter). It also occurs with new AUP3 projects, when dropping audio files like MP3 or AIFF onto Audacity.

Apps on my Mac:
no such things as Skype, Zoom, or Meetings.

Candidates for sharing or altering keyboard commands are:
– Default Folder
– Typinator
I will look for others, …

… BUT: As it does not happen with v3.0.0.0 on my Mac (only with later versions of Audacity) AND as it as well happens also on a totally fresh and clean new installation of Big Sur, I doubt that the source for this problem lays in another software.

hello jademan, thanks for the info.

If I can assist with further testing, let me know. Glad to help!

It’s good someone else can reproduce the problem. Especially since it’s a developer.

Let’s hope 3.0.5 also helps the worst of the slowdown problems. Those will take your show away from you without the fireworks.


The bug report implies that one needs to open two files using the Cmd-O shortcut and the second one will be corrupted. I still can’t reproduce this on macOS 11.5.2 and Audacity 3.0.4.

– Bill

I still can’t reproduce this on macOS 11.5.2 and Audacity 3.0.4.

One Mac? I couldn’t do it using Audacity 3.0.4 on two different earlier Macs.

I didn’t try opening two shows like that.


Screen Shot 2021-08-30 at 5.30.54 PM.png
When I try that, it opens up two different Audacity windows and I get two WAL files. No corruption.

This is me hiding under the bed.


Like Koz, I cannot reproduce this on W10 with 3.1.0 alpha audacity-win-3.1.0-alpha-20210831+6d3dd0c-64bit

Both projects open fine - no corruption that I can detect.