Nyquist effects missing

Those are all Nyquist effects.
Has there been an error message: “Critical Nyquist files missing” ?

I’ve updated the topic title to better describe the problem.

Could you post the Audacity “log”:

  1. Launch Audacity
  2. “Help menu > Show Log”
  3. Save the log somewhere convenient on your computer, then attach it to your reply (See: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1)

Hi Steve,

There has been no error message.
Log attached.
log.txt (2.51 KB)

OK, but there is such an error in the log file (second line):

17:37:33: Audacity 2.1.2
17:37:33: Warning: Critical Nyquist files could not be found. Nyquist effects will not work.

I ‘think’ this problem is due to permission changes in Sierra.
When you installed Audacity 2.1.2, was it the first time that Audacity had been installed on that machine, or were you updating a previous version of Audacity?

There are three possible solutions that have been reported to work.

The easiest but least likely - reboot.

Or right-click or CONTROL-click over Audacity.app, click “Show Package Contents”, expand the “Contents” and “MacOS” folders then double-click the “Audacity” shell application. The Terminal will open then Audacity will launch.

Or it’s possible that files in the Audacity app have the xattribute “xattr com.apple.quarantine” set. This means that Gatekeeper blocks them. To fix it, open a Terminal (Applications > Utilities : Terminal.app) then type or paste:

sudo xattr -r -d com.apple.quarantine /Applications/Audacity/

and hit ENTER on your keyboard. Type your admin password (you won’t see it on the screen) then hit ENTER again.

Please let us know if this helps (and the answer to Steve’s question about whether this is a first installation of Audacity). Also is Sierra an upgrade over a previous version of Mac OS X?


Hi Gale,

Thank you for your response.

To cut to the chase, your third suggestion (with amendment) worked and I am now up and running.

To answer your (and Steve’s) questions: –

The computer is a late 2009 iMac on which I’d installed Sierra a few weeks ago.

Thereafter I installed Audacity 2.1.2. No prior version had been installed, although, as I said, I attempted to solve the problem by uninstalling and reinstalling Audacity.

Neither of the your first two suggestions worked(Reboot and via “Show Package Contents”).

In case other people following this thread have the same problem, I digress to report that I had some difficulty with the suggested third solution, probably because I have absolutely no experience of Apple’s Terminal. I tried entering the words “CODE: SELECT ALL” but Terminal would not accept the instruction. I then tried to enter the remainder of the code you suggested and Terminal requested a password, but did not accept the correct password. After a bit of a run around the net looking for a solution, I changed my password and thereafter everything worked.

I suspect you already know this, but the primary problem appears to be one which Apple identifies as a “Repackaging Problem”. You may find the video below interesting. The specific issue is discussed at about minute 22 or soon after.

The video reference is


Many thanks again for the assistance.

You just have to enter the text in green “as is”. The Select All link is just a convenience so you can correctly select all the text then copy it for pasting into the terminal.

The main thing about passwords that confuses first-time users of the terminal is that you can’t see the password you are typing in, so it is easy to enter the password incorrectly.

Thanks for the video reference. Firstly, contrary to that video, the Gatekeeper option to “open anyway” if an app is not from Apple Store or not from an “identified developer” has not been restored to the Gatekeeper Preferences dialogue in Sierra. The option is now hidden as a Terminal command.

I assume from the video that the “repackaging problem” is actually intentional, in that “external” libraries or plugins outside the resource are not allowed to be used. The Nyquist and Plug-ins folders are of course not in the Audacity.app/Contents/Resources folder. The Nyquist and Plug-ins folders would be seen by Audacity if put there (but users would not then be able to add Nyquist plugins conveniently). I somewhat doubt that is really the problem but it would need testing on a new Sierra installation that never had Audacity before, or perhaps by removing all the Gatekeeper references to Audacity. It could still be a random Gatekeeper bug.

The video suggests that codesigning the DMG (making sure sufficient objects within it are codesigned) is a resolution to the “repackaging problem”. If so then it’s possible that 2.1.3 when released may not have this problem, because it is our intention to codesign, though not necessarily as an “identified” (meaning paid for) developer.


Im having the same issue as well, only after following the advice from page 1- i am now seeing the plugins listed in the “add/remove plugins” window… but after clicking “enable” and then “ok” the plugins still aren’t usable.

1.Even if i click enable and OK…
Screen Shot 2016-11-13 at 7.51.26 PM.png
2.When i open the prompt again it still says “New”
Screen Shot 2016-11-13 at 7.51.36 PM.png

Is this your first ever install of Audacity on this startup disk?

Do the plugins on the USB drive get enabled?

What is the exact version of OS X/macOS that you have? Look at Apple menu > About this Mac.

Which of the solutions have you tried from https://forum.audacityteam.org/t/nyquist-effects-missing/43925/9 ? Removing the quarantine xattribute is the most likely to work.

If that does not help, make sure you check in the AppStore app for latest updates to your operating system.

And if that does not help, does 2.1.3-alpha have the same problem? Try “audacity-macosx-2.1.3-3a99837.zip” or “audacity-macosx-2.1.3-3a99837.dmg” from http://www.audacity.homerow.net/index.php?dir=mac/audacity-nightly-2016.11.14-06.00-3a99837/.


Oh wow, a new version!

I downloaded that and it still doesn’t seem to be working.

I just purchased this laptop a few days ago so this is my first Audcaity install on this, yes. (2015 Macbook Pro running on Sierra v10.12.1)

Initially when i would open Audacity the plugins that i’d dragged into the plugins folder weren’t even showing up in the list of plugins when looking for them in Audacity. The Nyquist prompt wasn’t showing either.

However, I tried the Quarantine tip (xattr -r -d com.apple.quarantine /Applications/Audacity/) and then the plugins, along with the Nyquist prompt reappeared. But now when i click “add/remove plugins” and then “enable” next to the plugin, then “OK”-I still don’t see any of the plugins (noisegate.ny for example) in the list of things that i can use. After this, when i click on “add/remove plugins” again, it just shows the plugins that i enabled as “new”.

Have you tried rebooting? It is possible that is needed for the xattribute change to take effect.


That didn’t seem to fix it either. I suppose i could try doing the “xattribute” once again to see if anything different happens this time. This is so frustrating.

Edit: Holy crap!!! That fixed it somehow.

It seem to be working fine now. Thank you guys so much for all of your help. :smiley:

i’m still having some similar issues on Mac OSX El Cap in that none of Steve Daulton effects will work. checked all files and [*] in libs , both sys lib and user lib and even copied those missing to multiple locations in other dirs. they are showing up in add remove effects and appear to enable but do not add to effect menu. running add remove and they are back to showing “new”. this is on newer versions od audacity 2.12 and above. ran an older build 2.11 and before and those effects appear in menu and do work in those builds. any idea what is going on with this?

See this post for solutions: https://forum.audacityteam.org/t/nyquist-effects-missing/43925/9

To be clear, we don’t make any “2.11” and “2.12” version. Audacity 2.1.2 (and 2.1.1) may be obtained from http://www.audacityteam.org/download/mac.

The issue addressed in https://forum.audacityteam.org/t/nyquist-effects-missing/43925/9 has only ever been reported in Sierra, and in 2.1.1 too, so I am not sure it is the same issue. Also please be aware of the correct locations for installing Nyquist plugins, The simplest place to put them is in the Audacity “Plug-Ins” folder. They will not be seen in your user Library or the system Library. Also make sure Nyquist effects are enabled in Effects Preferences.


Answer is a yes to trying the above. Yes, I stand corrected in versioning, I am referring to builds 2.1.2 and above. Plugins are located in correct paths, both in user libs, sys libs and in the Audacity application folder, under applications/audcatiy/plug-ins and also in applications/audacity/nyquist. Am trying the xattribute fix and rebooting but so far not enabling those specific ones only. My current version of Audacity is 2.1.3-alpha-Oct 1 2016. Will try and dl a newer 2.1.3 from Mac OSX nightly Audacity build page and see if that helps.

None of those are the correct place to put Nyquist plugins, except for /Applications/Audacity/Plug-ins, assuming that is what you meant to write.

It is best to write our paths fully and carefully, without abbreviations, to save confusion.


sorry correction to my spelling. They are located in applications/audacity/plug-ins. Then additionally I copied them to the user and system libs in audio/plugins. I thought I saw by default they are listed as applications/audacity/nyquist, when I unzipped the nightly build? I could swear they were outside the applications/audacity/plug-ins folder out of the zip file. In any case they are copied to the correct directories and everything else is just overkill and reaching to see why they arent working anymore. I did try the xattribute terminal solution proposed and after reboot, running add/remove effects and enabling them, they are still not showing up as enabled or listing in the effects menu at all. Running add/remove effects again shows them as still with “new” status.

We have indicated that Nyquist plugins are not to be installed in Library folders. Remove them from there.

Perhaps you should check that you ran the xattributes command correctly:

xattr -r -d com.apple.quarantine /Applications/Audacity/

Reboot after running the command.

Also it would probably be a good idea to quit Audacity, delete the file ~/Library/Application Support/audacity/pluginregistry.cfg then start over enabling the effects in Plug-in Manager.

You can also right-click or CTRL-click > Get Info over any plugin to see the permissions that different users have on the file.