Numark TTUSB + Audacity + MacBook Pro laptop OS X 5.5


I have a Numark TTUSB turntable + Audacity + MacBook Pro laptop Mac OS X 5.5.

Everytime I record into Audacity via the USB connection, the sound distorts heavily after a while.

Can anyone help me?


In the search box (top right corner of this page) type the words
ion usb
then press the search button.

21 pages of results, mostly discussing this problem.

Thanks, BUT:

Seems like the solution is to go analog.

But the whole purpose of buying the TTUSB turntable is to record via USB. I have another turntable, so knowing this, I would’ve kept my money!

So please, I would like to know a solution to record via USB into Audacity (or into another program) without the crazy distortion.

Thanks again.

The problem appears to be with the USB interface in the turntable.
If it is less than a year old you could try having it replaced, or money back under the warranty.

Not all of these units have the problem, and often they will work with one computer but not another. The issue seems to be that the interface is very borderline when it comes to stability. A good friend of mine has one of these turntables and has had no problem at all with it, but as you see from other posts, not everyone has been so lucky.

I agree with Steve, I would try and get you money back. I started off buying an ION iTTUSB (same company as Numark) to do my LP transciptions. I gave up after while - actullay the setup worked and recorded fine - but the TT gave far too much wow&flutter. I resurrected my old Technics/SME deck and arm and my pre-amp out of the attic (and treated it to a new catridge plus a home overhaul) - but I also bought an external USB soundcard (an Edirol UA-1EX) which cost less than half the price of the ION TT. This setup works fine for me and produces excellent results.


Thanks guys, this is really appreciated.

Seems to me like it could be a Mac Os X 10.5.5 thing (or a Intel processor thing? : my MacBook Pro is an Intel based computer), because my Numark TTUSB works fine with my PPC G5 Tower running on Mac Os X 10.4.11!

I have a Saffire Firewire external audio interface. So I guess that I either:

01_ Get my money back;
02_ Exchange the turntable with another one;
03_ Hook-up my TTUSB into my Saffire via the line RCA jacks, and connect the audio interface into my computer via the Firewire.


I wrote to Numark. Let’s see what they’ll tell me.

Much appreciated. Thanks again.

Qn: is your original TT better than the Numark one - and do you have a preamp with phono input (necessary for the RIAA equalizsation)? If so, then I would go for option 1 if possible.

Option 2 may give tou the same problems as you have now

Option 3 - as you yourself pointed out earlier this wastes some of the Numark’s functionality - namely the Analog-to-Digital-Converter (you will still be using the pre-amp that is buried in the Numark).

Another thought: have you tried using diferent USB input ports on your MAC? Since you say the TT works fine when pluged into your PC, I would then suspect the USB services on your MAC.


Unfortunately, my original turntable isn’t better than my Numark TTUSB.

I haven’t tried another USB input on my laptop yet (both of my computers are MACs: the tower is a PPC, and the laptop is intel based and has a newer operating system). I’ll do that later on today. Thanks!

I just got an answer from Numark: “The issue you are having has to do with the MacOSX USB audio drivers. The only fix is to downgrade the drivers. Attached to this email is the Downgrade USB drivers and a PDF of a step by step tutorial on how to resolve the issue.”

So looks like I have to DOWNGRADE my USB drivers! I can’t believe that! I bought a brand new computer (MACs don’t come cheap!), and I have to downgrade it because of a cheap turntable!

I am stunned!

Please do let us know how you get on.

On the box of the TTUSB, it says: “Mac OS 9 or higher, one available USB 1.1 port or higher”.

I refuse to downgrade my 3000$ computer because of this 150$ turntable. I’m writing them again.

So I got another answer from the people at Numark:

"I understand your concerns but, this is actually a Mac OSX problem. They upgraded the USB audio drivers and now everyone is having problems with their USB drivers. Here are some forums on the issue you are having. + "

On the box of the TTUSB, it says: “Mac OS 9 or higher, one available USB 1.1 port or higher”.

My laptop has exactly that. If it had said on the box: “You will have to downgrade the USB ports of your computer”, I realistically would’nt have bought this turntable.

The wrong information is written on the box and I end up wasting time and money on this issue.

Ah well… I guess I lost the war.

Can you use it on one of your other computers?

Yes, but I bought the laptop especially for my music studio (my tower PPC is for my graphic design studio, my business, what I earn my living with) to facilitate and to separate everything. So yes, I can sample into my tower, but that means hooking my laptop and my tower together every time after sampling to transfer docuemnts.

Now, it looks like my laptop won’t be used… unless I downgrade my USB ports, which I probably will. And when I will, Apple will probably come up with a fix, and my ports will be downgraded for nothing. Pfff… But from I read in the forums, this seems not to be linked to MACs only, right? PC users seem to have that problem to.

So I’m kind of angry at Numark for selling their products with malfunctions and with false information (technical requirements) on the boxes.

Oh yes, there’s plenty of PC users that have problems with USB turntables. The problem is typically bursts of static like noise that happens randomly. Some users have it worse than others. In some cases it is very intermittent, but for others it can happen almost immediately.

There have been all manor of “fixes” for individual users, such as using a different USB port (on the same machine) / connecting via a powered USB hub / connecting directly without a USB hub / only recording on a Wednesday and wearing a blue shirt… The thing is that there has been no consistent pattern. It seems to me that the USB port is just very borderline when it comes to stability, at least on some of these units. As I think I mentioned before, some users have no problem at all, they just plug in and it works - unfortunately not the case for all users.

Perhaps the older USB drivers for your Mac will be a bit more tolerant than the newer drivers and it will fix the issue for you - I sincerely hope so. I shall be watching this thread with interest to see how it goes. Good luck.

or you could by one of those portable USB disks to transfer the files between the two …


The suggestion about the USB key is excellent. Thank you!

I tried sampling on my laptop today via both available USB ports today and it all worked fine. And I didn’t even reboot my laptop since the last time!

So I guess the bottom line is this: 1) companies should develop products with stable USB interfaces, and 2) companies should develop products that follow certain standards so things like that don’t happen anymore.

In this case, Apple and Numark should’ve developed their products on the same USB interface standard so both machines work together. Is it Apple’s fault for wanting to upgrade their USB interfaces? Is it Numark’s fault for using old USB interfaces? Should’ve representatives of both companies talked to each other? Did Apple make the switch too fast? Should computers have one port with the old interface and another one with the new to insure compatibility with all peripherals?

But it’s not only an Apple problem like the Numark representative wanted me to believe because PC users have the same problem.

So I say this: “Numark… Make the USB interface of your machines stable and compatible with computers!”

Hi all, I currently have a HP Pavilion laptop running on Windows XP and I want to use the internet through an Ethernet cord for a faster connection. The wireless internet works just fine, but when I connect one end of the Ethernet cord in the router and the other in my laptop, my internet suddenly stops working. How do I enable a wired internet connection on my laptop?

jumbika , your question is totally off topic, has nothing at all to do with the question being discussed, and has nothing to do with Audacity. Read the manual, or ask in a forum that is relevant to your question.

I too have the intermittent static problem, but not with the Numark, rather a Stanton T.90 USB turn table. OSX 10.5.5 iMac, 4GB memory, Audacity 1.3.5d, temp files on iMac hard drive.
If I hit the “pause” button, while recording, so sound continues to come out through the speakers, static stops.
Tried turning off the software play through (though it makes monitoring a bit hard). Still happens.
Tried head phones, tried all three USB ports. Tried putting my left leg in, then taking it out, then shaking it. Even tried 15century motets.
The other week all was butterflies and flowers. This week it’s been as up and down as the Down Jones index – butterflies and flowers not in evidence.
Lots of web cruising resulting in company in misery, but no solutions. Maybe I’ll try temp files in a RAM disk.

Cheers all

Hi! I have been having the “noise” issue after recording 2:00 minutes while using 1.3.6b. Input is using USB CODEC. Turntable is Ion TTUSB10.

I downgraded to v 1.2.5 Mac Intel. No I am recording using the same settings but no more noise.

I also noticed that the USB CODEC - Core Audio does automatic leveling, so I am unable make any adjustments to the input level. Not sure how good this will be, but so far sounds pretty good.