Noise when recording stereo-mix

When I record system audio with stereo-mix, there is a noise throughout the recording. It’s not really annoying or noticeable, except if there is a silence or when using headphones. I’ve added a sample of only the noise, you might have to increase volume to the max to hear it. Is there any way I can get rid of that noise without using filters or effects like noise removal? And if not, what settings should I use?

I’m recording with the Windows WDM-KS setting and Audacity 2.0.4 for Windows 7 (32-bit on 64-bit machine). I also have a filter/effect/equalizer (not sure how to call it) active called SRS Audio Sandbox. Even when I turn that thing off or uninstall it, the noise stays.

Frying mosquitoes. We’re getting to be old friends with this. Typically that happens with a USB microphone and rarely with a line-level device. It’s computer digital housekeeping getting into the sound. I’m fairly sure about that because when it happens to me, I can hear my computer shifting gears for different tasks.

We’re not entirely sure how it gets into the show. It’s a chimera. Every time we get close, it changes into something else. We were almost 100% sure it was caused by digital interference leaking down the USB cable right up to the day I got it with a system that had no cable.

Stereo Mix is a deadly service to troubleshoot because you’re recording “The Computer” and everything in it. At minimum, the sound is going through the computer twice: once in the playback service and then again in the record. Two opportunities to pick up trash.

So we know in the very generic sense what it is, but there’s no clue how to cure it. It’s wide band enough that Noise Removal only helps a little bit and then only until the noise changes. Remember, Noise Removal only works on noises that do not change over time.

Your particular show might benefit from Noise Removal. Pick the first value, noise reduction in the 9-12-18 (gentle) range to avoid damage to the show.


Use Wasapi loopback instead.
The recording is almost bit-perfect.
I don’t know, is it available in version 2.0.4 (I’m on 2.0.6 alpha)?

WASAPI loopback should be available in 2.0.4 - but you’d probably be better off anyway upgrading to the current release 2.0.5 which you can get from here:


You should definitely try WASAPI - but are you saying you don’t hear that noise in headphones when listening, without recording?


Unplugged all the cables I could remove from my computer one by one to see if something causes that noise, but it doesn’t stop. If I add some cheap USB device to my computer I can hear a high pitched noise, but that’s gone when removing it and it only affects my headphones, not my speakers or the Audacity recording.

The reason I still use 2.0.4 is because that’s the only version where I can get the WDM-KS recording option. Also, I can’t record stereo-mix with the WASAPI option, only the output of the speaker. If I select the SRS Audio Sandbox output the audio volume is way to low, even if I set everything to the max.

I’ll try the noise removal solution

I can hear some noise coming out of my speakers and headphones when not recording, but it’s less then I get when I do. When I add a silence to my recording, it also creates the noise. It doesn’t matter what encoder I use. I even got that noise on some audio I edited that was recorded, where no noise was present before editing.

What does that mean? WASAPI is meant for recording computer playback from any device, not just the built-in audio. You should at least try it, because (I think) it captures the sound before it gets to the sound card, as opposed to stereo mix which merely sends a copy of the output to the input once the output is already playing.

What is the sound source you are recording - web browser?

Please check that the built-in sound device has the correct drivers supplied by the computer manufacturer (if you are using a branded computer like Dell or HP) or by the motherboard manufacturer (if you built the computer yourself). See Missing features - Audacity Support .

Also look in your sound card control panel and turn off all filters and effects.

Turn Skype off if you have it.


It could be either hardware or software related issue.
Did you assemble the computer? Some motherboards feature the HD audio so be sure that internal cabling is set properly (and firmly) also if the HD audio is connected to the front case panel be sure that settings are right.
Then the BIOS has to be set to use or not the HD audio according to your computer setup, check Windows recording properties and only enable the device you’re recording from.