Noise Gate Plugin - not showing up in Effects Menu [SOLVED]


I’ve just downloaded the Noise Gate file for Mac using the ZIP folder because the Download link only gives a text file and not the .ny file. This is the link:

However, once I am putting the Noise Gate plugin file into Audacity Plugins folder, while it does show in the Plugins Folder, when I open Audacity (after having closed it down and reopening). I cannot see Noisegate in the Effects menu.

When I click in Add / Remove Plugins, to enable NoiseGate, again, I cannot find Noise Gate in the Effects drop down menu.

Please can you advise?

Kind Regards

Hi there

I’m using Mac OS Sierra Version 10.12.6


And I’m using Audacity Version 2.1.3.


Attached my copy of Noise Gate 3.0.

Noisegate.ny (8.56 KB)

Nyquist plugins are plain text files with “,ny” file extension. If macOS adds a “.txt” file extension you can just rename it back to “whatever.ny”

Or what I perceive to be versions 3. Versions and Revisions are different in Nyquist.


Thank you Koz - I reinstalled the version you sent but I’m still not seeing Noisegate in my Effects dropdown menu to enable it …

I’m trying to clean up the sound re: breathing and clicks, etc. on a podcast without any background music.

Is there another simple and easy way I can do this without using Silence under Generate dropdown menu?

It’s an hour long podcast and I don’t want to go through each and every sentence.


Hi there

I am having this problem too. I had a look at the online manual and it mentions going to Add / Remove Plugins to enable or disable installed plugins, but this menu item is completely missing under Effect, Generate and Analyze on my version of Audacity (2.1.0)

Thanks in advance for any assistance

That’s because 2.2.0 did not have that feature.

It came in with 2.1.1 and was called “Manage” then

In 2.1.2 the nomenclature was changed to the "Add/Remove Plug-ins

All of those versions are way out of date and superseded (Unless you are visually impaired and need screen reader functionality - in which case 2.1.1 is the current version).

I suggest you download the latest Audacity version 2.2.0 from here:


Thanks very much for your help. I’m not sure how I ended up with an old version of Audacity since I only installed it a few weeks ago! I must have clicked on the wrong link.

Thanks for your assistance :slight_smile:


I’m seeing a similar problem when trying to add the Acx-check.ny plug-in. Firstly there was no Plug-Ins folder in my /Library/Application Support/audacity/ folder so I created one. When I downloaded the Acx-check.ny plug-in and moved it to the Plug-Ins folder I could not see the plug-in under the the Analyze → Add/Remove plug-ins… menu even if I restarted Audacity. I have version 2.2.0


Wrong folder. That’s the system-wide folder. You want your user library folder, which is at ~/Library/Application Support/audacity/. The “~” character at the start is important.
– Bill

Thanks Bill. When I look under the Users folder and my account name there is no Library folder so perhaps I’m still looking in the wrong place.

Mac hides the user Library folder by default.

In the Finder, click the Go menu while holding down the option key. “Library” should appear as an option in the menu. Select it.

If that doesn’t work, do Go > Go to Folder and type “~/Library/Application Support/audacity” into the dialog. Don’t forget the “~” character at the start.

– Bill

Thanks very much Bill - that worked!