No Instrument sound when using Behringer UMC22


And please forgive me if this has been addressed…I have been search for hours.

I am using the Behringer UMC22 to plug into the USB port on my PC with Win 10 (64bit). Recording in stereo in Audacity. The driver is the standard USB CODEC. No other drivers installed.

The mic channel on the device works great using either the mic or an electric guitar. The instrument channel gives no sound level in Audacity at all. I tried phantom power on/off, monitor on/off. I can hear the instrument through headphones fine.

Both the mic and the instrument work when using another DAW (Studio one), but I like Audacity and want to use it.

Tried going into the Win sound settings and get nothing for the instrument (mic in). Tried setting it to 2 channel stereo…but it will not (even with Audacity not on). It is set to 1 channel 41k (CD quality). But, again, all works fine with Studio One.

Can anyone help?

Thank you, and Happy New Year.


Do you mean there is no option to set the device to “2 channel stereo” in the Recording tab of the Windows Sound Control Panel? There “should” be an option to do that.


Thank you for the note. There is an option to do that…but when I do it, I get a message that says device in use. I select and hit “apply.” But, when I go back and check…it is still in 1 channel.

I do not have audacity of anything else open.

I can see the green input light, light up, on the umc22, but nothing on the audio input in Win. If I put the mic in the XLR mic input…get signal…but still cannot select 2 channel.


Thank you for the reply

There is an option to set to 2 channel…however, every time I try to do so, I get a ‘device in use’ message and it does not take.

I have nothing open on my machine.

If I have the mic on using the umc22, the win mic input show signal. But, not with the instrument input, even without the mic in.

Thank you

Where are you looking? Please post a screenshot so I can see what you are looking at.

Settings> Sound> Input > Device properties > Advanced

On my version of Windows 10, “Settings” only has the options:

  • System
  • Personalisation
  • Gaming
  • Update and Security

If I go to:
“Settings > System > Sound”
I can select which audio device I want to use in the “Input” (Exmple: “Microphone (USB Audio Codec)”), and then choose “Device Properties”.
That brings up this window:

I can then select the “Advanced” tab, and select “2 Channels 16-bit 44100 Hz (CD Quality)” here:


Yes, thank you. That is it exactly. However, I can select 2 channel (CD) but when I hit ‘apply’ it says device in use and the change does not take.

I go to task manager and there is nothing open.

Not sure what to do next…or why this works fine with Studio One.

Really like Audacity, though. Also, if I save the file as an mp3 in Studio one, I can bring it up in audacity and both the voice and guitar play. Sounds very good. And great tools to work on the file with…really like that. Wish I could record both with it.

It looks like Microsoft have made a total mess of this.

Try this, but ensure that all other programs are closed before you start (my computer crashed on one of my attempts, even though this is a clean and fully updated Windows 10 testing machine - there appear to be system level bugs here).

  1. Right click on the loudspeaker icon in the Taskbar and select “Open Sound Settings”
  2. Click on the link “Sound Control Panel”
  3. Close the “Sound Settings” window.
  4. In “Sound Control Panel”, select the “Recording” tab
  5. Ensure that the default device is set to any available device that is NOT the device that you want to change.
  6. Right click on the device that you want to change and select “Properties”
  7. Select the “Advanced” tab
  8. Select the Channels / sample rate that you require
  9. Click “OK”


That did it !

Amazing. Cannot thank you enough. Wow. NOW I can use Audacity…this was a big help.

Thank you very much. Should put this in the FAQ’s.


I’ve already escalated this to Audacity’s QA guys. This has not been documented before as it appears to be a fairly new Windows 10 bug.

Not sure about that till we get to do some more testing - I did some testing today HP Envy SSD W10

I can’t test Steve’s Steps for changing the recording device settings as my new(ish) HP laptop only allows me to have recording input at 16-bit 48000Hz with the onboard soundcard - the dropdown is grayed-out and inoperable.
Later I also tried my external USB soundcard (Edirol UA-1EX) and that was the same with recording settings

For playback however, while my Edirol will only allow 16-bit 48000 Hz my onboard soundcard output has the option of 16-bit 4800 and 24-bit 4800, I appear to be able to switch between the two settings (even though the onboard soundcard mic is set as the default) and both settings seem to facilitate playback.

The first time I did it I got the warning that the device was in use by another app and if I changed it that app may lose sound - but I was able to OK that and the change was made.

Audacity seems to play quite happily regardless of whether the soundcard is set to 16-bit or 24-bit - and iTunes plays with either setting too.

So on this PC it looks like a warning that can be overridden rather than a no-can-do bug by Microsoft.

But jolly glad we got you fixed and working with Steve’s workaround, navigate40


That used to happen here too, but not now. No new software on the test machine other than updates. I now need to dance this merry dance: No Instrument sound when using Behringer UMC22 - #9 by steve

If we create an FAQ for this we can add you “merry dance” as a workaround that may be needed by some users,


I just bought the UMC22 and had the same problem on my Windows 10 PC. Fixed it perfectly by downloading this Beringer driver:

In the process I had to also download the LAME for Windows, but the driver installer guided me through that. All works perfectly now after a couple of days of frustration. Did my first recording today.

I have almost the same issue and I’ve tried the solution near the end which almost worked but…

I can see the bars/leds lighting up so it is picking up the guitar through the audio interface (see attachment) but I can’t hear it through my pc headphones, nor will it pickup in Bandlab even though it works perfectly fine with a MIC.

beh error.jpg

Update: I’ve actually got it working using the Line 1 input. The Inst 2 input just not playing! Which is fine, I’ll just have to keep swapping the cables between mic and guitar! Bahhhh!!

As with most USB interfaces, the two inputs are hard wired:
Input 1 → Channel 1
Input 2 → Channel 2

An alternative to swapping the cables around, is that when you want to record from input 2, set Audacity to record “2 channels (stereo)” (in the Device Toolbar). This will record channel 2 in the right channel of the stereo track. When the recording is done, you can “Split to Mono” (see: Splitting and Joining Stereo Tracks - Audacity Manual) and delete the empty “left” track (Click on the in the top left corner of the track).

I was too facing this issue when I downloaded Behringer’s recommended driver (ASIO4ALL) from their official website. I did some digging and found one YouTube video where this guy was using Behringer USB WDM AUDIO 2.8.40. After installing it, my guitar line is working absolutely normal.

I was too facing this issue when I downloaded Behringer’s recommended driver (ASIO4ALL)

Audacity doesn’t support ASIO so it won’t work.* It’s only useful if you are using an ASIO application.

The Behringer uses standard Microsoft-supplied drivers so you don’t have to download anything.

ASIO4ALL is a “translator” that allows non-ASIO hardware to work with ASIO applications. But it doesn’t work the other way around… It does NOT make a non-ASIO application (like Audacity) work with ASIO hardware/drivers.

***** If you’re a programmer you can compile Audacity with ASIO support but Audacity doesn’t have a license to distribute an application with ASIO support.