No audio on record or playback with El Capitan

I just updated my MacBook Air(OS 10+) with El Capitan and the connections between it and Audacity and my interface are not working. I can’t get ANY AUDIO in either record or playback. Then I checked your Forum and it said to download “Linein” which I did, which did nothing. Other answers in Forum did not address my problem. I’m trying to record a voiceover audition (due today!) and I need help, PLEASE!

Thanks, Susan

You posted in a volunteer forum, not a help desk. It could take us collectively days to figure out what went wrong. You should think about what to do if this process doesn’t work. Use your SmartPhone Personal Recorder in a quiet room. People use similar techniques to record AudioBooks.

What’s your microphone? Is it visible in Mac System Preferences when you plug it in? Forget Audacity for a minute.

Apple (upper left) > System Preferences > Sound > Input. There may be a tiny sound meter with the microphone and it should jump when you speak or scratch it (never blow into a microphone).


Thanks, Koz,

I followed your instructions by just tapping on the graph icon on my iPhone and was able to sample a recording. I hope this will work with a script to send in (which is supposed to be in a zip file) ! But should I still email my problem to the Tech folks to resolve my Mac/El Capitan problem?


I’m behind on this. I can usually give you step by step instructions, but I can’t this time. I’m reasonably sure the Personal Recorder is a free download, not native on the phone.

I do know the hard part is not running the software or making the recording. It’s getting a soundfile out of the iPhone so you can use it for something useful. That’s where I was in the instructions when I had to go do something else.

So you are the iPhone expert. If this whole thing is just going straight into the mud, find a friend who can help, or make your voice recording for you.

which is supposed to be in a zip file

You can do that with the Mac tools. Make a folder with all the right stuff in it. Control-Click on the folder > Compress [whatever it was you called it]. It should give you whatever it was you called

I still email my problem to the Tech folks to resolve my Mac/El Capitan problem

I don’t see any problem with us figuring it out for you, but it’s going to take longer than fifteen minutes, keeping in mind we’re helping others, too from our home bases across nine time zones.

Note Apple Care is only going to want to deal with Apple products. They won’t touch the microphone or Audacity.


There is no e-mail support for Audacity. You have to ask here.

We need concrete information to go on, particularly version number of Audacity (Audacity > About Audacity…) and makes and model numbers of interface and microphone and how they connect to the computer.


Thanks, Koz and Gale for working on this. (also for helping me get the zip file figured out.)
This is the info you asked for: Audacity 2.0.6; interface is Focusrite Scarlett 212; microphone is a Rode–0246620. Hope this all helps! Susan

Forgot to mention, I plug my mic into the interface, which is plugged into my Mac.

2.0.6 is rather old. You can get a more modern 2.1.1 or 2.1.2 here: Audacity ® | Download for Mac OS. If you need to drag audio files into Audacity, 2.1.2 can’t do that but 2.1.1 can. Of course you can still import audio using the File menu in 2.1.2.

Notice on


The Scarlett 2i2 runs in class-compliant mode on a Mac. No driver is required. Simply plug and play.

If you have previously installed the Focusrite USB driver and are experiencing glitchy audio on Mavericks you can put your unit into class compliant mode by following the instructions > HERE

At least two people on El Capitan has said it helped to go class compliant with the Scarlett 2i2. Click the HERE link in the quote above if you want to learn more.

Can you describe more clearly exactly what the problem is? Is it that you can record but not hear while you are recording? And also that you can’t play and hear the track once recorded?

Exactly what do you have selected as playback device in Audacity’s Device Toolbar?


I’ve been able to record, but there’s NO sound thru headphones and NO sound thru playback.

My device toolbar always defaults to “Core Audio…Built-in Output…Built-in Mic…and Mono” when I connect and start recording. So each time I’ve connected with Scarlett, I have to change manually the Output, etc. I always keep “Mono” because for voiceovers it produces better sound than with “Stereo.”

I’ll do the download of the Audacity upgrade and also the Compliant directions within the next 2 days. Hopefully those will work, I’ll get back to you.


I read through that three times. Audacity only checks for new connections and devices when it starts. So if you connect your Focusrite with Audacity already running, it will be invisible. Restart Audacity or Transport > Rescan…

I record a tiny USB microphone repeatedly in Audacity and it configures itself correctly every time. I never disconnect the microphone (normally), but I restart Audacity. It just knows.

There’s another oddity in your setup. I didn’t think you could connect to a 2i2 in mono. As far as I know, it’s an aggressively stereo (two blue waves) machine. It’s not a sound mixer, either. You can’t assign your voice to left or right or some combination.

Another oddity. If you record in Stereo (2i2 normal) your voice should not just sound poor quality, it should be coming out of the left-hand side of your headphones with nothing on the right. How are you listening?


Gale – I downloaded 2.1.1 but it’s not being accepted. Got this ridiculous message: “Unidentified developer, security preferences allow installation of only apps from the Mac App Store and identified developers…etc.” So what should I do now, please? Also the “compliant” info for the Scarlet said the same thing–it’s not being recognized.

Koz–I’ve only been recording in Mono, as it gives the best result for voiceover recording. My headphones are old Pioneer stereo but they’ve always worked great.

Thanks, guys for your continued help. I’ve used Audacity since 2006 and love it, but my system has been a PC/Windows for most of the time up until recently (Mac), and since I’ve upgraded to El Capitan, there’s been nothing but problemos. :frowning: Susan

Susan that’s just Apple trying to protect you from potentially malicious downloads (Windows does similar)- assuming you trust us …

just right click on the Audacity icon and select Open from the dropdown menu and confirm that you want it it open.

On subsequent occasions you will not be asked this.


Thanks, waxycylinder for that last bit of Apple info! Neat trick. Thanks also, Gale and Koz, I am now up and running with the new 2.1.1.

Just have to figure out now why MacOs system does not let me use “software playthrough” without the latency during audio recording. Any ideas, anyone? I’ve changed the Audio to Buffer from 100 to 60; and the Latency Correction from -130 to -200 but don’t think it makes a difference…

or do I need to re-post this in another Forum question?


do I need to re-post this in another Forum question?

You’re good here. We object if you join somebody else’s message. That’s a nightmare to keep straight.

There is no live monitoring of your voice in real time. That’s called Zero Latency Monitoring and it’s generally not available by plugging into the Headphone socket of most computers. It’s not a Mac thing. You are listening to computer processing delay. The voice is “one computer late.”

The Overdubbing people run into this. Play an existing musical background and sing to it. Unless you make special arrangements, you will not be able to hear yourself singing without the echo.

This is one of the special arrangements.

That little silvery USB adapter will let you listen to the background music from the computer and the perfect, correct, zero-echo voice on the way to the computer. The voice hasn’t got to the computer yet, so it’s still perfect.

If you’re doing a simple voice recording without all the musical hoo-haa, you can listen to the mixer, the USB adapter (if it supports it) or the microphone itself.

You should be able to listen to the 2i2. The 2i2 should be able to pull off that bi-directional monitoring trick. That’s what Direct Monitor On means. I don’t own one so I can’t directly vounch for it like I can the others.


Will try, Koz. Thanks again for your help! -Susan