NEW update not allowing me to monitor audio?

Hi,

Since updating to new version, have problems monitoring audio.

When I first open up audacity and link my Blue Yeti mic all is well I can hear the mic in my headphones from the output of mic. But If I go to record I get a error message. (Pic attached)

Sometimes by pressing the monitor audio button on transport bar the audio to headphones is cut off, audacity will then allow me to record audio but im unable to monitor and unable to give a good take.

Could you please look into this for me. Im running a M1 Pro 2021 macbook Pro.

Thanks.
Screenshot 2022-11-09 at 20.23.27.PNG.jpg

Does it work when you switch the input from mono to stereo?

I’m getting this as well, very often, only thing to do is close audacity and reopen it. Often it’s not recognising that i have headphones plugged in either and have to go to preferences and select headphones for playback devices. I’ve never had so many issues with an update going back over a dozen years using Audacity.

Or Transport > Rescan Audio Devices. You will have to do this if you plug in the device while Audacity is running.


Or Use the new Audio Setup button.

Good idea, just tried and same result, Thanks for reply.

I also have this issue after getting a new Mac (macOS 13.0.1 and Audacity 3.2.1).

I have a Samsun Q2U microphone which has analog direct monitor mode, where I plug headphones into the microphone and get zero latency monitoring.

With Audacity 3.1.3, I have the following behaviour:

  • record device set to mic, playback set to mic: monitoring stops while recording and starts again as soon as recording stops
  • record device set to mic, playback set to anything else: monitoring continues while recording (desired behaviour)

With Audacity 3.2.1, if I start recording, monitoring stops, regardless of what the playback device is set to, or whether recording mono or stereo. It does not return when recording stops. To re-enable the monitoring I have to either unplug and reconnect the microphone, or deselect and reselect “Thru” in Audio/MIDI Settings:

Screenshot 2022-11-17 at 2.18.24 PM.jpg
Please let me know if I can provide any more information.

So your report seems to be fairly complete - thank you. Let me suggest also posting this issue here: Issues · audacity/audacity · GitHub





And here is a similar report from fight4theusers: Audio Monitoring cuts out when recording

@maximlee22, @raquirk, @crb, do you want to share which versions of MacOS and Audacity you are using ?

Does the issue also occur with Audacity 3.1.3? Old Audacity versions download

Do you have the issue with the nightly alpha?: https://nightly.link/audacity/audacity/workflows/build/master

I’m facing exactly the same issue. Has this been solved?

No, see the same thing on Sonoma / M2 Pro. Github issue is still open.