My voice is recording but not using a mic

UM2 to Audacity recording my voice

I’ve got two weird things happening when recording my guitar through some pedals including a loop pedal into an audio interface connected to my laptop via USB.

Guitar into pedals into Fender amp then line out to audio device with USB cable to laptop.

What works:
When I play guitar, which passes through the MXR Clone Looper pedal through the amp to the Behringer UM2 audio interface box then to the laptop running Audacity recording software, I get the guitar signal and it records just fine.

What’s weird:

  1. If I talk while recording, this also shows up on the recording loud and clear. I’m thinking my laptop mic must be on and is picking up my voice - I’ll test this out later tonight. At least I can get vocals into my recording without springing for a mic to hook into the other channel of the audio interface box, although it’s most likely not a high quality.

  2. The weirder thing. Although my guitar records fine, if I hit the playback on my loop pedal, which goes through the exact same cable path as the guitar (to the amp, out the line out to audio interface box, then to the laptop via USB.), IT DOES NOT REGISTER ON THE METERS IN THE AUDACITY SOFTWARE AND DOES NOT RECORD! Even though the clip light is flickering on the audio interface box so I know the box is getting the signal (and I can hear it on the headphones connected to the audio box). It just doesn’t seem to pass this through the USB to the laptop. But it comes into the audio interface box through the same cable from the amp that the guitar signal comes through.

I’m sure there is an explanation but I have no idea what it could be. In theory, any signal going to the amp where I can hear it on the amp should go out the line out (which it is cause I see the clip light flickering on the audio interface) and through the audio interface to the USB out -the guitar does but the recorded loop of the guitar does not…

Even though the clip light is flickering on the audio interface box

Hopefully not the CLIP light. That’s to signify audio damage. You should get the SIG light while you’re performing.

Do you record internet music or other content?

Do you use Skype, Zoom or other communications, chat, or conferencing?

Do you know where your laptop microphone is? Mine is just left of the left-hand shift key.

You’re wearing headphones connected to the UM2. I do it that way, too. But is the music also heard in the room—sometimes?


I meant the green signal light on the UM2. So I checked again and I was using the computer mic, I changed mics to the "Microphone (2 - USB Audio CODEC), but now no signal in Audacity. I do have 2 (Stereo) Recording Channels selected.

When I go to the Windows Sound Control Panel, I did have to change to 2 Channel 16bit 48000 Hz, then I can see the meter move in the Windows Start Test when I strum the guitar. So I know Windows is receiving the audio signal through the USB connection.

But when I restart Audacity and try to record, nothing.

Forgot to mention Audacity level: 2.4.2 And Windows 10 Home Edition.

In Audacity I click on Meters but don’t see them move.

Hey I saw this post from Feb and followed it exactly (except it’s 16 bit not 6 bit). I had mine set up this way - closed Audacity and reopened - but still no signal from guitar playing in Audacity although I can see the signal on meters test in Windows Sound Comtrol Panel.

I don’t record anything on this laptop and have not used Zoom in weeks - don’t use anything else.

Plug the UM2 in and make sure the Power light on the front comes on.

Right click the Windows Speaker icon > Recording devices. Find the right one. I don’t know any handy spells other than it’s going to mount as USB Audio CODEC.

Select it > Properties > Advanced: Default Format Dropdown: 2-Channel, 6-bit, 44100. > Apply > OK.

Launch or Relaunch Audacity to reset its internal device count.

Microphone setting in the menu bars: Microphone (USB Audio CODEC), 2 (Stereo) Input Channels.

Click the Audacity recording meters to start monitoring (without actually going into record). Tap, scratch or speak into the microphone (Never Blow) and the sound meters should jump.

If you set up for dual channel, your voice will be on the Left and the guitar on the Right. It’s the only way to record guitar.

If you turn down the recording level on the UM2 for the guitar input, does the recording become silent?

Please describe in detail exactly what is plugged into which socket, but before you do that, I’d suggest simplifying your setup…

Take the pedals and amp out of the equation. Go from your guitar straight into the MXR Clone Looper.

Hi Steve,

So look at my second post above at 9:17, I had been recording from the laptop mic accidentally do that explains why it recorded the guitar sound (from the actual strings and not the USB connection), and also explains why I was recording my voice as I did not have a mic hooked up to the UM2 for voice.

So changed the mic in Audacity to the USB mic, made sure I selected Stereo recording, and changed the setting in Windows to 2 channel 16 bit 48,000 (and also tried 44,100) Hz, per the instructions from another post on here.

After doing this - I get a meter reading on the Windows Sound Control Panel for testing the mic when I strum guitar, and I get no reading from talking, and it’s the USB mic selected so I know it is not the laptop mic. This means I am getting a signal from the USB cable connected to the UM2 when I stream the guitar.

However, when I then open Audacity and click the meter to monitor - and also if I try to record a stereo track, there is no reading it all from guitar strumming and no sound at all when I play the track - flat line and dead silence.

Check that you have the USB device selected as the recording input in the Device Toolbar.

I do have it selected.

Perhaps I should uninstall Audacity and reinstall? Maybe try the new version 3.0?

What do you think?

I don’t think that will make any difference. I don’t think that Audacity is the problem.

I’m confused by your description of the problem.

Please post a screenshot of those meters.

In Audacity: “Help menu > Diagnostics > Audio Device Info” (or perhaps “Help menu > Audio Device Info” if you are using an old version).
Save the info when it appears, and attach it to your reply.

OK see two screenshots of the meters working from Windows Control Panel for Sound on the “Microphone (2 - USB Audio CODEC)”.

One screenshot from Audacity for devices selected.

And a text file with the Audacity Audio Devices info you asked for.

Thanks much!

Let’s check that it is “dead silence” rather than “very very low level”.

  1. Make a test recording.
  2. Apply the “Amplify” effect with default settings (make a note of what those settings are and include that info in your reply).
  3. What happens?

OK two screenshots. One of the original recording while strumming the guitar and showing the amplify affect settings about to be applies. The other with the amplify affect applied. It just sounds like scratchy noise.
Audacity - Amplify Effect to apply.JPG
Audacity - After Amplify Effect - just scratchy noise.JPG

I should add that the headphones connected to the UM2 play the sound loud and clear. The UM2 was bought new in the fall. And although I have had them connected to USB cable to my laptop, I have not been successful in recording from it, but I do see the signal meter from Window Control Panel for Sound, as I’ve noted above and included screenshots.

OK I just found out that I can plug my 1/4" guitar plug into the Instrument 1 of the UM2. I didn’t realize that before but just saw it on a YouTube demo of the UM2. Now it records the guitar. And I can change it to Mono recording and record the single track in mono, like it should be for guitar. I guess this works for now until I get a mic and want to simultaneously record vocals and guitar or vocals and keyboard.

If you can suggest something to get the Instrument 2 channel working to record from the UM2 that would be great. Incidentally I checked the same Windows Control Panel Sound mic tests for the Instrument 1 connection to UM2 and the levels are showing exactly the same for Instrument 1 and Instrument 2. Something is blocking the Instrument 2 channel when I get to Audacity to record it.


  • Kevin
  1. open the run dialog with Windows logo + R
  2. enter: mmsys.cpl
  3. press the OK button

That will open the Windows Sound control panel that looks something like this:

Open the “Recording tab”, then click on the device icon that corresponds with the UM2.

Click on the “Properties” button, then open the “Advanced” tab.

Set the default format to “stereo”.

Set the default format to “stereo”.

By "Set the default format to “stereo”, I assume you mean to 2 channel 16 bit 48,000 Hz, which is what it was set to already when I followed your instructions - as I had already done this in a previous step and is shown in one of my screen captures in a response above.

I followed your instructions, but still the same behavior:

  1. In the Windows Control Panel for Sound - I can see the meter moving in the “Test your microphone” bar, when I have the guitar plugged into Instrument 2 and strum it.

  2. In Audacity, I have “2 (Stereo) Recording Channels” selected, but when I click “Click to Start Monitoring”, it does not show any movement when I strum the guitar. I have the Instrument 2 Output knob turned almost all the way up on the UM2, and as I say I can see the bar moving when I test microphone from Windows Control Panel, but not from Audacity.

Weird huh? It’s like Windows recognizes the Instrument 2 input from UM2, but then Audacity does not. I wonder if there is a 3rd independent utility I can use to verify if Windows recognizes the audio input from the Instrument 2 (channel 2) coming from the UM2?

Oops, I forgot to post the screen capture. And I looked at responses above and see that I hadn’t uploaded this yet. But this is what it has been set to most of the day today.
Windows Sound Control Panel - set default to stereo.JPG

I made this screenshot - I see that you don’t need it, but it may be useful for anyone reading this later:


Probably better to select “2 channels, 16 bit, 44100 (CD Quality)”, since you probably want a standard audio file at the end (and 44100 is the Audacity default).

Strongly recommended: Turn off “audio enhancements”.

I doubt that these settings will make any difference regarding the problem, but those are the settings that I’d recommend (and worth a try).