Moving to new computer, Audacity doesn't record from on-line

I have used this program for many more years than I can remember and at my age, it isn’t very far. Most of my recording is from web sites. I now have a new computer, I cannot seem to get it to record that way. I can play Audacity files with no problem.

The only record I can achieve is through the computer microphone, nothing from on-line.

In the original set up, I jumpered the line-out to the mic in. It works flawlessly. The new computer does not have a line-out. It only has the 4pin jack (Mic, Left out, Right out, ground) I played with the jumping but no luck.

I set MME/Windows D/Windows V, Primary Sound/Windows (rea, Mono/Stereo, and Speaker Head/Microsoft Sound in the four pull down menus in the top bar but nothing gets my unit to record from On-Line. (Forgive what seems to be truncated entries but that is what the computer shows me.)

Maybe this makes more sense to you than it does for me.
I am open to suggestions.
Win 10

Choosing WASAPI as the audio host is one way to record what the computer is playing …
https ://

https ://

Yep, been there. Tried that.

With KTOO web site playing NPR news, I get audio recording only if I have the remote amplifier volume up and Audacity records the ambient audio in the room. The burst that is shown is when I tapped near the microphone.

WASAPI only works if you select the speakers as the recording device, (& 2 channels). You have the microphone selected.

Another option is to select stereo-mix as the recording device.
As it’s a new computer stereo-mix may be disabled & hidden. Here’s how to make it visible, (if it’s available) …

https ://www
BTW Don’t download anything from thewindowsclub.

No so Trebor - I can set host to WASAPI and record from my PC’s onboard Mic - but mostly I have it set to record loopback for internet webcasts.


I am beginning to use my microsoft vocabulary…
On my test machine, I tried to follow the recommendations listed here already. I do not see methods to get to those screens and it used to be so easy. I get to a useless screen and continue to explore. I click on a different topic, I get sent back to that useless screen. again, and again. Finally I stumble onto it, it does not have the same options but eventually find the fix and set it. I teat Audacity and it is working exactly as I want.

I did say that I was on my test machine…

The computer that needs the adjustment is in a different room and does not have e-mail so I have to start the guessing all over again. Sooner or later…
At least I now know that it can be done.

Here is a new error for any of the settings I choose from the recording screen.


If you want to record the sound coming from the speakers, don’t select microphone, select speakers …

don't chose microphone if you want to record speakers.png

this works for me.png

I had about 6 weeks of success. After I got this one working, I tried it on my other (identical) computer but failed at every turn.

I have no idea what changed but just this morning, this computer decided to go back to some other setting and I get all the errors I have mentioned already.

The only thing that is different is that I am using WebEx to teach a computer science class and it uses the mic and camera however, for the last 3 weekends Audacity was recording flawlessly. I doubt that the on-line class did not affect anything.

Still searching…

Ok, I think I found it. Somehow the loopback (?) was disabled. It was not an option in Audacity menu.

Settings/Manage Sound Devices/Input Devices Stereo mix/ was disabled. Now the Stereo Mix menu item was visible in Audacity. Recorder is working but only on that one computer. Two others, not so much.

I hope that was the only thing I changed. At least the next time it happens, I can come back to this message and might be able to fix it.

When is 2.4.0 being released. I hope to see the Timer Record fix…

At lease the next time it happens

The successful chat or conference services change your computer settings and only some services put them back when they’re done.

Their product, their job, and promotion/publicity depends on total control of the sound pathways to avoid distortion, noise, feedback etc. etc. They have almost no need to save where the computer was before they set up for chat. So they don’t. You think you’re doing something wrong because the chat worked perfectly and now that stupid Audacity won’t record my YouTube Music. What’s wrong with Audacity, anyway?

You have a leg up because you have two computers and you at least know that it’s computer dependent.

Skype became the most popular conference system on earth working that way.

And yes, knowing how to put it all back together later is a definite advantage. Write it down.


" You think you’re doing something wrong because the chat worked perfectly and now that stupid Audacity won’t record my YouTube Music. What’s wrong with Audacity, anyway?"

I hope you do not believe that I am thinking this way. I have a high respect for Audacity.

I would agree with your assessment that WebEx may have walked all over my settings but Audacity was working for about a month while I was also using WebEx. Maybe something I did in that last session did it but it was not a problem all along. After a few check/changes in settings, that computer is the one that is now behaving the best. I tried the same changes in another identical computer but it will not connect to anything audio. It will take some more time to figure out how to ask the questions.

As for Timer Recording, I have two of three working but not in the same way yet (-: One starts recording at the beginning of the file when using Timer Record, the other starts at the end which causes my file to be twice as large. Neither start at the cursor location and I understand that it may have been corrected in the next release. However that s a separate issue from not recording at all.

This has been fixed for 2.4.0 - I did the QA testing for it.


With worm on tongue, I await its arrival…