Mixer Board disappears when clicking in Audacity window

Hi Folks,

Having just discovered the Audacity Mixer I have one frustration.
If I turn the Mixer on then ask Audacity to play the mixer minimises. Have I missed something or is this normal?


No I think your’e right. I just tested this and when I pressed play (I’m on 2.0.1 alpha) the mixer board minmized. It can be restored obviously. But don’t think it should do that so I would think it is a bug. I will flag this up and we’'ll see what happens.

BTW it also minimizes the mixer when you press Record too.


As a matter of interest - how did you just “discover” the mixer?


I assume we are talking about View > Mixer Board. If you have the Audacity window maximised, choose View > Mixer Board then press Play or otherwise click in the main Audacity window, then yes on Windows, Mac and Linux the Mixer Board will appear to “minimise” (it will be covered by the maximised window when you give back focus to the maximised window).

This was raised a long time ago and Vaughan who developed Mixer Board did not want to make it a child of the main window (like Analyze > Plot Spectrum, which on Windows and Linux is always visible when the main window is visible). Mixer Board was in fact a child window to begin with, but people who had a lot of tracks complained it got in the way.

The solution is to press the “Restore Down” window button in the main Audacity window so that Mixer Board will still be visible alongside, Alternatively, tile or “side by side” the windows. This is done by right-click over the Audacity window’s Taskbar button (or in Vista/7 over empty space in the Taskbar). See http://lifehacker.com/229612/windows-tip-tile-two-windows-with-just-two-clicks.

Alternatively you can find a program that will give you a window option to “pin” the Mixer Board (or any window) on top, for example:

I think there “would” be a case for Audacity to provide a way to pin Mixer Board, but this may be difficult to implement cross-platform.


“How Did I Discover The Mixing Boared?”

I was looking at another post on the forum and it was mentioned.

Gale thanks for your suggestions I’ll try them soon.

I’m running XP on two machines and Windows Vista on another and the latest version of Audacity on all three.


For Linux no change is necessary.
For example on Debian, click on the top left corner of the Mixer window and select “Always on Top”.
I don’t know if Mac OS X has that option, but it may just require a “Windows only fix”.

Not that I could find. The OS-X window that has focus is in front. You can’t make a window sticky ad lib. OS-X assumes Audacity knows that it’s doing.


I clarified in my previous post that the Mixer Board window only “appears” to be minimized. It is merely hidden when you click in the maximised Audacity main window.

Linux Ubuntu can also pin windows on top.

I have not tried it, but this claims to be the solution for Mac:
http://infinite-labs.net/afloat/ .