Missing plugin, even though it says Enabled

I was using Audacity 2.1.3, I think, and went to use the Limiter effect. It didn’t show up in the effects list at all. I checked the Add/Remove Plugin function, and it said Limiter was enabled. I went through a few rounds of rebooting Audacity, turning Limiter off and on manually, and nothing seemed to work. I tried updating the program to see if that helped, but it still has the same problem–it says Limiter is enabled, but it doesn’t show up in the list at all. It’s very frustrating, naturally. If anyone can help, that would be wonderful. I took some screenshots just to show that everything should be working properly.
Thanks in advance!

By default, Audacity’s Effect menu lists built-in effects first, then plug-in effects. The Limiter is a plug-in effect. Scroll down the list below “Wah Wah”.

Thanks, but I did consider that. I can only show so much on the screen at a time–Limiter is not present in that area, either. (And on previous uses, I would swear it was always in the main list, but memories fail.) No, I did scroll to the bottom, but all it says below Wahwah is: Adjustable Fade, Clip Fix, Crossfade Clips, and Crossfade Tracks.

What is drive “D:”?

I have an Asus. They want you to save everything in the Cloud, so the C drive is extremely small. Fortunately on the desktop, unlike my laptop (that’s a much longer story) they give you a much larger D drive called “Data” and that’s where I typically save programs that don’t automatically install themselves on the C drive.

I think that’s the problem. Audacity should be installed on a local drive.
I’m actually surprised that it works at all from cloud storage.

It is possible to run Audacity from a USB memory stick (“thumb drive”). To do that, you just need to:

  1. Get the ZIP version of Audacity from: Audacity ® | Download for Windows
  2. Extract the contents of the ZIP package onto the USB drive
  3. Open the folder (on the USB drive) that contains the file “audacity.exe” and create a new empty folder called “Portable Settings”.

To run this “portable” installation, double click on the “audacity.exe” file.
Tip: if you use this method regularly, you could create a Desktop shortcut to the audacity.exe file).

Some information about Portable Settings here: Preferences - Audacity Manual

No, the D: drive is a local drive, it’s a secondary hard drive built into the system. I was lamenting that the laptop lacks this feature, and as such doesn’t have enough space for the necessary Windows 10 security update. Asus just also offers a limited amount of OneDrive complimentary (I don’t know if OneDrive has this on its own), as well as 25gb with Dropbox. Both C: and D: are local hard drives on the computer.

OK, but the location of the plug-in is not one of the normal locations for plug-ins.
How did you install Audacity?

Well, I clicked the link, installed it, and told it to install to D: instead of its default. I didn’t change anything else. I’m not sure what else you mean by the question. (This would be so much faster and less frustrating with a dedicated help chat line =() Look, I’ve used Limiter before without a problem. It’s always been there before. I made absolutely no changes to the system, did nothing to the program, but last night, Limiter wasn’t there.

Which link?
If it was on this page: Audacity ® | Download for Windows there are two versions listed - the ZIP package and the EXE.
If you got it from somewhere else, please say where.

Audacity is free software, developed and supported by enthusiasts in their spare time. I certainly don’t want hundreds of people phoning me up night and day.

and we’re trying to work out why that happened. Plug-ins do not usually disappear for no reason, so we need to find out what’s peculiar about your set-up that allowed / caused that to happen - what the precise chain of events was.

So far I can see that Audacity is not installed in the normal installation directory, and no obvious reason why. We need to start somewhere, and a good place to start is with exactly which version of Audacity you have, and how it was installed.

You wrote in your first post: “I was using Audacity 2.1.3”
What happened next? Which version do you now have?

In my attempts to solve this problem, I updated to 2.2.1, thinking that perhaps running the latest version would solve the problem. I then did a complete uninstall and reinstall, and it still didn’t solve the problem. I literally have no idea what’s going on. Like I said, I used to use Limiter on several different files, but hadn’t needed it for about a month. At some point in that time, whatever happened happened. I didn’t change anything, or install any new plugins. I don’t muck about with system files, and Audacity has always been installed on my D: drive from day one. I install there because the storage space of my C: drive is 150 gigs while D: is 780. So I save C: for the Windows required programs and programs that won’t let me manually change the location for install.

What effects do you currently have listed below Wahwah?

If that is all, then you are missing many other plug-ins:

Perhaps. They’re present in the “Plugins” folder in the Audacity folder, but I did try adding them to the “Nyquist” folder, and making sure they were enabled, but it didn’t make any difference. Still, nothing is showing up. I do have to amend my comment about not adding anything, I had recently added the EQ curves download, but when I removed it, it didn’t fix the problem, either. I don’t know if the problem existed prior to me adding that particular addon or not.

Try this (ensure that Audacity is not running before you start):

  1. Download “Audacity 2.2.1 zip file (11.57 MB)” from https://www.audacityteam.org/download/windows/
  2. Unzip (extract) the contents to a suitable location on your local computer where your standard (non-admin) log-in has read / write access. (if you’re not sure how to do that, ask).
  3. Open the extracted folder and find the file “audacity.exe”.
  4. In the same folder as the file “audacity.exe”, create a new folder and name it “Portable Settings”.
  5. Double click on the file “audacity.exe” to launch Audacity.

Do you see the full list of Nyquist plug-ins in the Effect menu?

I apologize for taking so long to get back to you; health issues. I just haven’t been able to get back onto this forum.
Yes, for whatever reason, your suggestion solved the problem. I even added the folder you suggested to my original Audacity program folder and it fixed the problem there. I’m not really sure why, so…gremlins? Regardless, thank you for your assistance.

Err, did notice today that the same thing had happened again, they’d all disappeared again. But the Portable Settings folder is still there, and it has stuff in it now. This time I definitely haven’t downloaded any new plugins, just the ones I’d had before I started having this problem. I didn’t have a need to use Limiter, I was just using my regular plugins and happened to notice that everything was missing again. Should I just try to keep it installed in C: and see if it doesn’t happen there? It just makes Windows upset if it can’t update every time it gets it into its little head to do so. But I can try it. After I finish with this audio file I can try reinstalling and using the previous directions to see if it fixes it again…could it just be the ACX check plug-in that’s doing this? That’s the only thing I need limiter for, anyway. I mean without that plug-in I can’t do anything for ACX, but if the plug-in won’t let me do anything for ACX anyway, it might just be a bit of a catch-22.

Using the method described in my previous post (https://forum.audacityteam.org/t/missing-plugin-even-though-it-says-enabled/48115/16) should work for any location that you have full read/write/execute access, provided that data transfer is fast enough, immediate enough and reliable enough for bi-directional asynchronous real-time data transfer (that rules out network drives, but any internal drive should work).

A particularly useful feature of this method of “installation”, is that Audacity can be reset back to virgin state, by deleting the Portable Settings folder and recreating a new, empty Portable Settings folder.

I’m a bit concerned that it was working, and then it wasn’t. What changed? If YOU didn’t change anything, then what did? If data is changing on its own, then there’s a strong possibility that the storage medium (the “disk”) is failing.

Nyquist is completely missing after upgrading from 2.2.1 to 2.3.2, even though I have Nyquist in the Manage Plug-ins menu like before, both Nyquist Plug-in Installer and Nyquist Prompt are enabled. Also the plugins folder contains 30 *.ny plugins.