i have windows 8
audacity 2.0.3 which i downloaded from the internet.

my recordings sound as if it is in a tunnel.
had a look at faq : recording - troubleshooting and followed the steps, did not work.
in the speaker properties - enhancements. selecting “disable all sound effects” did not work. the immediate mode is selected.
in the levels the hd audio output is 100, the rear green is 49 and the rear blue is 58. the rear and front pink are not connected.
where would the “echo cancellation” be?

Moderator note: please do not SHOUT fella - this is considered bad netiquette on most interweb forums. It doesn’t get your post answered any quicker - rather it annoys the forum elves as it makes it harder to read.

So you are complaining about your computer not Audacity.

Have you considered shouting at the computer manufacturer too?

What does “immediate mode” mean?

If you politely give us some information about what type of record player you have and how it is connected to the computer, we “might” consider responding to you.


Good morning Gale,

I am sorry that you took up my request for help in that manner, I was simply wanting to get to the point without much explanation and had no intention of being abusive.
I will certainly appreciate it if you could give some guidance as it is not Audacity that is the problem. I feel that there is some adjustment that possibly needs to be made and hopefully you will be able to assist.
I have been using Audacity with windows XP and had no problem but my computer crashed and now I have a new hard drive with windows 8 and have now started to play LP’s and when I playback it sounds hollow.
I have a Technics turntable connected to a Denon stereo amplifier which is connected in the green slot at the back of the computer.
With regard to the “immediate mode” : In the speaker properties under enhancements it states “select the sound effects to apply for your current listening configuration. Changes may not take effect until the next time you start playback”. Under this there is a block where you can select either “Disable all sound effects” which is blank and “Immediate mode” which is selected. Then there are blocks that can be selected and they are “environment, voice cancellation, pitch shift, equalizer, virtual surround and loudness equalization.” I am not sure what part the immediate mode plays.
Hopefully you will be able to give some sound advice that will assist me to be able to play and save my LP’s again.
Kind Regards

Start off with a good read of this set of tutorials from the manual: http://manual.audacityteam.org/o/man/tutorial_copying_tapes_lps_or_minidiscs_to_cd.html


Do you have a new computer with Windows 8 pre-installed, or are you using the same computer that had XP on it?

If it is the same computer then it will be essential to go to the web site of the computer or motherboard manufacturer and see if there is an audio driver for Windows 8 for your specific computer model. Otherwise you could get all kinds of audio misbehaviour because your sound device will still be assuming that Windows XP is talking to it.

A green port should be the audio out, for connecting a playback device.

For recording, the amplifier should be connected to the blue line-in of the computer.

Are you using the amplifier as playback device by connecting the amplifier to the green computer output? There is nothing wrong with that, but it could somehow be relevant to the problem.

If not, what speakers exactly do you use to listen to Audacity playback?

I had not heard of “immediate mode” before but does your “Enhancements” tab look like this?

Basically immediate mode applies changes made to the enabled sound effects “at once”. There seems some confusion as to whether enabling immediate mode means you then don’t have to click “Apply” to hear the changes, or whether you do but don’t have to click “OK”.

Either way, you want to click “Disable all sound effects” so that it has a tick (checkmark) in the box. Then the “immediate mode” box should be greyed out so that you cannot click it. OK that dialogue.

Then as the FAQ says, you also need to ensure sound effects and enhancements are turned off for the recording device, so that the “enhancements” are not recorded in the first place. To do that, click the “Recording” tab in Windows “Sound”, then right-click over the line-in that you should be recording from and choose “Properties”. If you then see an “Enhancements” tab, turn off all the effects and click OK.


Hi Gale,

I have a new computer with windows 8 pre-installed. I will check if the sound device from the old computer was transferred to the new one. Not sure how this works.

When I record into Audacity from the LP and then play it back it gives the tunnel sound when plugged into the green, so I will give it a try and plug the amplifier into the blue line- in and record something and then plug the amplifier in the green output to play it back and see if this solves the problem. I did not have to do this on my windows XP but I also had the older version of Audacity where I was able to change recording to line-in and there was no problem with playback. I cannot remember how the amp was connected but I think it was the green, not sure.

I am using Bang & Olufsen Beovox S30 speakers.

Yes, the enhancement tab is exactly as you have shown.

I will give your last paragraph of instructions a go tomorrow and hopefully it does the trick to sort out my problem.

Thank you for your assistance and will let you know if I get it right or not.

Best Regards

Good Morning Gale

I don’t seem to be able to get it right. I’ll tell you the procedure I went through.

The amplifier was plugged into the green jack at the back of the computer. I then followed your instructions by clicking on “Disable all sound effects” then the “immediate mode” became greyed. Then I went to “Recordings” tab in windows “Sound”, right-clicked over line-in and clicked on “Properties” which gives me “General’” “Enhancements” does not appear.
The playback still gives the tunnel sound.
I changed back to “Immediate mode”

I then tried the blue jack which gives me line-in. The speaker icon at the bottom right-hand corner now shows that it has been disabled. However I clicked on it and then on “Recording Devices”. In “Sound” under “Recording” I right clicked on “Line-in” properties which then gives me “Enhancements” where I was able to click on “Disable all sound effects” then OK.

On opening Audacity the speaker block is now blank. In the first block is “MME”, “Blank”, “Microphone” which I changed to “Line-in” (is this correct) then played the LP track which recorded but when I tried to play the recording back the following message appeared. “Error while opening sound devices. please check the output device settings and the project sample rate”.
I then tried plugging the amplifier in the green slot while I had Audacity on the screen. I tried the playback but it gives me the same message of the “Error” as above.
The speaker block in Audacity remained blank.

It would be appreciated if you could help. Windows XP never gave me problems recording and playback was great. Hopefully you will be able to give some advice as to how I can sort out the problem in Windows 8.

Kind Regards

So are those speakers connected to your amplifier, and you are connecting from green audio out of the computer to line-in of the amplifier to feed the speakers?

Or do you connect the speakers directly to the computer, if so, what inputs on the computer are the speakers connected to?

What audio are you playing? If you are playing a recording that was corrupted by “enhancements” it will still sound “in a tunnel” even if you have now turned off playback enhancements.

Try importing a known good WAV file and play that in Audacity.

How did you do that without unchecking “Disable all sound effects”? “Disable all sound effects” should be unchecked, as I think you say you have done below.

If the speakers are connected to the amplifier (see above) then I would imagine you need to connect from amplifier line-out to computer line-in (blue, in order to record), and from computer line-out (green) to amplifier line-in (in order to send audio to your speakers).

OK you do want the line-in recording effects to be disabled.

If you are intending to record from the amplifier connected to computer line-in, then yes the “Line-in” must be selected as input in Audacity.

You need a playback device to play to.

After plugging the amplifier into the green computer port, restart Audacity or choose Transport > Rescan Audio Devices from the menu at the top of the Audacity window. Audacity doesn’t see when you connect or disconnect cables while it is running, unless you do the rescan or restart. Then you should see the external playback device in Audacity.

If the B&O speakers are connected to the amplifier then you will need two cables, so you connect computer green to amplifier in and amplifier out to computer blue (as above).

If you only have one cable then you will have to record connecting amplifier out to computer blue then change the cable to computer green to amplifier in so you can play back.

Alternatively if the computer has built-in speakers you could use those instead, although obviously that won’t sound as good as B&O. If you have built-in speakers but Windows does not see them, go back to the “Playback” tab of Windows “Sound”, right-click in empty space, then choose “Show disabled devices”. If the built-in speakers appear, right-click over them and choose “Enable”.

If the tunnel effect continues on a new recording and/or playback, look in the Windows Control Panel to see if the sound card has its own control panel. There may be extra effects there to be disabled that don’t show in Windows “Sound”.

Also consider if the drivers of the computer sound device are up-to-date and intended for Windows 8. What is the exact make and model number of the computer? Are you using Windows 8 or Windows 8.1?


Yes the speakers are connected to the amplifier.

no they are not connected directly to the computer.

I am playing back a LP track in Audacity. In the green audio out under Sound - properties I only get “general” the “enhancements” is not there so I am unable to change anything.

It works perfectly. It was one of my previously recorded wav tracks.

Yes, I took out the check in “disable all sound effects” and the “immediate mode” comes up. I must admit that I did not take the tick out of 'immediate mode" when I ticked “disable all sound effects” but it still was greyed.

I will check the following and come back to you later. Thanks

There may be effects under an “Effects” tab or even the “Advanced” tab.

Also as I have said before, you need to open the Windows Control Panel, look under “Sound” for the sound device’s own control panel (if it has one) and turn off any effects you don’t require there. There could be recording effects there.

OK, so if you still have a tunnel effect when recording, assuming you have disabled all sound effects for line-in, this would mean that there are other effects to turn off in Realtek’s control panel, or the sound device is broken or has the wrong drivers, and so applies sound effects irrespective of settings.

Please test by making some new recordings.