Listen to one track, while recording a second just by itself?

Hi, my searches on this led to over-dubbing, which I don’t think is what I want.

I have an narration track in Audacity. It was done when I was much less good. I want to redo it, but with the same timing, because it needs to sync to an existing video.

So I want to listen to the old track in my headphones, while recording (roughly) the same thing from my mic in a new track.

I am fine with moving and editing that second track around later to sync up with the existing first track if there are minor sync issues. The sync between the two tracks does not have to be to the millisecond, anywhere close will work for this purpose. I will then save just the new track to WAV, and replace the old audio track in the video production.

So (a) I only want to hear the old existing track in my headphones, and (b) I only want the new mic input to be recorded in the new track.

I could open two audacity projects I suppose, and start recording from my mic in one project, and then start the play back of the old narration from the other project. However, I’d like to do this in one Audacity project for other reasons.

Hope this makes sense. Possible?

What you’ve described is overdubbing : tick the overdub box in Audacity preferences.

The recording device to select is the microphone, not the computer speakers, (a/k/a stereo mix).

BTW it’s difficult listening to an out-of-sync version of what you are saying without stuttering

Thanks. That works. In Edit / Preferences / Recording / Playthrough, check the box “Other tracks while recording (overdub)”.


Set headphones for output.

Set mic for input.

Track one is the old track I want to listen to.

Create a new second empty mono track, and position the cursor at the beginning.

Press record. I can hear the first track in my headphones playing back. I say the same thing into the mic, with of course a very slight delay which is fine, since I will advance this track in the video software (Camtasia) to line up with the old one later.

The new track only records my voice from the mic. I export just that new second track as wav, and import into the video software. I make sure the wave form lines up, pretty close, with the old track. I delete the old track, and render the video. All good.

If you’re able to hear the old track whilst recording the new version,
overdub must have been ticked in Audacity preferences.

Ah, quite right you are. It is checked. I will now edit my reply above just in case helps others.


I am not sure whether I am missing something here.

Here is what I thought this post was about and I was hoping to find the tip to what I was looking for.

I have a track already recorded in Audacity.
I want to play it while recording on another track. That track should be a track it by itself.
Not an overdubbed track.

I am just not able to get this done in Audacity.

On preferences I have checked

Record on a New Track.

I do not have an option for Play Other Tracks, but no Overdubbing.

Looks like Playback and Overdubbing are tied together - unfortunately!

Any workaround for this in Audacity. (I do not want to other solutions of saving and playing those tracks elsewhere.

I want to record separate tracks (like on a MIDI sequencer) so they can be adjusted independently for volume, effects, mute and other things. Finally, I can combine all the tracks and export into an MP3 or Wav.

Looking forward to your clarification or tips from any one else.

Thanks in advance

P.S I have the latest version of Normal Audacity as well as the Dark Audacity

As Audacity is a multi-track audio editor, “overdub” just means to record another track into a project that already has one or more tracks.
“Overdub” does not affect other tracks in the project.
“Overdub” is what you want.

You may find this page in the manual helpful:

You can announce live with wild track in your headphones. It takes practice. Your live mouth is two or three words late compared to the headphone voice. The resulting new track is almost perfectly matched to overall time and only wanders in word matching by a bit. Shift offset in post production.

The wild track can be from anywhere like a music player or a sound file on your phone. This appears like it would drive you nuts, but it’s surprisingly easy with a little practice.

Jay Foreman has a live theater show where he takes a request from the audience and then plays the song and sings the words—late. Don’t listen if you’re high or drunk. It’s super disorienting, but he said in an interview he’s playing back the real words in his head and singing them late, a cousin to this live reading technique.

So no, I didn’t just pull that out of my…ear.



Can you please re-check and tell me if I am missing something.
May be I did not make things CLEAR.

Unfortunately, for me (I have tested this on both Normal and also Dark Audacity)
when you turn on Play Other Tracks - IT ALWAYS OVERDUBS.

The new recorded track has the audio of the other tracks plus what I am trying to record new.

I do not want the other tracks to be recorded into the new track. That is I do not want OVERDUBBING.
Just want to hear the other tracks and what I am recording.

Thanks Sri.

We need to speak the same language.
What exactly do you mean? Do you mean that the original track is being mixed in on the same track as the new recording? If so, then that’s probably just a wrong setting, but I don’t want to make too many suggestions in case that is not what you mean.


Thanks for responding again.

Let me make it clearer by elaborating.

I am on Windows 10 Laptop.
I have a speaker connected to headphone out of the laptop.

In my Audacity Project, I start with two tracks

Track A: I have a Tanpura Drone
Track B: I have a Tabla Rhythm

On Track C I want to record a Song I am playing on my iPad instrument and feeding into
Audacity via Line In.

I want to hear Track A and Track B playing while I am recording my song on Track C.
But I do not want Track A and Track B audio to get recorded into Track C.

I just cannot get this to happen. The preference setting I am using is:

the preferences->recording-> Play Other Track While Recording (Overdub)

This seems to imply that Overdub will happen if Playing while recording is enabled.

How to get Playing without Overdubbing is my question.

Thanks Sri.

P.S. This gives me the freedom to mix the tracks differently as needed, while exporting the song

That is I do not want OVERDUBBING

What you have isn’t overdubbing. Overdubbing plays a clean backing track (typically drums or rhythm) into your headphones and records your voice clean, by itself on its own track.

What you have is a routing error, and it’s pretty common for people who like recording YouTube or internet sound.

We just need to find out where your error is. I need to drop for a while.


Hi folks, as the original poster, this conversation has been fascinating!

Fwiw, I set Audacity up as described in the first three posts.

I set the “Speakers” to my headphones. I put on my headphones, one ear on and the other off so I could still hear my voice.

I set the “Microphone” to my USB microphone.

I pressed Record, listened to the first track on my headphones, spoke into my microphone.

The recording did not have any of the first track on it, only what I entered with the microphone.

That is what is meant by the term: “overdubbing”.

That needs to be enabled.
You can also access it via:
“Transport menu > Transport options > Overdub” (should be ticked).

The option below it must be off (not ticked):
“Transport menu > Transport options > Software playthrough” (NOT ticked).

So in the “Device Toolbar” (Device Toolbar - Audacity Manual) set:
host = MME
Recording input = Line In.

There may be a problem with this setup.
How are you expecting to hear your iPad instrument while you play it? If the sound is routed through the computer, there will be a noticeable delay.


Thanks for all your attention/help.

There is something I am missing or amiss and I do not know what it is.

The new track I recorded includes the audio of the other tracks – I do not want that.
I am avoiding the use of “Over dubbing” just to avoid confusion.

Yes I have disabled software playthrough.

I also checked if by chance Audacity is listening to over the microphone (and not LINE IN) - which could also cause my issue. This is not the case.

So I am doing everything right, per what everyone has said here and based on my own understanding (which is quite in sync). But I cannot get the result I want.

But at least I know now and encouraged that it is not a Audacity limitation - just something wrong in my configuration. Will try to find what the issue is.

regards Sri.


As an aside…

I have my iPad feeding the audio IN of my PA600.
So the audio coming out of the keyboard and feeding Audacity has audio of iPad + whatever I play on the keyboard.

one ear on and the other off so I could still hear my voice.

That’s one way to do it. The other way is use a microphone or microphone system which will theatrically mix your live voice in real time with the backing track. Note you can’t (usually ) use the computer for this. The computer will always give you echoes and latency delay.

This pix is for illustration only. I wouldn’t use earbuds for good quality mixing, but that setup does work. No need to skip one earphone.


How do you hear that while playing? Does that have a separate output for monitoring?

If you generate an “Audio device info” file, and post it here, that may help us to see what the problem is.
See: Help Menu: Diagnostics - Audacity Manual

Also see:

You can’t see it, but the headphones are plugged into my UM2 microphone preamplifier (on the left). The UM2 will provide a theatrical mix of live sound and backing track without the backing leaking into the recording.

This picture is also a little Hollywood. When was the last time you saw a recording setup that didn’t look like an explosion in a cable factory?



Finally figured out what is going on.

There is a sentence in the documentation of Overdubbing I had missed.

To the effect

“… make sure you are able to hear external input while you are playing some track in Audacity…”

This precondition was not met in the Laptop I was using.

I checked this on a Third Laptop (bit older than the other two) and this condition was met and the issue I was facing vanished.

I am able to listen to tracks while recording a new track. The new track does not have the audio of other tracks.

Hope this is useful for someone else who may run into this issue.

Appreciate your help and your strong insistence that it should work.


P.S. Here is a sample to show the result, with no intention of publicizing the video.