Latency Correction Error

Hello all!

I desperately need some help! I recently bought a new computer with Windows 7 installed. I then downloaded the latest version of Audacity 2.0.4. I record voice only tracks from my microphone thru a Mobile Pre interface. Everything was working fine until yesterday when I opened the program and pushed record. The recording cursor did not move and then I got an error message that said:

“Latency correction setting has caused the recorded audio to be hidden before zero. Audacity has brought it back to start at zero. You may have to use the Time Shift Tool (or F5) to drag the track to the right place.”

I’m really not sure how to use the Time Shift Tool although I did try to click on it and drag it etc. to no avail. (I’m sure I’m not using the tool correctly!) I also tried closing the program, shutting down the computer, un-installing the program/re-installing the program (both 2.0.3 and 2.0.4 versions) etc. etc. Nothing seemed to work! Then I clicked on the Output device, Input Device and Input Channels dropdowns, changed them to another choice and then immediately changed them back to my preferred choice and then for some reason it worked! I have no idea why! But then when I opened the program again today, I started getting the same error message again and this time nothing seems to be fixing it! I previously had the beta version of Audacity on my old computer and never had this problem. I would so appreciate any help! I am not very technically gifted so you may have to “dumb up” any suggestions for me! Thanks in advance!

Try opening the Transport menu at the top of the window. Look for “Sound Activated Recording (on/off)”. You may find it is checked (ticked). If so, click on it to uncheck it then try recording again.


Hi Gale!

I checked to see if it was checked but it was off. Any other ideas??? I appreciate your help!

how to use the Time Shift Tool

Click on the Time Shift Tool (two sideways black arrows). When you then click on the blue waves in a sound track and push sideways, the music will become later in time. If you have some music sticking out before (to the left of) zero, that may cause Audacity to act funny and this may fix it.

Are you trying to overdub or sound-on-sound? It’s unusual for Audacity to complain about this unless you already have a sound track.

Audacity > Edit > Preferences > Recording.
Do your settings look like the illustration?

Screen shot 2013-10-11 at 5.36.42 PM.png

If you are not using Sound Activated Recording then the recording is stalling. You can just Edit > Undo the recording to save fiddling with Time Shift Tool.

Audacity may not start recording if the Audio to buffer in Koz’s picture is very low. Try making it 200 or 300 if it is already 100.

Does it record if you first select the Mobile Pre as input in Device Toolbar , like you did before?

Also make sure project rate bottom left is 44100 Hz and assuming you connect Mobile Pre to the computer with a USB cable, make sure the cable is tight and that you are connecting it into an empty USB port on the computer. You can’t share it with other USB devices connected to a hub all on one port.


Hi Gale!

I just wanted to thank you for all your help. After trying everything (to no avail), I finally unplugged the usb cable from the mobile pre and then re-plugged it in and all of a sudden it worked!!! Sheesh! Anyway, hopefully that was all it was! But again, thank you so much for your time and on-going suggestions - I truly appreciate it!

I had this same error and solved it by setting my recording and playback devices to the same device.